NEO(4) BSD Kernel Interfaces Manual NEO(4)NAME
neo -- NeoMagic MagicMedia 256 audio device driver
neo* at pci? dev ? function ?
audio* at audiobus?
The neo driver provides support for the NeoMagic MagicMedia 256AV and 256ZX AC'97 audio devices, found on many laptops.
The MagicMedia 256AV also comes in a variant (usually found on Dell and HP laptops) that works in Windows Sound System emulation mode, not in
AC'97 mode. That variant of the chip must be used with the wss(4) driver. The neo driver will not attach to such chips.
SEE ALSO ac97(4), audio(4), intro(4), midi(4), pci(4), wss(4)HISTORY
The neo device driver appeared in NetBSD 1.5.1.
The MagicMedia 256 series is not well-documented.
No MIDI or FM synthesizer capability is provided with the MagicMedia 256 in AC'97 mode. While those capabilities are provided by the Windows
driver for the chip, they are emulated by the Windows driver, and not directly supported by the hardware.
BSD June 22, 2005 BSD
Check Out this Related Man Page
WSS(4) BSD Kernel Interfaces Manual WSS(4)NAME
wss -- Windows Sound System hardware audio driver
wss0 at isa? port 0x530 irq 10 drq 0 drq2 1
wss0 at isa? port 0x530 irq 10 drq 0 flags 1
wss* at acpi?
wss* at isapnp?
wss* at pnpbios? index ?
audio* at audiobus?
opl* at wss?
The wss driver supports Microsoft's Windows Sound System, the MAD16 chip based hardware, and their clones.
The base I/O port is set by a jumper on the board; valid choices are 0x530, 0x604, 0xE80, or 0xF40. Both IRQ and DMA channels are software
programmable. The IRQ may be set to 7, 9, 10, or 11, and the DMA channel may be set to 0, 1, or 3.
The device flags must have bit 0 (value 1) set to enable the MAD16 support. This is to avoid potential conflicts with other devices when
probing the MAD16 because it requires use of extra I/O ports not in the base port range. Chips needing this flag include the OPTi 82C928,
82C929, 82C831, and the OAK OTI-601D. Setting bit 1 (value 2) in flags disables the joystick port on MAD16 hardware.
SEE ALSO acpi(4), audio(4), isa(4), isapnp(4), joy(4), opl(4), pnpbios(4)BSD June 22, 2005 BSD
11 More Discussions You Might Find Interesting
1. Post Here to Contact Site Administrators and Moderators
I read some of the messages(by neo and PTx) in your forum.I was looking for info on how to get started,and now I feel like this is more than I can handle.
Its not because I dont have the will to read and learn,but I dont know if I have the environment that will help me learn stuff at... (4 Replies)
I'm having a problemm with reading cdrw under red hat7.3, someone told me something about Juliette but i got no idea how to fix it. Linux generaly seems to have a problem with reading cdr burn under win. (5 Replies)
Might anyone know how to make a nbsp (160|0xA0) character? I am using a Dell Latitude D620 running Windows XP and then starting Exceed 9.0 defaulting to native window emulation for my X (us.kbf keymapping) (Latin-1 symbol set I believe) and calling an xterm (fontdefault, whatever that might be)... (1 Reply)
I'm looking for a recommended Laptop Hardware compatible list.
I know nowadays most distribs just work with most hardware but possibly a list of current laptops that don't work well with unix / Linux. (1 Reply)
Discussion started by: LaptopACPower
7. Post Here to Contact Site Administrators and Moderators
Hi Neo , I was searching for Unix Certifications on Google and got u r thread:
It was a gr8 read. Nice to know ur thoughts.. I m also a newbie to this Unix world and had a gr8 interst in it. I m learning shell scripting and other basics. Would... (2 Replies)
I have two files:
news.net xyz.com, telecom.net, highlands.net, software.com
example2.com earth.net, abc.gov.uk
file 2 are the search keys to search in file 1 if any of the search key is... (3 Replies)
thank's for your work on the mobile theme. I like it to be able to have a look to this site on my mobile now and then. I know responsive-Design-Area is another rather complex field of IT, which can be very painful(I dive into CSS/JS/HTML/RESPONSIVE/... in some rare occasions too - not... (1 Reply)
You work seriously hard to keep this site going, bringing it up to date and adding new stuff.
I think that you should have a "Hats Off" badge of honour in recognition of your hard work.
The code you have shared updating/upgrading the site is remarkable.
Bazza... (1 Reply)
I have just uploaded a new YT video with the goal of inspiring everyone to:
Be Inspired To Be The Best You Can Be
The Chronicles of Neo - The Revenge of the Nerds -Be Inspired To Be The Best You Can Be
In this raw, honest and casual 4K video, I begin a new... (2 Replies)