MKPASSWD(8) System Manager's Manual MKPASSWD(8)NAME
mkpasswd - generate hashed password table
mkpasswd [ -p ] passwdfile
Mkpasswd is used to generated the hashed password database used by the password library routines (see getpwent(3)).
The file passwdfile must be in password file format (see passwd(5)). Mkpasswd generates database files named ``passwdfile.pag'' and
``passwdfile.dir'' (see ndbm(3)). Data subsequently taken from the database files differ from passwdfile in one respect. Rather than
storing the encrypted password in the database, mkpasswd stores the offset of the encrypted password in passwdfile.
Mkpasswd exits zero on success, non-zero on failure.
The -p option causes mkpasswd to create ``passwdfile.orig'', a password file in the standard Version 7 format.
SEE ALSO chpass(1), passwd(1), getpwent(3), ndbm(3), passwd(5), vipw(8)4.3 Berkeley Distribution February 22, 1989 MKPASSWD(8)
Check Out this Related Man Page
MKPASSWD(1) Debian GNU/Linux MKPASSWD(1)NAME
mkpasswd - Overfeatured front end to crypt(3)SYNOPSIS
mkpasswd PASSWORD SALT
mkpasswd encrypts the given password with the crypt(3) libc function using the given salt.
OPTIONS -S, --salt=STRING
Use the STRING as salt. It must not contain prefixes such as $1$.
Use NUMBER rounds. This argument is ignored if the method choosen does not support variable rounds. For the OpenBSD Blowfish method
this is the logarithm of the number of rounds.
Compute the password using the TYPE method. If TYPE is help then the available methods are printed.
Read the password from file descriptor NUM instead of using getpass(3). If the file descriptor is not connected to a tty then no
other message than the hashed password is printed on stdout.
A list of options which will be evalued before the ones specified on the command line.
If the --stdin option is used, passwords containing some control characters may not be read correctly.
This programs suffers of a bad case of featuritis.
SEE ALSO passwd(1), passwd(5), crypt(3), getpass(3)AUTHOR
mkpasswd and this man page were written by Marco d'Itri <firstname.lastname@example.org> and are licensed under the terms of the GNU General Public License,
version 2 or higher.
Marco d'Itri 21 March 2008 MKPASSWD(1)
I'm trying to run phpBB2 software on Apache2, all was fine with setups except I had no password protecting my database.
After researching how to do it, I attempted to set password "freddy" to root (for obvious reasons "freddy" isn't the actual pw I used).
I now can't login to MYSQL4 using... (1 Reply)
Actually in my application there is an XML file. The password and the user name for the database that I need to access the development box is stored there.
But using some UNIX command I am able to access the raw content of the file and not the decrypted code for that password. When I am applying... (3 Replies)
I have a mysql database on the server where I have root access also to phpmyadmin.
I have such a database 1, which is a table users where a user named admin.
How shall be observed as the password for this user? (1 Reply)
I'm new to C++.
I have a text file named idpw.txt which is storing id and password
Here's my code so far:
string user,password, user1, password1;
cout << "Please enter your username" <<... (3 Replies)
I am looking for a command or script which should list out the files that uses database password 'June1232011'.
I know where the files are located (path) .Since there are too many files exist in the directory, i want to find out the files that uses this password.
It would be a... (10 Replies)
hello all, i am trying to find a better to do what i am doing right now...
i have a file called sidlist...which has my database_name and password to the respective database
so something like below.. file is called sidlist and entry is below...
pss, abcd1234... (5 Replies)
I created a gnupg password which I later forgot clumsy enough (after a holiday). I can always create a new one but unfortunately I have some files on the computer that I encrypted with it and would like to access it. I remember parts of the password and was wondering what's the the best way to... (0 Replies)
i have the accessibility to cat the /et/passwd file
in this file we see the paassword field but the password is in encrypted form
So, it can be possible to get the password encrypted string to convert it into human readable string via some md5 encryption code mechanism etc..
... (6 Replies)
I have a password reset expect script which stores all the op to an file. I need to check the whether password is successfully changed by greping out the file and storing the o/p to a variable.
But we try to print the variable , its shows only the command instead of its o/p.
... (2 Replies)
I need help in creating script for "User password reset in database" by logging into database from linux server and resetting the user password.
Could you please provide the script for this task?
Steps are given below.
1. Login into database from server
sqlplus... (5 Replies)