Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

imp(4p) [bsd man page]

IMP(4P) 																   IMP(4P)

NAME
imp - IMP raw socket interface SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> #include <netimp/if_imp.h> s = socket(AF_IMPLINK, SOCK_RAW, proto); DESCRIPTION
The raw imp socket provides direct access to the imp(4) network interface. Users send packets through the interface using the send(2) calls, and receive packets with the recv(2), calls. All outgoing packets must have an 1822 96-bit leader on the front. Likewise, packets received by the user will have this leader on the front. The 1822 leader and the legal values for the various fields are defined in the include file <netimp/if_imp.h>. The raw imp interface automatically installs the length and destination address in the 1822 leader of all outgoing packets; these need not be filled in by the user. If the protocol selected, proto, is zero, the socket will receive all IMP messages except RFNM and incompletes which are not input data for a kernel protocol. If proto is non-zero, only messages for the specified link type will be received. DIAGNOSTICS
An operation on a socket may fail with one of the following errors: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [ENOBUFS] eight messages to the destination host are outstanding, and another eight are already queued for output; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists. SEE ALSO
intro(4N), inet(4F), imp(4) 4.2 Berkeley Distribution May 16, 1986 IMP(4P)

Check Out this Related Man Page

UDP(4)							   BSD Kernel Interfaces Manual 						    UDP(4)

NAME
udp -- Internet User Datagram Protocol SYNOPSIS
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_DGRAM, 0); DESCRIPTION
UDP is a simple, unreliable datagram protocol which is used to support the SOCK_DGRAM abstraction for the Internet protocol family. UDP sockets are connectionless, and are normally used with the sendto and recvfrom calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). UDP address formats are identical to those used by TCP. In particular UDP provides a port identifier in addition to the normal Internet address format. Note that the UDP port space is separate from the TCP port space (i.e. a UDP port may not be ``connected'' to a TCP port). In addition broadcast packets may be sent (assuming the underlying network supports this) by using a reserved ``broadcast address''; this address is network interface dependent. Options at the IP transport level may be used with UDP; see ip(4). DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a port which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists. SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), intro(4), inet(4), ip(4) HISTORY
The udp protocol appeared in 4.2BSD. 4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution
Man Page