HT(4) Kernel Interfaces Manual HT(4)NAME
ht - TM-03/TE-16,TU-45,TU-77 MASSBUS magtape interface
NHT ht_drives # TE16, TU45, TU77
#Name Unit# Addr Vector Br Handler(s) # Comments
ht ? 172440 224 5 htintr # tu 16 massbus tape
major device number(s):
minor device encoding:
bits 0003 specify HT drive
bit 0004 specifies no-rewind operation
bit 0010 specifies 1600BPI recording density instead of 800BPI
The tm-03/transport combination provides a standard tape drive interface as described in mtio(4). All drives provide both 800 and 1600
bpi; the TE-16 runs at 45 ips, the TU-45 at 75 ips, while the TU-77 runs at 125 ips and autoloads tapes.
/dev/MAKEDEV script to create special files
/dev/MAKEDEV.local script to localize special files
SEE ALSO mt(1), tar(1), tp(1), mtio(4), tm(4), ts(4), dtab(5), autoconfig(8)DIAGNOSTICS
tu%d: no write ring. An attempt was made to write on the tape drive when no write ring was present; this message is written on the termi-
nal of the user who tried to access the tape.
tu%d: not online. An attempt was made to access the tape while it was offline; this message is written on the terminal of the user who
tried to access the tape.
tu%d: can't change density in mid-tape. An attempt was made to write on a tape at a different density than is already recorded on the
tape. This message is written on the terminal of the user who tried to switch the density.
tu%d: hard error bn%d er=%b ds=%b. A tape error occurred at block bn; the ht error register and drive status register are printed in
octal with the bits symbolically decoded. Any error is fatal on non-raw tape; when possible the driver will have retried the operation
which failed several times before reporting the error.
If any non-data error is encountered on non-raw tape, it refuses to do anything more until closed.
The system should remember which controlling terminal has the tape drive open and write error messages to that terminal rather than on the
3rd Berkeley Distribution January 28, 1988 HT(4)
Check Out this Related Man Page
MTIO(4) BSD Kernel Interfaces Manual MTIO(4)NAME
mtio -- generic magnetic tape I/O interface
Magnetic tape has been the computer system backup and data transfer medium of choice for decades, because it has historically been cheaper in
cost per bit stored, and the formats have been designed for portability and storage. However, tape drives have generally been the slowest
mass storage devices attached to any computer system.
Magnetic tape comes in a wide variety of formats, from classic 9-track, through various Quarter Inch Cartridge (QIC) variants, to more modern
systems using 8mm video tape, and Digital Audio Tape (DAT). There have also been a variety of proprietary tape systems, including DECtape,
and IBM 3480.
UNIX TAPE I/O
Regardless of the specific characteristics of the particular tape transport mechanism (tape drive), UNIX tape I/O has two interfaces: "block"
and "raw". I/O through the block interface of a tape device is similar to I/O through the block special device for a disk driver: the indi-
vidual read(2) and write(2) calls can be done in any amount of bytes, but all data is buffered through the system buffer cache, and I/O to
the device is done in 1024 byte sized blocks. This limitation is sufficiently restrictive that the block interface to tape devices is rarely
The "raw" interface differs in that all I/O can be done in arbitrary sized blocks, within the limitations for the specific device and device
driver, and all I/O is synchronous. This is the most flexible interface, but since there is very little that is handled automatically by the
kernel, user programs must implement specific magnetic tape handling routines, which puts the onus of correctness on the application program-
DEVICE NAME CONVENTIONS
Each magnetic tape subsystem has a couple of special devices associated with it.
The block device is usually named for the driver, e.g. /dev/st0 for unit zero of a st(4) SCSI tape drive.
The raw device name is the block device name with an "r" prepended, e.g. /dev/rst0.
By default, the tape driver will rewind the tape drive when the device is closed. To make it possible for multiple program invocations to
sequentially write multiple files on the same tape, a "no rewind on close" device is provided, denoted by the letter "n" prepended to the
name of the device, e.g. /dev/nst0, /dev/nrst0.
The mt(1) command can be used to explicitly rewind, or otherwise position a tape at a particular point with the no-rewind device.
FILE MARK HANDLING
Two end-of-file (EOF) markers mark the end of a tape (EOT), and one end-of-file marker marks the end of a tape file.
By default, the tape driver will write two End Of File (EOF) marks and rewind the tape when the device is closed after the last write.
If the tape is not to be rewound it is positioned with the head in between the two tape marks, where the next write will over write the sec-
ond end-of-file marker.
All of the magnetic tape devices may be manipulated with the mt(1) command.
A number of ioctl(2) operations are available on raw magnetic tape. Please see <sys/mtio.h> for their definitions.
The manual pages for specific tape device drivers should list their particular capabilities and limitations.
SEE ALSO dd(1), mt(1), pax(1), tar(1), st(4), wt(4)HISTORY
The mtio manual appeared in 4.2BSD.
The status should be returned in a device independent format.
If and when NetBSD is updated to deal with non-512 byte per sector disk media through the system buffer cache, perhaps a more sane tape
interface can be implemented.
BSD January 14, 1999 BSD