how to write this script?


 
Thread Tools Search this Thread
Operating Systems AIX how to write this script?
# 1  
Old 09-03-2009
how to write this script?

If I need delete some disk,

Code:
for i in hdisk1 hdisk2 hdisk3 hdisk4
do 
rmdev -dl $i
done

if I have more than 100 hdisks, how to write a script like that to delete them?

Last edited by vgersh99; 09-03-2009 at 11:49 AM.. Reason: code tags, PLEASE!
# 2  
Old 09-03-2009
To keep the forums high quality for all users, please take the time to format your posts correctly.

First of all, use Code Tags when you post any code or data samples so others can easily read your code. You can easily do this by highlighting your code and then clicking on the # in the editing menu. (You can also type code tags [code] and [/code] by hand.)

Second, avoid adding color or different fonts and font size to your posts. Selective use of color to highlight a single word or phrase can be useful at times, but using color, in general, makes the forums harder to read, especially bright colors like red.

Third, be careful when you cut-and-paste, edit any odd characters and make sure all links are working property.

Thank You.

The UNIX and Linux Forums

---------- Post updated at 10:51 AM ---------- Previous update was at 10:49 AM ----------

create a file myDisks.txt with one disk name per line.
Code:
#!/bin/ksh
while read disk
do
  rmdev -dl "${disk}"
done < /path/to/myDisk.txt


Last edited by vgersh99; 09-03-2009 at 01:26 PM.. Reason: forgot 'do' - fixed
# 3  
Old 09-03-2009
Thank you,

However, it shows this error:

0403-057 Syntax error at line 4 : `done' is not expected.
# 4  
Old 09-03-2009
because vgersh99 just forgot the "do" before the rmdev instruction...
# 5  
Old 09-03-2009
Quote:
Originally Posted by vbe
because vgersh99 just forgot the "do" before the rmdev instruction...
ooops - thanks vbe - fixed the post.
# 6  
Old 09-03-2009
Thank you all!
# 7  
Old 09-03-2009
Since I assume you dont want to remove your rootvg disks, try

Code:
for i in $(lspv| awk '!/rootvg/ {print $1}') ; do rmdev -dl $i ; done

Rgds
zxmaus
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Please help me to write the script

Hi All, I have written the follwing script to take the backup of the file every day along with the date. DATE=`date +%Y%m%d` export DATE cp var/hr/hr333m.txt cp var/hr/payments/hr333m_$DATE.txt The file name as follows after taking the backup. hr333m_20110630.txt Could you... (3 Replies)
Discussion started by: ajaykumarkona
3 Replies

2. IP Networking

read/write,write/write lock with smbclient fails

Hi, We have smb client running on two of the linux boxes and smb server on another linux system. During a backup operation which uses smb, read of a file was allowed while write to the same file was going on.Also simultaneous writes to the same file were allowed.Following are the settings in the... (1 Reply)
Discussion started by: swatidas11
1 Replies

3. Shell Programming and Scripting

Q: How to write this script?

Hi there :rolleyes: I have a folder called backup it is path is: ~/backup Inside this folder, there are four files: ~/backup/test1.cpp ~/backup/test2.cpp ~/backup/test3.cpp ~/backup/PATHS.TXT The fourth file PATHS.TXT contains the original paths for the three files. This is the... (4 Replies)
Discussion started by: domain
4 Replies

4. Shell Programming and Scripting

Script Help - Another Way To Write This

I am adapting an Open Step ping server script to Ubuntu 8.10 and one section of my script isn't working # if there are servers that just went down or came back up, notify # with high importance if ; then echo notifying of servers that are up again or just now down notify high # if there... (2 Replies)
Discussion started by: gbxfan
2 Replies

5. Shell Programming and Scripting

Better way to write this script

Hi All, I have written the following script. I have just repeated some commands, and I am sure there is a more better way to do it. I hope I one of gurus here will help me make it in a better shape. Here is the script: #! /bin/sh sed -i -e "s/test2.xxx/test3.xxx/" -e "s/output2/output3/"... (2 Replies)
Discussion started by: faizlo
2 Replies

6. UNIX for Dummies Questions & Answers

Should I write a PERL Script or Shell Script?

Hello, I have done some BASIC shell scripting/PERL scripting before so I am familiar with the languages. I am not really sure which one would lend itself better to the application I have to write. I am required to scan the message logs for possible break in attempts. If I use shell scripting... (2 Replies)
Discussion started by: mojoman
2 Replies

7. Shell Programming and Scripting

Please write this script for me

UNIX shell script (Bourne shell syntax) called admin_script. This script is described below as a usage summary: admin_script Note: if no options are specified, a menu is displayed which allows users to perform one of the following tasks and then exit. If incorrect options are provided,... (1 Reply)
Discussion started by: nadman123
1 Replies

8. Shell Programming and Scripting

Help me to write the script

Actually i am working with two diffrent files having same structure each file contain Ten diffrent column and i want to write a script which will compare the colummns of first file with the column of second file and diiference will be send to the first column of third file . similarly for... (5 Replies)
Discussion started by: gyana_cboy
5 Replies

9. AIX

How to write script for this ?

Hi All, I want to read username and lastupdate only from /etc/security/passwd and write the same data to another file: The data in /etc/security/passwd will be in this form for example: For more details : http://www.unet.univie.ac.at/aix/files/aixfiles/passwd_security.htm#A1219924 smith:... (0 Replies)
Discussion started by: me_haroon
0 Replies

10. Shell Programming and Scripting

Help! Need to write my first script

Hi Folks! I am a MacUser and am trying to learn Unix for the last few months. I will explain in detail what I am trying to do, and apreciate you help if you can teach me even if it is a single comand line inside the script. I own a small company, where I manufacture special gypsums and... (5 Replies)
Discussion started by: fundidor
5 Replies
Login or Register to Ask a Question