Sponsored Content
Operating Systems AIX Need help with mksysb backup on a DVD Post 302493239 by rbatte1 on Wednesday 2nd of February 2011 08:01:07 AM
Old 02-02-2011
I fear that is correct saikiran_1984. I hit this myself a year ago when I was given a 9115-505 (p505) to set up for a client. It had a DVD-ROM (Read-Only) and so I refused until a DVD-RAM was installed. They are a few hundred pounds sterling, probably less than 1,000 US dollars.

The process I write the DVD with is a little convoluted, but I have a filesystem outside of rootvg that I create a file using the normal mksysb:-
Code:
mksysb -e /mksysbfs/mksysb.file

I then use the next command to actually write the removable media:-
Code:
mkdvd -d /dev/cd0 -m /mksysbfs/mksysb.file

Before actually running the mksysb to disk file, I also do the following:-
Code:
mkszfile                       #- recreate lv/fs information for rootvg
rm /disaster/*.pvlist 2>/dev/null

lspv|while read pv serial vg status
do
        echo "$pv \c" >>/disaster/$vg.pvlist
        echo "$pv $vg                               \r\c"
        echo "$pv $vg" >> $log
        sleep 1
done

for vg in `lsvg|sort|grep -v rootvg`
do
        echo "\nSaving $vg structure"
        lsvg -l $vg > /disaster/$vg.lsvg-l
        echo "restvg -q -f /disaster/$vg.structure `cat /disaster/$vg.pvlist`" >>/disaster/restvg_commands
        echo "^\./" > /etc/exclude.$vg               # Ignore all the files
        savevg -ef /disaster/$vg.structure $vg
        if [ $? -ne 0 ]
        then
                echo "Failed to save $vg structure\n\nExiting"
                exit 2
        fi
done

Now, /disaster is a very small filesystem in rootvg, just 1PP and it holds these files so after a mksysb restore, I can run the commands in restvg_commands and it will build all the other volume groups, logical volumes, filesystems and mount them.

As a word of warning, this only really works if you have an identical machine to restore to (same hdisk numbers and sizes) but at least the structure information is there for you to work with too. I am working on a version that removes any mirrors in case you have a live machine with simple disks and a restore server with RAID or some other form of hardware protection.


Of course, if rootvg is what is corrupt and you are restoring over the original machine, you should be able to import the volume groups with importvg and they should recover with the original data.


I hope that this is useful. Testing something like this is very important. have you got DR hardware organised? There are many companies that will lend you hardware when you need it for an annual fee of about 10% of the base cost. It releives you of hardware headaches from having a second server at a second site and making sure no-one decides to use it for something else!

Let me know if you want a few names to get started with.




Robin
Liverpool/Blackburn
UK
 

10 More Discussions You Might Find Interesting

1. AIX

mksysb backup

How I can to obtain a full Backup of a AIX server with the command "mksysb"?? what is the correct form? Thanks (1 Reply)
Discussion started by: granador
1 Replies

2. AIX

mksysb backup testing

Hi All i have a number of IBM servers with different models, and i want to do a backup for the rootvg using mksysb and that backup will be stored on a 4mm DDS tape. i have only one machine (p550) which i can use it for testing purposes, so the quesion is that can i test my mksysb backups on... (6 Replies)
Discussion started by: TheEngineer
6 Replies

3. AIX

mksysb backup

hi guys, i just want to take my server's mksysb backup through dvd-rom.but am having the doubt that, while am taking the mksysb backup in image it shows 8GB. So can i confirm that it takes 2 dvds and after writing in 1st cd it will ask for 2nd cd?????? please help me out. (1 Reply)
Discussion started by: rrlog
1 Replies

4. AIX

How to restore from mksysb backup

system is not booting ... i want to restore from mksysb backup. (2 Replies)
Discussion started by: AIXlearner
2 Replies

5. AIX

Need to take MKSYSB backup

Hi, Can any one suggest me how to take the mksysb backup in CD (VCD/DVD). I have tried like #mkcd -d /dev/cd0, but its not working. (3 Replies)
Discussion started by: oprakash
3 Replies

6. AIX

mksysb backup

hi we are having one rootvg in that we created one lv named mksysb_backuplv and normally script will run accordingly to take the backup in the cron,here i just want to know if any rootfilesystem was correpted like /usr or /tmp ,then how could i restore the particular filesystme from the... (1 Reply)
Discussion started by: senmak
1 Replies

7. AIX

MKSYSB backup

Hi, Currently we are taking mksysb backup through smitty mksysb command and directing the backup to happen on a tape.We have inbuilt tape drives in the AIX servers. Can we take the mksysb backup through 3rd party software tool (Symantec netbackup of IBm TSM). If yes what is the procedure and... (4 Replies)
Discussion started by: dwiravi
4 Replies

8. AIX

No response when inserting mksysb backup DVD #3

Hello AIXians, I have a corrupted file systems in my AIX server (6.1), which are /var, /home & /opt. I tried many times to fix them using fsck but it gives me: 'Fatal I/O error'. So I decided to restore them from bootable mksysb DVD (4 DVDs) after booting from these DVDs. Every thing was... (0 Replies)
Discussion started by: Mohannad
0 Replies

9. AIX

Using mkdvd to create bootable mksysb on dvd reports success but nothing on dvd?

Hello, Running AIX 7.1 7100-00-03-1115, trying to make a mksysb image to a dvd drive using mkdvd. My final command looks like this.. mkdvd -e -V rootvg -R -C /usr1/AIXADMIN/mkcd/cd_fs -I /usr1/AIXADMIN/mkcd/cd_images -M /usr1/AIXADMIN/mkcd/mksysbimage -d /dev/cd0 -Y When i run this... (3 Replies)
Discussion started by: c3rb3rus
3 Replies

10. AIX

Can I use mkdvd to create bootable DVD from mksysb on tape

Hi, Is it possible to use mkdvd to create a bootable DVD using a mksysb on tape as the source image? On the system concerned, we don't have enough free space to create the mksysb to file first, so would like to use the existing tape mksysb backup. The DVD disk/s will then be used to boot a... (4 Replies)
Discussion started by: alanp36
4 Replies
dvdbackup(1)						      General Commands Manual						      dvdbackup(1)

NAME
dvdbackup - Tool to backup DVDs SYNOPSIS
dvdbackup [OPTION]... DESCRIPTION
This manual page documents briefly the dvdbackup command. This manual page was written for the Debian distribution because the original program does not have a manual page. dvdbackup is a tool to extract data from video DVDs. It has the advantages of being small, fast, and easy to use. OPTIONS
A summary of options is included below. -h, --help print a brief usage message -V, --version print version information -I, --info for information about the DVD -M, --mirror backup the whole DVD -F, --feature backup the main feature of the DVD -T X, --titleset=X backup title set X -t X, --title=X backup title X -s X, --start=X backup from chapter X -e X, --end=X backup to chapter X -i DEVICE, --input=DEVICE where DEVICE is your DVD device. This switch only needs to be used if your DVD device node is not /dev/dvd -o DIRECTORY, --output=DIRECTORY where DIRECTORY is your backup target. If not given, the current working directory will be used. -v, --verbose print more information about progress -n NAME, --name=NAME (optional) set the title - useful if autodetection fails -a 0, --aspect=0 to get aspect ratio 4:3 instead of 16:9 if both are present -r {a,b,m}, --error={a,b,m} select read error handling: a=abort, b=skip block, m=skip multiple blocks (default) -p, --progress print progress information while copying VOBs Option notes -a is option to the -F switch and has no effect on other options -s and -e should preferably be used together with -t General backup information If your backup directory is /my/dvd/backup/dir/ specified with the -o flag, then dvdbackup will create a DVD-Video structure under /my/dvd/backup/dir/TITLE_NAME/VIDEO_TS. If the -o flag is omitted, the current directory is used. Since the title is "unique" you can use the same directory for all your DVD backups. If it happens to have a generic title dvdbackup will exit with a return value of 2, and you will need to specify a title name with the -n switch. dvdbackup will always mimic the original DVD-Video structure. Hence if you e.g. use the -M (mirror) you will get an exact duplicate of the original. This means that every file will have the same size as the original one. Likewise also for the -F and the -T switch. However the -t and (-t -s/-e) switch is a bit different the titles sectors will be written to the original file but not at the same offset as the original one since there may be gaps in the cell structure that we do not fill. EXAMPLES
dvdbackup -I gathers information about the DVD. /dev/dvd is the default device tried - you need to use -i if your device name is different. dvdbackup -M backups the whole DVD. This action creates a valid DVD-Video structure that can be burned to a DVD-/+R(W) with help of genisoimage. dvdbackup -F backups the main feature of the DVD. This action creates a valid DVD-Video structure of the feature title set. Note that this will not result in an image immediately watchable - you will need another program like dvdauthor to help construct the IFO files. dvdbackup defaults to get the 16:9 version of the main feature if a 4:3 is also present on the DVD. To get the 4:3 version use -a 0. dvdbackup makes it best to make a intelligent guess what is the main feature of the DVD - in case it fails please send a bug report. dvdbackup -T 2 backups the title set 2 i.e. all VTS_02_X.XXX files. This action creates a valid DVD-Video structure of the specified title set. Note that this will not result in an image immediately watchable - you will need another program like dvdauthor to help construct the IFO files. dvdbackup -t 1 backups the title 1. This action backups all cells that forms the specified title. Note that there can be sector gaps in between one cell and another. dvdbackup will backup all sectors that belongs to the title but will skip sectors that are not a part of the title. dvdbackup -t 1 -s 20 -e 25 This action will backup chapter 20 to 25 in title 1, as with the backup of a title there can be sector gaps between one chapter (cell) and on other. dvdbackup will backup all sectors that belongs to the title 1 chapter 20 to 25 but will skip sectors that are not a part of the title 1 chapter 20 to 25. To backup a single chapter e.g. chapter 20 do -s 20 -e 20. To backup from chapter 20 to the end chapter use only -s 20. To backup to chapter 20 from the first chapter use only -e 20. You can skip the -t switch and let the program guess the title although it is not recommended. If you specify a chapter that is higher than the last chapter of the title dvdbackup will truncate to the highest chapter of the title. EXIT STATUS
0 on success 1 on usage error 2 on title name error -1 on failure AUTHORS
dvdbackup was written by Olaf Beck <olaf_sc@yahoo.com>, but is now maintained by Benjamin Drung <benjamin.drung@gmail.com> and Stephen Gran <sgran@debian.org>. This manual page was written by Stephen Gran <sgran@debian.org>. 0.2 2008-03-18 dvdbackup(1)
All times are GMT -4. The time now is 07:17 AM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy