Sponsored Content
Full Discussion: Data restoration
Operating Systems AIX Data restoration Post 302477026 by bakunin on Friday 3rd of December 2010 05:23:11 AM
Old 12-03-2010
You will need a suitable tape drive, like a 3490 tape library for instance. Connect this to your system, run

Code:
# cfgmgr
 <...some output...>

# lsdev -C | grep "rmt"

and you will see one (or several) devices, "rmt0" (, "rmt1", ...) etc..

Use - depending on what was used to write to the tape - standard "tar" or "dd" with "/dev/rmt<n>" as input device (or whatever else is able to read your format) to read from it and "tctl [-f <device>]" to control the tape operation.

For instance, to rewind and eject the tape loaded in "/dev/rmt1":

Code:
# tctl -f /dev/rmt1 rewoffl

or, read the third file on the tape with tar:

Code:
# tctl -f /dev/rmt0.1 fsf2 ; tar -xvf /devb/rmt0.1

I hope this helps.

bakunin
 

10 More Discussions You Might Find Interesting

1. Solaris

Can before and after snapshots be used to verify successful filesystem restoration?

Hello Guys, Can before and after snapshots be used to verify successful filesystem restoration? snapshots will be created using fssnaps and restoration is thru legato restore? Any ideas on this? or any other ways I could verify that restoration is good? Regards (0 Replies)
Discussion started by: MarkyBoy
0 Replies

2. Shell Programming and Scripting

Restoration issue

Dear All, I am using sun OS server and performing weekly backup on a tape DDS2 for log files for the past 7 days, the log file sizes are ranging between 1 - 2 G......When i want to restore a specific file from the tape, i have to restore the whole files from the tape by using the command (tar... (1 Reply)
Discussion started by: charbel
1 Replies

3. Solaris

restoration

i have 2 hardisk. Hardisk A and Hardisk B. i have backup the oracle folder from hardisk A to hardisk B c0t0d0s4/oracle. If i want to restore , what is the command and what do i need to do ? urgent help needed. Thanks for your quick reply . (1 Reply)
Discussion started by: Farbegas
1 Replies

4. UNIX for Dummies Questions & Answers

LTO multivolume restoration problem in SELS9

Can anybody help me ? ? Previously data was taken multi volume LTO Tape backup in Red hat Linux by following command : tar -cvf /dev/rmt/tps6d7v -b 1000 -M filenames , now i try to Restore it in SELS9 by following command : tar -xvf /dev/st1 -b 1000 -M filenames , it extracts only part of the... (0 Replies)
Discussion started by: pramanik
0 Replies

5. AIX

mksysb restoration steps

please provide me with the steps to restore from mksysb tape. i m using AIX 5.3 TL 7 (2 Replies)
Discussion started by: debasis9
2 Replies

6. AIX

mksysb restoration using NIM

Hi, I just want to ask whether anyone has experience on restoring mksysb backup in NIM. We have taken the mksysb backup and the SPOT has been configured on NIM also. I just want to know the checkpoints before doing this. Is there any checkpoints we need to do? Do we need to unmirrorvg? This... (12 Replies)
Discussion started by: depam
12 Replies

7. Solaris

question about restoration from backup tape (solaris 10)

I am trying to restore opt on my server. my issue is, all the partitions are saved into the same back up tape. what is the exact command to just restore /opt for example, supposing c0t0d0s7 is the partition for /opt ---------- Post updated at 01:16 PM ---------- Previous update was at... (7 Replies)
Discussion started by: feg
7 Replies

8. Shell Programming and Scripting

MySQL Restoration Backup Script

Hi there, Alright I have this line that I'm working with (bash programming): mysql -u username -pHASH ${args} < /home/site/backups/site.${args}.sql I get this error on that line: ./restore.sh: line 51: syntax error near unexpected token `newline' ./restore.sh: line 51: `mysql -u... (5 Replies)
Discussion started by: Pandoula
5 Replies

9. Solaris

Error after systeme restoration

Rebooting with command: boot Boot device: /pci@1e,600000/pci@0/pci@a/pci@0/pci@8/scsi@1/disk@0,0:a File and args: SunOS Release 5.10 Version Generic_147440-01 64-bit Copyright (c) 1983, 2011, Oracle and/or its affiliates. All rights reserved. WARNING: system call missing from bind file... (8 Replies)
Discussion started by: andersonedouard
8 Replies

10. AIX

Mksysb restoration

Hi, I am an newbie to AIX. Recently, I being assigned to do an mksysb restoration at our DR site. It always encounter "Out of Space" during restoration, this is even when I restored to 4x146GB HDD. Even though, on production, it only need 2x146GB HDD for the rootvg. What is the problem, I... (19 Replies)
Discussion started by: AIXBlueCat
19 Replies
BACKUP_DELHOST(8)					       AFS Command Reference						 BACKUP_DELHOST(8)

NAME
backup_delhost - Deletes a Tape Coordinator entry from the Backup Database SYNOPSIS
backup delhost -tapehost <tape machine name> [-portoffset <TC port offset>] [-localauth] [-cell <cell name>] [-help] backup delh -t <tape machine name> [-p <TC port offset>] [-l] [-c <cell name>] [-h] DESCRIPTION
The backup delhost command deletes the indicated Tape Coordinator entry from the Backup Database. It is then impossible to submit backup operations to that Tape Coordinator, even if it is still running. To keep configuration information consistent, also remove the corresponding entry from the /var/lib/openafs/backup/tapeconfig file on the Tape Coordinator machine. To list the Tape Coordinator machines and port offsets defined in the Backup Database, issue the backup listhosts command. OPTIONS
-tapehost <tape machine name> Specifies the hostname of the machine housing the Tape Coordinator to delete. -portoffset <TC port offset> Specifies the port offset number of the Tape Coordinator to delete. If omitted, it defaults to 0. If provided, it is an integer between 0 (zero) and 58510, and must match the port offset number assigned to the same combination of Tape Coordinator and tape device or file in the /var/lib/openafs/backup/tapeconfig file on the Tape Coordinator machine indicated by the -tapehost argument. -localauth Constructs a server ticket using a key from the local /etc/openafs/server/KeyFile file. The backup command interpreter presents it to the Backup Server, Volume Server and VL Server during mutual authentication. Do not combine this flag with the -cell argument. For more details, see backup(8). -cell <cell name> Names the cell in which to run the command. Do not combine this argument with the -localauth flag. For more details, see backup(8). -help Prints the online help for this command. All other valid options are ignored. EXAMPLES
The following command deletes the Backup Database entry for the Tape Coordinator with port offset 2 on the Tape Coordinator machine "backup3.abc.com": % backup delhost -tapehost backup3.abc.com -portoffset 2 PRIVILEGE REQUIRED
The issuer must be listed in the /etc/openafs/server/UserList file on every machine where the Backup Server is running, or must be logged onto a server machine as the local superuser "root" if the -localauth flag is included. SEE ALSO
backup(8), backup_addhost(8), backup_listhosts(8) COPYRIGHT
IBM Corporation 2000. <http://www.ibm.com/> All Rights Reserved. This documentation is covered by the IBM Public License Version 1.0. It was converted from HTML to POD by software written by Chas Williams and Russ Allbery, based on work by Alf Wachsmann and Elizabeth Cassell. OpenAFS 2012-03-26 BACKUP_DELHOST(8)
All times are GMT -4. The time now is 04:30 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy