Sponsored Content
Full Discussion: MKSYSB backup
Operating Systems AIX MKSYSB backup Post 302422496 by kah00na on Tuesday 18th of May 2010 02:37:39 PM
Old 05-18-2010
Our NIM server has a filesystem named /export/mksysb just to hold mksysb images. We use to have the client LPARs NFS mount this filesystem and create their backups there, but with AIX 6.1 TL5, the NIM server doesn't like it when there is already a /export/mksysb entry in the /etc/exports that he didn't put there. Now, we have our NIM server tell the clients to create their mksysb's to the same /export/mksysb filesystem on our NIM server. The difference is that the backups are being handled by our NIM server and it maintains the entries in the /etc/exports file. These are the NIM commands that we use:

First remove the old mksysb resource and file to create enough space for a new mksysb:
Code:
nim -o remove -a rm_image=yes lpar01_mksysb

Create a new mksysb file and NIM resource:
Code:
nim     -o define \
        -t mksysb \
        -a server=master \
        -a location=/export/mksysb/lpar01 \
        -a source=lpar01 \
        -a mk_image=yes \
        -a mksysb_flags=iXp \
        -a comments="lpar01_mksysb_AIX$(oslevel -r)_defined$(date +%Y/%m/%d)" \
        lpar01_mksysb

Also, the NIM server doesn't like to make 2 mksysbs going on at the same time because it may not complete correctly due to limited amount of space in the /exports/mksysb filesystem. This can be over riden by adding the "-F" option to the first part like this:

Code:
nim     -Fo define \ ...

 

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

AIX + backup or mksysb (yes i did a search)

Whats up guys. I dont ask many questions but this time i need a quick one answerd. NOS: AIX 4.3.3 and 4.3.2 BOX: RS/6000 F50 i have 12 pv's (mirrored) and 2 vg's and i want them both backed up @ once on one tape drive so i can do it via cron. I have looked at mksysb and backup. my main... (5 Replies)
Discussion started by: Optimus_P
5 Replies

2. AIX

mksysb backup

How I can to obtain a full Backup of a AIX server with the command "mksysb"?? what is the correct form? Thanks (1 Reply)
Discussion started by: granador
1 Replies

3. AIX

mksysb backup testing

Hi All i have a number of IBM servers with different models, and i want to do a backup for the rootvg using mksysb and that backup will be stored on a 4mm DDS tape. i have only one machine (p550) which i can use it for testing purposes, so the quesion is that can i test my mksysb backups on... (6 Replies)
Discussion started by: TheEngineer
6 Replies

4. AIX

mksysb backup

hi guys, i just want to take my server's mksysb backup through dvd-rom.but am having the doubt that, while am taking the mksysb backup in image it shows 8GB. So can i confirm that it takes 2 dvds and after writing in 1st cd it will ask for 2nd cd?????? please help me out. (1 Reply)
Discussion started by: rrlog
1 Replies

5. AIX

Question about restoring from mksysb backup

Hello, Last night I applied a DB2 fix pack which is now causing problems with the application that uses db2. Prior to applying the fix pack I did a mksysb(rootvg) which includes the file system that has db2 installed on it. If I do a restore from this will it restore the db2 version back to... (1 Reply)
Discussion started by: jyoung
1 Replies

6. AIX

How to restore from mksysb backup

system is not booting ... i want to restore from mksysb backup. (2 Replies)
Discussion started by: AIXlearner
2 Replies

7. AIX

Need to take MKSYSB backup

Hi, Can any one suggest me how to take the mksysb backup in CD (VCD/DVD). I have tried like #mkcd -d /dev/cd0, but its not working. (3 Replies)
Discussion started by: oprakash
3 Replies

8. AIX

mksysb backup

hi we are having one rootvg in that we created one lv named mksysb_backuplv and normally script will run accordingly to take the backup in the cron,here i just want to know if any rootfilesystem was correpted like /usr or /tmp ,then how could i restore the particular filesystme from the... (1 Reply)
Discussion started by: senmak
1 Replies

9. AIX

Need help with mksysb backup on a DVD

i have an AIX server and planning to upgrade the operating system, before that i want to take a system backup which can be used in case of upgrade failure. i dont have NIM server t hold the mksysb backups. so i have the only option of taking the backup on DVD. i have the following optical drive... (5 Replies)
Discussion started by: saikiran_1984
5 Replies

10. UNIX for Advanced & Expert Users

Installation through mksysb image backup

Hi Experts, I am very new to AIX, I have a mksysb image in one of my aix server (V6), I would like to install this mksysb image on newly lpar. Is it possible without tape and NIM? Advice would be appreciated. Regards, Rockie (11 Replies)
Discussion started by: aix.rockie
11 Replies
nfsd(7) 						 Miscellaneous Information Manual						   nfsd(7)

NAME
nfsd - special filesystem for controlling Linux NFS server SYNPOSIS
mount -t nfsd nfsd /proc/fs/nfsd DESCRIPTION
The nfsd filesystem is a special filesystem which provides access to the Linux NFS server. The filesystem consists of a single directory which contains a number of files. These files are actually gateways into the NFS server. Writing to them can affect the server. Reading from them can provide information about the server. This file system is only available in Linux 2.6 and later series kernels (and in the later parts of the 2.5 development series leading up to 2.6). This man page does not apply to 2.4 and earlier. As well as this filesystem, there are a collection of files in the procfs filesystem (normally mounted at /proc) which are used to control the NFS server. This manual page describes all of these files. The exportfs and mountd programs (part of the nfs-utils package) expect to find this filesystem mounted at /proc/fs/nfsd or /proc/fs/nfs. If it is not mounted, they will fall-back on 2.4 style functionality. This involves accessing the NFS server via a systemcall. This sys- temcall is scheduled to be removed after the 2.6 kernel series. DETAILS
The three files in the nfsd filesystem are: exports This file contains a list of filesystems that are currently exported and clients that each filesystem is exported to, together with a list of export options for that client/filesystem pair. This is similar to the /proc/fs/nfs/exports file in 2.4. One difference is that a client doesn't necessarily correspond to just one host. It can respond to a large collection of hosts that are being treated identically. Each line of the file contains a path name, a client name, and a number of options in parentheses. Any space, tab, newline or back- slash character in the path name or client name will be replaced by a backslash followed by the octal ASCII code for that character. threads This file represents the number of nfsd thread currently running. Reading it will show the number of threads. Writing an ASCII decimal number will cause the number of threads to be changed (increased or decreased as necessary) to achieve that number. filehandle This is a somewhat unusual file in that what is read from it depends on what was just written to it. It provides a transactional interface where a program can open the file, write a request, and read a response. If two separate programs open, write, and read at the same time, their requests will not be mixed up. The request written to filehandle should be a client name, a path name, and a number of bytes. This should be followed by a new- line, with white-space separating the fields, and octal quoting of special characters. On writing this, the program will be able to read back a filehandle for that path as exported to the given client. The filehandle's length will be at most the number of bytes given. The filehandle will be represented in hex with a leading 'x'. The directory /proc/net/rpc in the procfs filesystem contains a number of files and directories. The files contain statistics that can be display using the nfsstat program. The directories contain information about various caches that the NFS server maintains to keep track of access permissions that different clients have for different filesystems. The caches are: auth.domain This cache maps the name of a client (or domain) to an internal data structure. The only access that is possible is to flush the cache. auth.unix.ip This cache contains a mapping from IP address to the name of the authentication domain that the ipaddress should be treated as part of. nfsd.export This cache contains a mapping from directory and domain to export options. nfsd.fh This cache contains a mapping from domain and a filesystem identifier to a directory. The filesystem identifier is stored in the filehandles and consists of a number indicating the type of identifier and a number of hex bytes indicating the content of the iden- tifier. Each directory representing a cache can hold from 1 to 3 files. They are: flush When a number of seconds since epoch (1 Jan 1970) is written to this file, all entries in the cache that were last updated before that file become invalidated and will be flushed out. Writing 1 will flush everything. This is the only file that will always be present. content This file, if present, contains a textual representation of ever entry in the cache, one per line. If an entry is still in the cache (because it is actively being used) but has expired or is otherwise invalid, it will be presented as a comment (with a leading hash character). channel This file, if present, acts a channel for request from the kernel-based nfs server to be passed to a user-space program for han- dling. When the kernel needs some information which isn't in the cache, it makes a line appear in the channel file giving the key for the information. A user-space program should read this, find the answer, and write a line containing the key, an expiry time, and the content. For example the kernel might make nfsd 127.0.0.1 appear in the auth.unix.ip/content file. The user-space program might then write nfsd 127.0.0.1 1057206953 localhost to indicate that 127.0.0.1 should map to localhost, at least for now. If the program uses select(2) or poll(2) to discover if it can read from the channel then it will never see and end-of-file but when all requests have been answered, it will block until another request appears. In the /proc filesystem there are 4 files that can be used to enabled extra tracing of nfsd and related code. They are: /proc/sys/sunrpc/nfs_debug /proc/sys/sunrpc/nfsd_debug /proc/sys/sunrpc/nlm_debug /proc/sys/sunrpc/rpc_debug They control tracing for the NFS client, the NFS server, the Network Lock Manager (lockd) and the underlying RPC layer respectively. Deci- mal numbers can be read from or written to these files. Each number represents a bit-pattern where bits that are set cause certain classes of tracing to be enabled. Consult the kernel header files to find out what number correspond to what tracing. SEE ALSO
nfsd(8), rpc.nfsd(8), exports(5), nfsstat(8), mountd(8) exportfs(8). AUTHOR
NeilBrown 3 July 2003 nfsd(7)
All times are GMT -4. The time now is 02:27 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy