Sponsored Content
Top Forums Shell Programming and Scripting Operating System Revision Level Post 302314241 by TonyFullerMalv on Thursday 7th of May 2009 07:42:50 PM
Old 05-07-2009
Code:
$ uname -r

would spit out 5.8 for Solaris 8 (SunOS 5.8) and the Kernel revision for Linux.

Code:
$ sar -q

Will output today's run queue sizes since midnight if the sa1(8) and sa2(8) cron jobs have been set up to log sar(1) data at regular intervals and will display historical data if pointed at a prior date's sar data file, otherwise use:
Code:
$ vmstat 5 4

Where 5 is the seconds between measurements and the 4 is the number of measurements to display, the first column headed "r" shows the number of processes waiting to run.
 

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

UNIX Operating System

Hello Everyone, I'm new to this forum and Unix. I have a couple of questions and please, excuse my ignorance. I have a spare machine which is now running MS Windows 98 and I would like to format the disk and install the Unix operating system along with Oracle 8i and SQL Server. My... (13 Replies)
Discussion started by: IronBear
13 Replies

2. UNIX for Dummies Questions & Answers

Operating System

Which is much more powerful as an operating system: 1. Windows 2000 2. Windows 98 3. Windows XP 4. Windows ME 5. Unix 6. Linux and why is it much more powerful than the other operating systems that i have mentioned. thanks for your info... (1 Reply)
Discussion started by: alecks1975
1 Replies

3. Solaris

Who has "Solaris 10 Advanced System Administration(SA-202-S10)" latest revision doc?

Dear All, I am going to examine SA202 but I got SA-202-S10 revision A.1 so it might be out of date. Who has "Solaris 10 Advanced System Administration(SA-202-S10)" latest revision document? Could you share it ? Thank you in advance (2 Replies)
Discussion started by: unitipon
2 Replies

4. Homework & Coursework Questions

Operating system LINUX

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: Write a C program that accepts 3 parameters. Each parameter indicates the quantity of product to be produced.... (1 Reply)
Discussion started by: paradise
1 Replies

5. Homework & Coursework Questions

Operating system LINUX

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: Write a C program that accepts 3 parameters. Each parameter indicates the quantity of product to be produced.... (0 Replies)
Discussion started by: paradise
0 Replies

6. UNIX for Advanced & Expert Users

Best Operating System

Hello All, I want to install Linux on my machine, so please tell me one thing which is the best to install- 1.)Red Hat 2.)Cent OS 3.)Red Hat 4.)Ubuntu 5.)Fedora except that if there is any please tell me. (1 Reply)
Discussion started by: parthmittal2007
1 Replies

7. What is on Your Mind?

New operating system and new license

Hello all, I'm new here. I wanted as nickname just wizard but it was taken. So Magus.Wizard instead; in my view, a wizard is somebody who really understands computers, a computer wizard, a master, a profi. Not too much about myself, more to the topic - I get tired from all the crap can be found... (2 Replies)
Discussion started by: Magus.Wizard
2 Replies

8. UNIX for Advanced & Expert Users

What's my Operating System

Can we know the operating given the IP address or DNS of the host. All I have is file://myserver/myapp (4 Replies)
Discussion started by: mohtashims
4 Replies

9. UNIX for Advanced & Expert Users

Revision Control System

We've recently migrated from Unix to Linux, and unfortunately one of the command 'chown' is turned down on the new environment. My dilemma is that whenever a user co (check-out), on new environment, scripts from RCS it overwrites the file ownership from the group ID to himself, and whenever he... (8 Replies)
Discussion started by: sethmj
8 Replies
uname(2)							   System Calls 							  uname(2)

NAME
uname - get name of current operating system SYNOPSIS
#include <sys/utsname.h> int uname(struct utsname *name); DESCRIPTION
The uname() function stores information identifying the current operating system in the structure pointed to by name. The uname() function uses the utsname structure, defined in <sys/utsname.h>, whose members include: char sysname[SYS_NMLN]; char nodename[SYS_NMLN]; char release[SYS_NMLN]; char version[SYS_NMLN]; char machine[SYS_NMLN]; The uname() function returns a null-terminated character string naming the current operating system in the character array sysname. Simi- larly, the nodename member contains the name by which the system is known on a communications network. The release and version members further identify the operating system. The machine member contains a standard name that identifies the hardware on which the operating sys- tem is running. RETURN VALUES
Upon successful completion, a non-negative value is returned. Otherwise, -1 is returned and errno is set to indicate the error. ERRORS
The uname() function will fail if: EFAULT The name argument points to an illegal address. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Standard | +-----------------------------+-----------------------------+ |MT-Level |Async-Signal-Safe | +-----------------------------+-----------------------------+ SEE ALSO
uname(1), sysinfo(2), sysconf(3C), attributes(5), standards(5) SunOS 5.10 21 Jul 1999 uname(2)
All times are GMT -4. The time now is 02:36 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy