Sponsored Content
Operating Systems Solaris How to find network cards available ... Post 302094594 by nibiru78 on Monday 30th of October 2006 07:38:17 AM
Old 10-30-2006
For the example here it is assumed that hme0 is not installed on the system and eri0 has been configured and working.

1) Do
dladm show-link - this shows list of network cards installed on the system during installation time. If an interface is not installed on the system it will not show here. That means driver for that interface (device) has not been installed.
bash-3.00# dladm show-link
ge0 type: legacy mtu: 1500 device: ge0
eri0 type: legacy mtu: 1500 device: eri0

2) Also checking modinfo | grep device should list the driver if it is installed and loaded.

3) prtconf also helps to list available devices.
bash-3.00# prtconf -a /dev/hme
prtconf: invalid device path specified
bash-3.00# prtconf -a /dev/eri
SUNW,Sun-Fire-880
pci, instance #2
network, instance #0
bash-3.00#

4) Even kstat -c net | more will show all the configured interfaces as modules and their instances. But anything comeup here after it is plumbed.

5) Finally ifconfig -a shows all the interfaces plumbed so far. Plumbing can happen only after a device (NIC) has been installed with appropriate driver.

6) Can also lookinto these files
bash-3.00# grep -w ge /etc/path_to_inst
"/pci@8,600000/network@1" 0 "ge"
bash-3.00# grep -w eri /etc/path_to_inst
"/pci@9,700000/network@1,1" 0 "eri"
bash-3.00# grep -w hme /etc/path_to_inst

Something about NIC
********************
Solaris has physical and logical interfaces. Physical interface is a HW with approriate driver. Logical inteface is mapping with physical interface (NIC) and has configuration information such as ip etc.

During system installation, the Solaris installation program detects any interfaces that are physically installed and displays each interface's name. At least one interface from the list of interfaces should be configured. The first interface to be configured during installation becomes the primary network interface. The IP address of the primary network interface is associated with the configured host name of the system, which is stored in the /etc/nodename file. You can configure additional interfaces during later.

Network Interface Names
***********************

Each physical interface is identified by a unique device name. Device names have the following syntax:

Driver names on Solaris systems could include ce, hme, bge, e1000g etc. The variable instance-number can have a value from zero to n, depending on how many interfaces of that driver type are installed on the system.

Some typical driver names for this interface are eri, qfe, and hme. When used as the primary network interface, the Fast Ethernet interface has a device name such as eri0 or qfe0.

Configring the interface.
*************************
Get the driver for the NIC from the installation CD and add package. Once package is installed an entry into /dev/.... will be made

now, dladm show-link. This should show the interface.

next, ifconfig hme0 plumb up should work and
ifconfig hme0 should showup without the IP.

IP configuration can be done as per the normal process.
This User Gave Thanks to nibiru78 For This Post:
 

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

SCO Unix and Two Network Cards

Our shops server runs SCO Openserver 5 release 5. It has two network cards in it (one on 10.0.0.6 and one on 90.0.0.99). When I run scoadmin and look at the network settings it show both my 3com network cards and a loop back driver http://theentertainer.com/james/untitled.jpg Can anyone tell... (1 Reply)
Discussion started by: potter
1 Replies

2. Solaris

Disable Network cards under boot Prom

Hi, I'm looking for a command to be able to disable a network card under the boot PROM. I need it to force my Jumpstart to use the Ethernet card of my server (V880) instead of my fiber card (gem0). Thanks, Fabien (6 Replies)
Discussion started by: unclefab
6 Replies

3. Solaris

How to List all Network cards

Hi, I'm looking for a command to be able to list all my network cards available on my server. With the command "ifconfig - a", I can only see to configured network card(s) Any idea ? :confused: Thanks a lot for your help, Fabien (5 Replies)
Discussion started by: unclefab
5 Replies

4. AIX

Load balancing across network cards

The title speaks for itself. I have never attempted this but understand there is a way to use two network cards (en0 and en1) with the same IP address so as to load balance the traffic flow through both cards. Anyone know the answer? (4 Replies)
Discussion started by: johnf
4 Replies

5. Solaris

qfe errors and network cards

Hi All, Hope you are all doing good. In MY unix box i have 2 network cards. I want to know what if one network card fails. Does the second one will automatically take all the traffic or how it is supposed to work. Also in my logs i am seeing below errors . Can you throw some light of this qfe... (3 Replies)
Discussion started by: Krrishv
3 Replies

6. Solaris

Network cards - Routing

Hi all I hate networking, I hate everything to do with it. Its something I do in anger in one contract, then forget. This is more of a question / than a problem. So, on a solaris 10 server, using older qfe cards, Ive got a sun truck with 4 nics (qfe0,3,4,7), and a ipmp pair (hemo0,qfe1).... (2 Replies)
Discussion started by: sbk1972
2 Replies

7. Hardware

Slackware 13.1 can't configure two network cards

Hello everybody, I'm having troubles with Slackware 13.1 and network cards. I have one on-board Ethernet card (which is recognized and works okay) and a PCI Ethernet card (which is also recognized, but doesn't appear in 'ifconfig -a'). If i run a 'lspci', i can see the kernel recognized the... (5 Replies)
Discussion started by: semash!
5 Replies

8. UNIX for Dummies Questions & Answers

How to use wild cards to find files beginning with upper and lower case

Im trying to use wild cards to find files that start with either an upper or lower case letter e.g. list files that beginning with b or B, i also want to sort them by the time they were last modified. e.g latest file created first. At the moment i have the following code that ls -d... (3 Replies)
Discussion started by: parker4001
3 Replies

9. UNIX for Dummies Questions & Answers

1 Server with 2 ethernet cards IP on seperate network. Possible?

Hi All, I have just setup a webserver running on a linux box. This server has 2 ethernet cards and only 1 is in used now. eg. 192.168.10.1 is my server IP. All users from 192.168.10.X can access my webserver. However, users from another LAN 10.10.10.X are not able to access my webserver. They... (0 Replies)
Discussion started by: jackma
0 Replies
HME(4)                                                     BSD Kernel Interfaces Manual                                                     HME(4)

NAME
hme -- Sun Microelectronics STP2002-STQ Ethernet interfaces device driver SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file: device miibus device hme Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_hme_load="YES" DESCRIPTION
The hme driver supports Sun Microelectronics STP2002-STQ ``Happy Meal Ethernet'' Fast Ethernet interfaces. All controllers supported by the hme driver have TCP checksum offload capability for both receive and transmit, support for the reception and transmission of extended frames for vlan(4) and a 128-bit multicast hash filter. HARDWARE
The hme driver supports the on-board Ethernet interfaces of many Sun UltraSPARC workstation and server models. Cards supported by the hme driver include: o Sun PCI SunSwift Adapter (``SUNW,hme'') o Sun SBus SunSwift Adapter (``hme'' and ``SUNW,hme'') o Sun PCI Sun100BaseT Adapter 2.0 (``SUNW,hme'') o Sun SBus Sun100BaseT 2.0 (``SUNW,hme'') o Sun PCI Quad FastEthernet Controller (``SUNW,qfe'') o Sun SBus Quad FastEthernet Controller (``SUNW,qfe'') NOTES
On sparc64 the hme driver respects the local-mac-address? system configuration variable which can be set in the Open Firmware boot monitor using the setenv command or by eeprom(8). If set to ``false'' (the default), the hme driver will use the system's default MAC address for all of its devices. If set to ``true'', the unique MAC address of each interface is used if present rather than the system's default MAC address. Supported interfaces having their own MAC address include on-board versions on boards equipped with more than one Ethernet interface and all add-on cards except the single-port SBus versions. SEE ALSO
altq(4), intro(4), miibus(4), netintro(4), vlan(4), eeprom(8), ifconfig(8) Sun Microelectronics, STP2002QFP Fast Ethernet, Parallel Port, SCSI (FEPS) User's Guide, April 1996, http://mediacast.sun.com/users/Barton808/media/STP2002QFP-FEPs_UG.pdf. HISTORY
The hme driver first appeared in NetBSD 1.5. The first FreeBSD version to include it was FreeBSD 5.0. AUTHORS
The hme driver was written by Paul Kranenburg <pk@NetBSD.org>. BSD June 14, 2009 BSD
All times are GMT -4. The time now is 08:52 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy