Sponsored Content
Operating Systems HP-UX ANSI / C Compiler for HP-UX 11.11 Post 302069724 by buffoonix on Tuesday 28th of March 2006 05:53:58 PM
Old 03-28-2006
Although it seems you have worked it out
I thought you might be interested to hear about my experience
with installing codeword protected HP-UX SW.
However, I have to admit that I never fumbled with a trial license.

Usually if you posses a codeword and customer ID
installation would be done by swinstall like this

# swinstall -v -x customer_id=XXXXXXXXX -x codeword=XXXXXXXXX -x mount_all_filesystems=false -s /path/to/sw.depot \*

This should install all filesets of such a depot.

Sometimes depots need a reboot (certainly not the ANSI C compiler)
if for instance a new kernel needs to be built and booted.
You can check in advance if a depot requires a reboot by issueing

# swlist -l fileset -a is_reboot -s /path/to/sw.depot

and it show either false or true.
For such a depot that requires a reboot the above swinstall would be aborted
after the analysis phase because the autoreboot flag is per default set to false.
To change this include in the above swinstall command another -x option of
-x autoreboot=true
swinstall would also abort if the filesystem size check would detect that the space
in the target filesystems wouldn't suffice.
In such a case you should check the ERROR lines from the output that are also
logged to /var/adm/sw/swagent.log which filesystems were deemed insufficient.
To check how much space would be required for a depot to install you could run

# swlist -l fileset -a size -s /path/to/sw.depot

and to see what files would be where installed you can issue

# swlist -l file -s /path/to/sw.depot \* | more

After the codeword protected depot has been installed you usually find your codeword
and customer ID being stored in this file

# cat /var/adm/sw/.codewords

As for the HP-UX ANSI C compiler its depot is on the application set of
CDs that appear at least twice a year.
You need to mount any of the CDs and inspect a file in the root of the CD
which usually is called CD_TABLE_OF_CONTENTS.
There you search for ANSI C where it reads the name of the depot
(something like B?????) and also tells you the install size.
Then page backwards up until you reach the CD delimiter that tells you
on which of the 4-6 CDs the depot is located.
To mount your CD you of course need to know the device file to access.
You can find out by

# ioscan -knfCdisk | more

Then

# mkdir /cdrom && mount /dev/dsk/c?t?d? /cdrom

and find your depot

# swlist -s /cdrom B?????

You could either directly swinstall from CD

# swinstall -x codeword=XXXXXX -x customer_id=XXXXXX -s /cdrom B?????

or first move the depot from CD to some filesystem on your box
so that you also could install over your LAN via RPC on other boxes

e.g.

# swcopy -x codeword=XXXXXX -x customer_id=XXXXXX -x enforce_dependencies=false -s /cdrom B????? @ /some/dir/on/your/box

Then you could install from another box on your LAN

# swinstall -x codeword=XXXXXX -x customer_id=XXXXXX -s your_depot_host:/some/dir/thereon B?????

N.B. the official website to get a codeword would be here

http://licensing.hp.com/welcome.slm

Very important, you need to specify the ID of the CD from where you would install
the depot (as been read from CD_TABLE_OF_CONTENTS)

HTH
 

9 More Discussions You Might Find Interesting

1. Programming

Ansi C

Dear All, I have to develope some C functions in Unix for a Magic program. The original MSE code which compiles the attached C program uses a +z option, but the cc compiler don't know this. The complete command in the compiler script is 'cc -c -Aa +z myfile.c'. The warning message is 'The -z... (4 Replies)
Discussion started by: Frankie
4 Replies

2. Programming

ANSI C vs POSIX

can somebody explain about the ANSI C vs POSIX. say i was using open and fopen, i know that open is POSIX, and fopen is ANSI C. i read that that POSIX is a system call and ANSI C is like a standard library function. wouldn't the fopen function has to call on open function anyway to open any kind... (2 Replies)
Discussion started by: bb00y
2 Replies

3. UNIX for Dummies Questions & Answers

ANSI C compiler on UNIX

Hi, I run into an error message like this (Bundled]) cc: "flat.c", line 350: error 1705: Function prototypes are an ANSI feature.' Also when trying to compile with -Aa or -Ae options I get (Bundled) cc:warning 480: The -A option is available only with the C/ANSI C product; ignored. Is that... (1 Reply)
Discussion started by: elenav
1 Replies

4. Programming

hint on ansi c

I am a student. And need help on following program. I want to make a c program. I have to scan a sentence and I have to interchange a word from that sentence. Example: Scan the sentence is " Drilling machine and Milling machine " . Replace the word "machine" by "operation". And output should... (2 Replies)
Discussion started by: dhaval chevli
2 Replies

5. Shell Programming and Scripting

Convert file from Unix - ANSI to PC - ANSI

Hi, I am creating a file in Unix using a shell script. The file is getting created in the Unix - ANSI format. My requirement is to convert it to the PC - ANSI format. Can anyone tell me how to do this? Thanks, Sunil (0 Replies)
Discussion started by: ssmallya
0 Replies

6. HP-UX

Unix_ANSI to PC-ANSI

I want to convert a file from Unix-ANSI to PC-ANSI format. How can i achieve that? (0 Replies)
Discussion started by: ssmallya
0 Replies

7. Programming

How Can a Machine Reads a Compiler Since A Compiler is Written in Text! Not Binaries?

To make a programming language you need a compiler, so what was the first programming language and how was is created if you need the compiler first? The compiler itself is considered as a high language comparing to the machine! since the compiler is not created in 1's and 0's... Eventhough i... (12 Replies)
Discussion started by: f.ben.isaac
12 Replies

8. Programming

why the implementatoin of Bakery algorithm in ANSI C does not work in ANSI C

I follow the description of wiki (Lamport's bakery algorithm - Wikipedia, the free encyclopedia), then implement that algorithm in C, but it doesn't work, Starving is still here, is the implementation worry? Only print out: Thread ID: 0 START! Thread ID: 0 END! Thread ID: 0 START!... (2 Replies)
Discussion started by: sehang
2 Replies

9. Programming

C fdopen with and without -ansi

I have very little experience with gcc compilation under different environments, so please bear with me. I carried over 20 years old project into Ubuntu 18.04, it has old style K&R parameters, no function declarations to speak of, many functions without return are not declared void, and on and... (8 Replies)
Discussion started by: migurus
8 Replies
sin(3M) 																   sin(3M)

NAME
sin(), sinf(), sinl(), sinw(), sinq() - sine functions SYNOPSIS
HP Integrity Server Only DESCRIPTION
returns the sine of x (x specified in radians). On PA-RISC systems, may lose accuracy when x is far from zero. is a version of it takes a argument and returns a result. Integrity Server Only is a version of it takes a argument and returns a result. is an version of it takes an argument and returns an result. is equivalent to on HP-UX systems. USAGE
To use these functions compile either with the default option or with the and the options. To use (for Integrity servers) or compile also with the option. To use any of these functions, make sure your program includes and link in the math library by specifying on the compiler or linker command line. For more information, see the at the following site: PA-RISC Only Millicode versions of the and functions are available. Millicode versions of math library functions are usually faster than their counter- parts in the standard library. To use these versions, compile your program with the or the optimization option. For special cases, the millicode versions return the same values as their standard library counterparts (see the section). RETURN VALUE
If x returns NaN and raises the invalid exception. If x is NaN, returns NaN. When it raises no other exception, whether raises the inexact exception is unspecified. ERRORS
No errors are defined. SEE ALSO
asin(3M), asin(3M), atan(3M), atan2(3M), cos(3M), csin(3M), sind(3M), sincos(3M), tan(3M), math(5). STANDARDS CONFORMANCE
: SVID3, XPG4.2, ANSI C, ISO/IEC C99 (including Annex F, ``IEC 60559 floating-point arithmetic'') : ISO/IEC C99 (including Annex F, ``IEC 60559 floating-point arithmetic'') sin(3M)
All times are GMT -4. The time now is 05:45 PM.
Unix & Linux Forums Content Copyright 1993-2022. All Rights Reserved.
Privacy Policy