Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

gpioow(4) [netbsd man page]

GPIOOW(4)						   BSD Kernel Interfaces Manual 						 GPIOOW(4)

NAME
gpioow -- 1-Wire bus bit-banging through GPIO pin SYNOPSIS
gpioow* at gpio? offset 0 mask 0x1 gpioow* at gpio? onewire* at gpioow? DESCRIPTION
The gpioow driver allows bit-banging a 1-Wire bus as a master using one GPIO pin. The pin is used as a data signal. The GPIO pin must be able to drive an output and read an input. The pin number is specified in the kernel configuration with the offset locator. The mask locator should always be 0x1. The offset and mask can also be specified when gpioow is attached at runtime using the GPIOATTACH ioctl(2) on the gpio(4) device. SEE ALSO
gpio(4), intro(4), onewire(4) HISTORY
The gpioow driver first appeared in OpenBSD 4.0 and NetBSD 4.0. AUTHORS
The gpioow driver was written by Alexander Yurchenko <grange@openbsd.org> and was ported to NetBSD by Jeff Rizzo <riz@NetBSD.org>. BSD
July 19, 2009 BSD

Check Out this Related Man Page

GPIOLED(4)						   BSD Kernel Interfaces Manual 						GPIOLED(4)

NAME
gpioled -- GPIO LED generic device driver SYNOPSIS
To compile this driver into the kernel, place the following lines in your kernel configuration file: device gpio device gpioled DESCRIPTION
The gpioled driver provides glue to attach a led(4) compatible device to a GPIO pin. Each LED in the system has a name which is used to export a device as /dev/led/<name>. The GPIO pin can then be controlled by writing to this device as described in led(4). On a device.hints(5) based system, like MIPS, these values are configurable for gpioled: hint.gpioled.%d.at The gpiobus you are attaching to. Normally assigned to gpiobus0. hint.gpioled.%d.name Arbitrary name of device in /dev/led/ to create for led(4). hint.gpioled.%d.pins Which pin on the GPIO interface to map to this instance. Please note that this mask should only ever have one bit set (any other bits - i.e., pins - will be ignored). On a FDT(4) based system, like ARM, the DTS part for a gpioled device usually looks like: gpio: gpio { gpio-controller; ... led0 { compatible = "gpioled"; gpios = <&gpio 16 2 0>; /* GPIO pin 16. */ name = "ok"; }; led1 { compatible = "gpioled"; gpios = <&gpio 17 2 0>; /* GPIO pin 17. */ name = "user-led1"; }; }; Optionally, you can choose to combine all the LEDs under a single ``gpio-leds'' compatible node: simplebus0 { ... leds { compatible = "gpio-leds"; led0 { gpios = <&gpio 16 2 0>; name = "ok" }; led1 { gpios = <&gpio 17 2 0>; name = "user-led1" }; }; }; Both methods are equally supported and it is possible to have the LEDs defined with any sort of mix between the methods. The only restric- tion is that a GPIO pin cannot be mapped by two different (gpio)leds. For more details about the gpios property, please consult /usr/src/sys/boot/fdt/dts/bindings-gpio.txt. The property name is the arbitrary name of the device in /dev/led/ to create for led(4). SEE ALSO
fdt(4), gpio(4), gpioiic(4), led(4) HISTORY
The gpioled manual page first appeared in FreeBSD 10.1. AUTHORS
This manual page was written by Luiz Otavio O Souza. BSD
May 14, 2014 BSD
Man Page

13 More Discussions You Might Find Interesting

1. Tips and Tutorials

Unix File Permissions

Introduction I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls: $ ls -ld /usr/bin /usr/bin/cat drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin -r-xr-xr-x 1 bin bin ... (6 Replies)
Discussion started by: Perderabo
6 Replies

2. Shell Programming and Scripting

sorting left-justified numeric values

I have a file which looks roughly like this: 996 mmmmmmm 996 xxxxxxxxxxxxx 99600 ssssssssss 9964 fffffffffffff and would like to sort it numerically on the first field. I tried: sort -nr --key=1 .... The output I get is: 99600 ssssssssss 9964 ... (3 Replies)
Discussion started by: rovf
3 Replies

3. Programming

Memory Leaks

Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram. main() { malloc(1gb) return(0) } The program above exits without freeing the memory. In this case will the 1 gb of heap memory be returned... (9 Replies)
Discussion started by: rupeshkp728
9 Replies

4. Solaris

How to install PGX32 on Sparc 10 Ultra?

I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10. I've got the Oracle installation guide for it and I got as far as: "4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive." I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Discussion started by: Michele31416
21 Replies

5. Shell Programming and Scripting

Better to Use Return Code or wc -l Output?

Hey All, Quick question... I'm writing a short script to check if a continuous port is running on a server. I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the return code from the command or if its better to pipe to... (12 Replies)
Discussion started by: mrm5102
12 Replies

6. Shell Programming and Scripting

Vm versus physical linux server

Does anyone have a script that can be run to tell you if you are on either a VM Linux or a physical Linux server? (15 Replies)
Discussion started by: bigbenn
15 Replies

7. BSD

NetBSD 6.1.2: apm and admd not found

I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system? Is it necessary to recompile the default amd64 kernel to use apm? Or is there a new method for power management and suspend/resume? (2 Replies)
Discussion started by: bsdx
2 Replies

8. Shell Programming and Scripting

RFC - Korn shell prompt

Hi, I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD. So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post. The prompt is... (2 Replies)
Discussion started by: gezley
2 Replies

9. Shell Programming and Scripting

Make bold chars in UNIX

Hi all, I want to make the string as bold in unix. is there any way to acheive this? thanks in advance. (16 Replies)
Discussion started by: SekhaReddy
16 Replies

10. Shell Programming and Scripting

Adding a List of Times

Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Discussion started by: Brusimm
5 Replies

11. UNIX for Beginners Questions & Answers

BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD

Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;) But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
Discussion started by: fossiili
0 Replies

12. UNIX for Beginners Questions & Answers

Grandpa returning to UNIX

On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)
Discussion started by: fossiili
13 Replies

13. UNIX for Beginners Questions & Answers

Grep command to show the number of results

Hi I wanted to know if there is an option in grep command to show the number of results (not the number of lines of findings). Thanks (14 Replies)
Discussion started by: abdossamad2003
14 Replies