|Linux & Unix Commands - Search Man Pages
ONEWIRE(4) BSD Kernel Interfaces Manual ONEWIRE(4)
onewire -- 1-Wire bus
onewire* at gpioow?
1-Wire bus was originally developed by Dallas Semiconductor for connecting integrated cir-
cuits. It is commonly used for connecting devices such as electronic keys, EEPROMs, temper-
ature sensors, real-time clocks, security chips, etc.
The onewire driver provides a uniform programming interface layer between 1-Wire master con-
trollers and various 1-Wire slave devices. Each 1-Wire master controller attaches a onewire
framework; several slave devices can then be attached to the onewire bus.
The driver supports plugging and unplugging slave devices on the fly.
gpioow(4) 1-Wire bus bit-banging through GPIO pin
owtemp(4) temperature family type device
The onewire driver first appeared in OpenBSD 4.0 and NetBSD 4.0.
The onewire driver was written by Alexander Yurchenko <firstname.lastname@example.org> and ported to
NetBSD by Jeff Rizzo <riz@NetBSD.org>.
BSD April 4, 2006 BSD
All times are GMT -4. The time now is 08:25 PM.