Empty folders with SFU

Thread Tools Search this Thread
Special Forums Windows & DOS: Issues & Discussions Empty folders with SFU
# 1  
Old 09-18-2013
Empty folders with SFU

Hi all,

i am currently setting my windows XP environment to use with Services for Unix (NFS Client) to mount my unix file system as a network drive. However, though i could mount the unix file directory successful, but the folder is empty (which is not). Why is this so? i have imported my unix password and group file but there is no difference. Pls advise urgently. thank you
# 2  
Old 09-18-2013
Permissions are always a thorny issue with Windows-UNIX mounts.
This User Gave Thanks to DGPickett For This Post:
# 3  
Old 09-18-2013
sorry, a fundamental question, do i need to install both the client for nfs and server for nfs to work? i have only install client for nfs at the windows and perform a map to the unix server..
# 4  
Old 09-20-2013
Yes, but SAMBA can use the SMB protocol and the windows mount server. You can SAMBA serve your UNIX files to windows clients and vice versa, and of course you can SAMBA mount UNIX on UNIX.

For NFS, or AFS or whatever, windows and UNIX both need client and or server depending on the roles (mounted server or mounting client). I think there is even a system for mounting zip files as compressed file systems, where the netword xfer is compressed as well as the storage.
# 5  
Old 09-21-2013
thanks for the good idea of samba, but does samba cause additional loading to the host server? sorry, i need to read up more about samba but do i need to install additional packages to do so or it is already in the os existing default packages? thanks for the idea..Smilie

---------- Post updated at 10:31 PM ---------- Previous update was at 10:27 PM ----------

Originally Posted by lchunleo
thanks for the good idea of samba, but does samba cause additional loading to the host server? sorry, i need to read up more about samba but do i need to install additional packages to do so or it is already in the os existing default packages? thanks for the idea..Smilie
for the problem which i had mentioned earlier, it is the permission of the folders that resulted me unable to see the files. had successfully managed to see the folders and the files. now, i have to do the other way round, to let the unix clients see the windows folder..

just curious any reason is samba better than Microsoft S4U?
# 6  
Old 10-04-2013
Install SAMBA
client and server
# 7  
Old 10-04-2013
You only need the NFS client which is part of SUA (SFU). There is nothing wrong with that NFS client. It is working as intended. The reason you are having a problem is that Windows and Unix use different authentication mechanisms.

The correct longterm solution is to use AD/LDAP. A quick "fix" is to add your UID and GID to two new DWORDs (AnonymousUid and AnonymousGid) under the following registry key:

Do an Internet search and you will find plenty of documentation about this "fix"

Avoid Samba like the plague. It is seriously buggy.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

How to delete some empty folders?

I have an amount of folders and I want to delete only the empty ones. But I have more than 200 empty folders, so I would preffer do not delete one by one... I know it is possible, but I don't know how. I've tried with the size, using 'du' command, and saving the result in a file. After that, I made... (3 Replies)
Discussion started by: saitsug
3 Replies

2. Shell Programming and Scripting

Deleting empty folders

Hey, I need help with writing a shell script that deletes empty folders..anyone? :) Thank you! (5 Replies)
Discussion started by: putukas
5 Replies

3. UNIX for Dummies Questions & Answers

Removing empty folders

Hello, I have a folder that contains all my music. Recently, I started using a different media player, and I let it manage my music folder. It has sorted all my music neatly in folders by artist and album. However, all the old folders that the songs used to be in are still there, yet they are... (2 Replies)
Discussion started by: emveedee
2 Replies

4. Shell Programming and Scripting

Find empty folders

In current folder, there are many subfolders, subfolder's subfolders... under it. How can I find out the empty folders with no files in it. I only need the top folder list. For example, I have folders like below: a/b/c a/b/x/x.txt a/s a/s/y I need get the folder a/s, but not... (6 Replies)
Discussion started by: rdcwayx
6 Replies

5. UNIX for Dummies Questions & Answers

Removing empty folders using 'find'

Hey there! I try to use 'find' to remove empty directories like this: find . -depth -type d -empty -exec rm -rf {} ';' It works just fine, but there are some directories i want to exclude. So i tried to do sth like this: find . -depth -type d -empty -exec grep -v "not this one please" -exec... (5 Replies)
Discussion started by: deTTo
5 Replies

6. UNIX for Dummies Questions & Answers

Removing empty folders using the "find" command

Hi I'm trying to remove empty sub-folders from 1 main folder using the find method, but the "- empty" parameter isn't recognized by my Unix version. Any idea how to implement such thing? Thanks. (3 Replies)
Discussion started by: biot
3 Replies

7. UNIX for Dummies Questions & Answers

how to find empty folders without using -empty

hi all: my solaris FIND does not support find myFolder -type d -empty how can i find the empty folders? thanks! (7 Replies)
Discussion started by: lasse
7 Replies

8. Shell Programming and Scripting

SFU awk help

hi guys i am trying using this awk command which works perfectly on unix awk '$1>=dt' dt="2007-12-03" filename but when i run same command for same file under SFU it does nothing simply prints the file ( just like cat command ) i am not getting why ? any way i used sed for same ( little... (5 Replies)
Discussion started by: zedex
5 Replies

9. Windows & DOS: Issues & Discussions

FTP using SFU

I'm trying to ftp a file from Solaris to Windows XP Pro using SFU and the command that I used is as follows: ftp -n “host” << cmd user “loginname” “password” cd Directory ls filename error bye cmd If the filename does not exist, it shows the following output: Output to local-file:... (2 Replies)
Discussion started by: ilak1008
2 Replies

10. UNIX for Dummies Questions & Answers

zip nesting empty folders

I'm using the following command to zip a project file, but when it finishes, the resulting zip file contains all the directories above the file I wanted zipped, myapp.app, each one empty until you get to the actual app. zip -r myapp.app.zip ... (0 Replies)
Discussion started by: groundlevel
0 Replies
Login or Register to Ask a Question