Visit Our UNIX and Linux User Community


gethostbyname failed

 
Thread Tools Search this Thread
Special Forums Windows & DOS: Issues & Discussions gethostbyname failed
# 1  
Old 11-10-2009
gethostbyname failed

gethostbyname is failing and returning NULL on Windows 7. Should i use inet_addr or there is other way to get it
# 2  
Old 11-10-2009
If you get into cmd.exe can nslookup return the value?

What I'm asking is: does the windows box dns server resolve the hostname? - so windows can get it.
# 3  
Old 11-10-2009
it failed with localhost name itself. Windows 7
# 4  
Old 11-13-2009
I don't know Windows 7 - other than that some coworkers installed it and broke software. How unusual.

I would say the hosts file is not there, and that you need to set up your network access.

Previous Thread | Next Thread
Test Your Knowledge in Computers #714
Difficulty: Medium
Machine learning is a well known method for mitigating the Von Neumann performance bottleneck
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Failed to su to user

I am unable to su to functional user, though changed the soft-hard limit for open files in limits.conf. The following command did not help.ulimit -n <value>While su to user, the error I am getting is -su: cannot set user id: Resource temporarily unavailableWhether I need to restart the application... (1 Reply)
Discussion started by: atanubanerji
1 Replies

2. UNIX for Dummies Questions & Answers

FTP failed

Hi All, We are using the following step to place a file in server using FTP STEP_EXECUTE STEP090 /usr/pjc/bin/FTP -i DATASET FTPIN $sic/ctl/ftpsic.ctl DISP=OLD,KEEP,KEEP STEP_END If we run this step we are getting the error. ftp> open arg.mnd.appsc.com Connected to arg.mnd.appsc.com.... (4 Replies)
Discussion started by: ajaykumarkona
4 Replies

3. Solaris

Cygwin X Server error: xdmcp fatal error session failed session 23 failed for display

Hi, i got the following error when i tried to access the cygwin x server from a windows XP PC. "xdmcp fatal error session failed session 23 failed for display" Alternatively, when i tried to access the same Cygwin X Server from another windows XP PC which is on a different LAN... (3 Replies)
Discussion started by: HarishKumarM
3 Replies

4. IP Networking

The system function gethostbyname() failed to find the client's host name

As we are facing issue with this server connection. The error is: The system function gethostbyname() failed to find the client's host name. how can i check if the server "server1" is able to resolve the client hostname (hosts / dns)? i can ping the client from server. any... (1 Reply)
Discussion started by: jinslick25
1 Replies

5. OS X (Apple)

Failed Drive

I am trying to recover data off a drive that failed in my iMac. Apple returned the drive to me and I purchased a hard drive enclosure. I have been doing research on prices for data recovery services, way too expensive. I seen some links using Unix DD commands in the terminal none of which worked.... (6 Replies)
Discussion started by: KJ1906
6 Replies

6. UNIX for Dummies Questions & Answers

Ok. I've have looked and failed.

What I want seems to me should be simple but so am I so.... I have a Unix server that is running a program we will say logged in as UserA. The program is outputting a bunch of stuff to the terminal. I would like to log in from my machine to the server as Either UserA, UserB or if needed... (2 Replies)
Discussion started by: Dishevel
2 Replies

7. AIX

SFTP Failed---Request for subsystem 'sftp' failed on channel 0

Hi, While I am trying SFTP my machine to another unix machine , it was working fine till 10 min back. But now i am getting the below error "Request for subsystem 'sftp' failed on channel 0" Could you please someone help me to solve or analyise the root cause... Cheers:b:, Mahiban (0 Replies)
Discussion started by: mahiban
0 Replies

8. Programming

regarding gethostbyname()

iam using gethostbyname for verifing whether net is active or not it's work fine but how it's work i mean whether it is using ping or sending socket, who it determining the internet . thank u in advance sree (2 Replies)
Discussion started by: phani_sree
2 Replies

9. Solaris

mirror failed

i am working in sun solaris unix platform with storage device T3+ i got an error message mirror failed i have telneted to the storage and gave the command format it gives disk not available , i have shifted my storage from node A to node B then i gave the same command format by telneting to... (0 Replies)
Discussion started by: sasiprabu
0 Replies

10. Programming

g++ is OK while gcc is failed

#include <iostream> using namespace std; int main(void) { cout << "hello" << endl; return 0; } I tried this: 1) g++ test.cpp -o test // It's OK 2) gcc test.cpp -o test // Failed /tmp/ccriZviL.o(.text+0x14): In function `main': : undefined reference to... (3 Replies)
Discussion started by: princelinux
3 Replies

Featured Tech Videos