frecover


 
Thread Tools Search this Thread
# 1  
Data

Started an frecover from Sam, with a recovery scope and a different destination.
Here is what is happening.

Starting file recovery...
frecover(5423): incorrect volume mounted;
frecover(5424): expected volume 1, and got 2
frecover(5433): Do you wish to continue using this volume? (^[yY]/^[nN]) y
frecover(5434): attempting to resynchronize after volume header

Nothing seems to be happening. I've been waiting about a half hour. No new files, and the frecover process is in sleep mode with little to no cpu usage.

Any ideas on what is going on, or what I can do to find out if it is actually working?
# 2  
Assuming that you do have volume one mounted, here is something from the frecover man page which might help:

<I>
Care should be taken to match the names specified by the include and exclude options with the names in the index on the tape. Since the files are stored on the backup in lexographic order as defined by the LANG or LC_COLLATE environment variable, frecover uses the exact path names to determine when a partial recovery is complete, and when an earlier tape needs to be loaded. If a user's specification of a file to be recovered is misspelled, this may cause confusing messages, such as frecover asking for the previous volume, when volume one is mounted.
</I>

# 3  
Nope everything is fine on the file name specs. I know that the data I am searching for is not on the first tape and probably starts on the second, and since it was already in the drive. I just started the process thinking that it could resync the headers fine. But for some reason it seems to be stuck.
# 4  
Question Man page for frecover?

Please format and post the man page for frecover, or post a URL to an on-line version of the man page. -Thanks.

[Edited by Neo on 11-17-2000 at 07:10 PM]
# 5  
You can find just about any man page by searching google.com for '<I>command</I> man'.

frecover man page is here: http://www.devresource.hp.com/STK/ma...ecover_1m.html

It is an HP-UX specific command.
# 6  
Thanks for the man page pointer. Here are my current thoughts of what I would do if this was my problem and some background discussion.

First of all, in my years of HPUX experience, I always tried to avoid using SAM. SAM does many commands when you execute a function and it is hard to debug errors, as you are discovering.

Back away from SAM, decide what you are going to do, use the HP documentation and man pages and do it, step-by-step without SAM in between you and the environment. This has always been my method-of-operating in an HPUX environment. That is not to say that SAM is 'not good' because I use it to add users, groups and other less complex tasks. However,
for non-trivial tasks or tasks that are giving errors, I immediately move from SAM to the command line.

Now, assume you are at the command line. Take a look at the files and their permissions, write them down, etc. Start your reconfiguration step-by-step. If that does not work and you get errors, for example with frecover(); I would use a system call tracing utility to find out what is the exact HPUX system call returning the error and the arguments being passed to the system call. Sometimes the return codes of the systems call are much more informative that the text messages in the console. You will have to read the detailed man pages of the system calls to get this information. Somethings you will have to go into the header files in the associated system libs and look for the #defines in the right includes to get the next level of details.

I don't recall the name of the HPUX system call trace utility, something like ptrace() or strace() or something like that. There is one however, and learning to use it will become one of your greatest sysadmin debugging tools.

However, in many cases, just executing the task from the command line, step-by-step, in a controlled manner, with lead to a discovery of the problem. It may not be necessary to go a level deeper into system call tracing; but you will surely learn a lot about your environment getting out from under SAM and into the nuts-and-bolts of the task at hand.
 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

6 More Discussions You Might Find Interesting

1. Red Hat

frecover counterpart on linux

Hello All, The frecover command on HP UX gives information about the backed up file in the format- Magic Field: Machine Identification: System Identification:HP-UX Release Identification:B.11.11 Node Identification: User Identification: Record Size: Time: Media Use:0 Volume Number:1... (1 Reply)
Discussion started by: shamik
1 Replies

2. HP-UX

frecover problem

I had to do a recovery and restore from backup (using ignite & backups from fbackup job) on hpux 10.20. Problem is, all users (except root) receive error 'unknown user' when logging in (during script that checks quotas). They can still successfully log in to the system. However, the files... (9 Replies)
Discussion started by: mrviking
9 Replies

3. HP-UX

frecover command need help urgent please

Hi, I have a tape fbackup done (fbackup -f /dev/rmt/0m -i / -I index.fullfbackup) and I need to restore 3 filesystems, I would like to know the correct command and options: example: I want to restore the filesystem /data1 under /data1 and /data2 under another filesystem /datatest I tried... (4 Replies)
Discussion started by: touny
4 Replies

4. HP-UX

HP fbackup/frecover to SUN UNIX format?

Hi All, We have about 7 years worth of data which used the HP fbackup utility. Is there any utility to read these tapes on Solaris? The goal is to create new tapes using Legato. Do we need to download them to a box first using frecover, then copy them from SUN using Legato? Any help in... (0 Replies)
Discussion started by: tinakumar
0 Replies

5. UNIX for Dummies Questions & Answers

frecover on HP 11.11

Hi, Can someone please explain how I can check whether my files were backed-up to tape. I issued this command and got an error:- # frecover -I /tmp/mth -f /dev/rmt/5m frecover(2105): did not find expected file marker frecover(5409): unable to read volume header frecover(5418): not an... (2 Replies)
Discussion started by: gummysweets
2 Replies

6. HP-UX

frecover

I have machine (HP-UX) 11.x and I took backup using fbackup (took 4 DDS tapes) then i did restore using frecover . the restore failed on the 4th tape . and the process killed . Can I restore only the 4th tape. or I have to do full recover from biginning ? (1 Reply)
Discussion started by: salhoub
1 Replies

Featured Tech Videos