Visit Our UNIX and Linux User Community


Reel to reel tape!!!!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Reel to reel tape!!!!
# 1  
Old 12-02-2002
Reel to reel tape!!!!

I have a problem. Someone gave me a 9-Track reel-to-reel tape and told me to get the information off of it. The only thing that was given to me along with it was this information:
Magnetic Tape: 6250 BPI
EBCDIC
9-Track

Record Size = 60 Bytes
Records/Block = 60


I am pretty sure that the information came from a mainframe computer and I am positive that this has been done before using the dd command.

If I use dd with the default values or obs=60 I get nothing back. Can anyone give me any ideas on how to extract the data from this tape?
# 2  
Old 12-03-2002
If each record is 60 bytes and you have 60 records per block, then each block is 3600. If you're writing to a disk file, the obs is irrelevant. It's the ibs which is critical. Although I would just use bs=3600.

Mainframes tend to have a concept called "labelled tape". The label will appear to you as a tiny file at the beginning of the tape. If your tape is labelled, you will get only one or two short records. Use the no-rewind device and if the dd gives you a very short file, run it again and you may get the real file.

You have ebcdic and you probably want ascii, so you will need to use conv=ascii on the dd statement.
# 3  
Old 12-03-2002
That certainly helped but now I have another problem. The data was extracted to one file. If I cat the file it looks something like this:
&M-^@^@M-^W^@^B&M-4^@1^@^@^@^@M-&M-^QM-$ M-^Q^A M-^Q^A{^@^@M-=M-2M-JSANTA MONICA
The data does not seem to be compressed because you can clearly make out certain words, however, I'm pretty sure that the file or files are all supposed to be just text. Does anyone have any ideas on how I might be able to extract this data?
# 4  
Old 12-03-2002
Did this by any chance come from a Unisys mainframe?
# 5  
Old 12-03-2002
I'll give you one guess where it came from and you probably know better than I do what kind of mainframe it was.
# 6  
Old 12-03-2002
I thought so, but I wasn't sure.
I'm looking at some of our manuals here as to the tape format defaults.

I'm checking with some people here too, since they write tapes all the time. Also, a BLOCKSIZE of 60 seems a little odd - the default on LIBRARY/MAINTENANCE tapes are 2701.

And another thing would be the number and size of headers. You have Volume Headers, Header Labels, Tape Directories, all seperated by TAPEMARKS before the data ever starts.

And yet another problem could be the exact OS and version.
I don't recall if it was a OS/2200 or an MCP machine - it might not matter though.

Yet all of this could be irrelevant if they decided to use some other format than the usual.

I'll look into it some more.
# 7  
Old 12-04-2002
What type of system are you dumping this to? Do you need to add the "conv=ascii" to the dd command or does your system use ebcdic?

(Sorry! Didn't see that Perderabo had covered that)

Last edited by RTM; 12-05-2002 at 11:26 AM..
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #17
Difficulty: Easy
Microsoft first developed the Java programming language.
True or False?

9 More Discussions You Might Find Interesting

1. AIX

Ejecting tape on AIX & Some Tape commands

I am trying to use this command to eject the tape mt -f /dev/rmt/0 unload but it gives me error mt -f /dev/rmt/0 unload mt: 0511-575 unload is not a recognized subcommand. Usage: mt Subcommand Valid subcommands are: weof eof fsf bsf ... (5 Replies)
Discussion started by: filosophizer
5 Replies

2. UNIX for Dummies Questions & Answers

Copying tape-to-tape on UNIX

I am using a 4mm tape to backup my Unix system. However, I wanted to make a copy all of the files and archive headers (or just the archive headers if that's possible) created on one of my tapes to another 4mm tape. I only have one tape drive. Is there a command that will complete such task? ... (1 Reply)
Discussion started by: acoco
1 Replies

3. AIX

How to make a copy of a tape to another tape?

Hello, We need to make a copy of a backup tape, using the 2 tape recorders in IBM 3582 Tape Library We tried tu use "tcopy", it seems to work fine (no error messages) but we aren't sure if we can rely on it. my question is how to check if the copy succeded or not, but i also want to know... (3 Replies)
Discussion started by: fastlane3000
3 Replies

4. SCO

Tape Status shows 2 Hard errors and 5 Underruns on new tape

when I do a tape status /dev/rStp0 I get the following on a new tape and I have tried several: Status : ready beginning-of-tape soft errors : 0 hard errors: 2 underruns: 5 My BackupEdge has stopped backing up my system because it asks for a new volume yet my total system data is under 20... (5 Replies)
Discussion started by: psytropic
5 Replies

5. UNIX for Dummies Questions & Answers

Sony Reel to Reel TC 366 help

HI I am recording some live music on my Sony Reel to Reel TC 366 and keeping the needles below the red but when I play it back the needles are way over in the red producing distorted sound. There is no volume out button on this model, just RCA out to my amp. Could it be a internal electronics... (0 Replies)
Discussion started by: jamt
0 Replies

6. AIX

How to copy a tape into another tape ?

I am new to AIX. I want to make a duplicate tape. How can I do that ? (1 Reply)
Discussion started by: Anonno
1 Replies

7. UNIX for Dummies Questions & Answers

Mounting DLT tape and to backup file to tape

Hi there: I'm new here Can anyone help me: I have DS15 Alpha server : Unix 5.1B Now i need to connect a DLVT VS80 1U Rackmount Tape Drive unit. What is the exact comman to mount the DLTape IV?? How do i make backuo @ copy file to the tape? Thanx to all (0 Replies)
Discussion started by: ayzeayem
0 Replies

8. UNIX for Advanced & Expert Users

Space free on tape /delete a single file on tape

Hi, I' using a sun solaris server, I would like to known if there is the possibility to control how many space is free on a tape and how I can delete a single file on a tape. Thanks DOMENICO (3 Replies)
Discussion started by: Minguccio75
3 Replies

9. Solaris

copy tape to tape using dd

I have two tape drives attached to my system , and i am trying to copy one tape to another using both tape drives and using the following command : dd if=/dev/rmt/1 of=/dev/rmt/2 but unfortunitly i am getting the following error : read: Not enough space 0+0 records in 0+0 records... (2 Replies)
Discussion started by: itsgeorge
2 Replies

Featured Tech Videos