Visit Our UNIX and Linux User Community


syslogd


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers syslogd
# 1  
Old 11-25-2002
syslogd

Working out of AIX 4.3.

All logs that were written via application suddenly stopped. executing a tail -f <logfile> was not producing any results.

Tried to refresh the syslogd (daemon). When executing "refresh -s syslogd" system would display
<<0513-036 The request could not be passed to the syslogd subsystem.>>

I then grep'd for the syslogd daemon which was up and running.

<< root 52722 5444 0 Nov 22 - 1:29 /usr/sbin/syslogd >>

Since I did not know what to do next I thought I'd restart the process.
Then I killed the process.
Then restarted the daemon .... got this message <<0821-600 ./syslogd: continuing without SRC support>>

Then executed the refresh again, this time
got message << 0513-036 The request could not be passed to the syslogd subsystem.
Start the subsystem and try your command again. >>

Went into smitty " Processes and Subsystems". Started the subsystem. However when checked via listing all subsystems the syslogd showed up as , 'inoperative'

My concerns are.....

Firstly, eventhough the syslogd daemon was up and running, why was the refresh message 0513-036 displayed?
Secondly, why does the status show inoperative, even when I started the subsystem.
and finally how do I get the syslogd status to active..


Thnx
buRst
# 2  
Old 11-26-2002
You may have already tried this, but here goes.

I would simply kill and restart the daemon with the "-D" option. This will redirect all responses that would normally go to the console. Also, if you have an /etc/syslog.conf file make sure it is readable. This file tells the daemon where to put the logs it receives. YOu can specify it with the -f FILENAME option.

Use this command line::
/usr/sbin/syslogd -d -D -f /etc/syslog.conf

The lower -d turns on debugging.

Read thru the manpage again maybe you missed something.
# 3  
Old 11-26-2002
Thank you very much for the input..
I did however go crazy over the man pages and Document Library at AIX, finally got into "Operating System Devices" where currently Iam going through the "Starting and Stopping of a Subsystem".

So, back to the cure... Before I started the Subsystem, I HUP'd the syslogd. Then went into smitty and then continued with the Starting of Subsystem process and ... guess what, the system now lists as 'active'. Once completed I also refresh -s syslogd and I got the message below
"0513-095 The request for subsystem refresh was completed successfully. "

The reading still continues.........

Thnx
buRst
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #616
Difficulty: Medium
There is no separate char data type in Python.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Syslogd configuration

Where do I configure where syslogd writes to log files? I've got open files in an archive directory called errlog.131017 and audlog.131017 and, having run an fuser, it appears that syslogd is writing to these files. (3 Replies)
Discussion started by: psychocandy
3 Replies

2. Solaris

Syslogd

Hi , Iam using Solaris8 and as I checked I found syslogd process not running can please somebody suggest me the way to start it. (2 Replies)
Discussion started by: Laxxi
2 Replies

3. AIX

Configure AIX syslogd

Hi Guys, I am configuring syslogd for Message broker. I know that we have to add a line user.* /var/log/wmb.log to the /etc/syslog.conf file. I want to know what userid does the user in user.* take? Thanks (1 Reply)
Discussion started by: vandi
1 Replies

4. Linux

Message from syslogd

I'm recieving from time to time such messages: Message from syslogd@localhost at Sat Jul 8 18:29:58 2006 ... localhost kernel: Disabling IRQ #17 What could cause such messages? How can I at least disable these messages which are posted on all terminals? Note: $ uname -a Linux... (19 Replies)
Discussion started by: Hitori
19 Replies

5. Solaris

Restarting syslogd on Unix

Hi All, I can seem to find the syslog daemon in the /etc/init.d/ dir. i have made change to the syslog.conf i need to restart the daemon. am using solaris 10. i have no problem on version 9 Anyone with a template i can use for log review for auditing purposes. (1 Reply)
Discussion started by: lottiem
1 Replies

6. AIX

syslogd - unable to log ?

Hi, I wanted to log some authentication information, so I added following line to /etc/syslog.conf: auth.info /home/vilius/dir1/eeerrr.log After that I refreshed syslogd subsystem: refresh -s syslogd To check my logging I made few unsuccessfull attempts to login as root using ssh and... (1 Reply)
Discussion started by: vilius
1 Replies

7. Solaris

Ignore events with syslogd

Hi friends, is it possible to ignore special messages with syslogd? we have some errors that are firmware issues an no real faults. we serach for a way to ignore ONLY these messages... OS is solaris 10... any ideas? tia, DN2 (1 Reply)
Discussion started by: DukeNuke2
1 Replies

8. UNIX for Advanced & Expert Users

Syslogd

I have a remote syslog server which is recieving messages from many hosts. I would like it to log them in seperate files denoted by hostname . For example all messages for host1 in a directory of the same name. Is there an easy way to do this using syslogd? I have a feeling syslog-ng provides this... (3 Replies)
Discussion started by: silvaman
3 Replies

9. UNIX for Advanced & Expert Users

multiple instances of syslogd - is it possible?

I would like to start up multiple instances of syslog daemon. I am having a little difficulty. Is this at all possible? I have separate syslog.conf1.... syslog.conf5 files. I have linked the daemon to separate files syslogd1 ... syslogd5 I have arranged the rcd.2 start/stop scripts for... (9 Replies)
Discussion started by: Gary Dunn
9 Replies

10. Cybersecurity

HELP!!! syslogd is down...

Hi all My system logger has been down for the past 3 days... I am not able to get it to start from the terminal... /etc/init.d/syslogd start I am unable to find a log as to why it is failing!! Please advice where to look!!! I am totally lost here! Thanks in advance... KS (5 Replies)
Discussion started by: skotapal
5 Replies

Featured Tech Videos