Problems with Apache setup


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Problems with Apache setup
# 1  
Old 11-25-2002
Question Problems with Apache setup

I posted a problem with the forum on 11/18/02. Unfortunately, I
have been out of town. Today is the first chance I've had to try
the suggestions that were made.

Here is the output from the ls -l configure* command:

-rw-r--r-- 1root sys 58230 May 21 2002 configure


When I type " sh ./configure or ksh ./configure " I get the output:

. /configure: ^M: not found
. /configure: ^M: not found
. /configure: ^M: not found
. /configure: syntax error line 103: `in^M unexpected


The forums help would be greatly appreciated. Thanks.
# 2  
Old 11-25-2002
It looks like you opened the file in Windows and then saved it, resulting in the windows "^M" end of line character appearing in the file.

Backup your Apache files and then try to remove all the "^M" characters at the end of each line in the file "configure"

Also, if you are to run a command like:
Code:
./configure

you need to make the file executable - which your isn't (-rw-r--r--), this can be done with the command:
Code:
chmod +x configure

# 3  
Old 11-25-2002
Yep, and when you run the script like cstovall did, as a parameter to the shell, the script does not need the executable bit set.
Jimbo
 
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

apache httpd virtual hosts setup keep hitting the same VirtualHost

I'm trying to set up two virtual hosts. Here's my httpd config: <Directory /Users/userX/dev/sandbox-2> Order deny,allow deny from All Allow from localhost </Directory> NameVirtualHost 127.0.0.1 <VirtualHost 127.0.0.1> DocumentRoot "/Users/userX/dev/sandbox-2" ... (0 Replies)
Discussion started by: GlideK
0 Replies

2. Linux

Could not open the lock database - Apache WebDAV setup

I configured a WebDAV server using Apache. Here is my configuration: DAVLockDB /var/www/DAVLock.db <Location /majid> AllowOverride None Options +Indexes DAV On AuthUserFile /var/www/users.db AuthName Authentication AuthType Basic <Limit... (1 Reply)
Discussion started by: majid.merkava
1 Replies

3. IP Networking

Problems with Internet setup

Hi, I am using VMWARE and when I have the network connection set to NAT and the VM set to DHCP I get internet connection. But when I set the connection to BRIDGED and assign a static IP address I loose internet connection. I have used netconfig to manually assign the IP Address, GATEWAY, and... (5 Replies)
Discussion started by: mojoman
5 Replies

4. Web Development

Problems starting Apache 2.0.54

Hi, I just installed Apache 2.0.54 and when I try and start httpd I get mohit@mohit-desktop:/sw/pkg/apache/bin$ ./httpd -k start httpd: Could not determine the server's fully qualified domain name, using 127.0.1.1 for ServerName (13): make_sock: could not bind to address :80 no listening... (1 Reply)
Discussion started by: mojoman
1 Replies

5. Web Development

Apache Problems.

Hello guys I have been running a LAMP stack for awhile now but have never really explored the server side end of things. What I am trying to do is have a python script on a website run a bash command. This will accomplish a system so someone can create an account for proxy access via a webpage.... (45 Replies)
Discussion started by: darkphaux
45 Replies

6. UNIX for Dummies Questions & Answers

How to setup Apache + mod_fcgi + suphp?

Hello. Could you please post an example of configuration of Apache + mod_fcgi + suphp? Till now I can get to work only either mod_fcgi or suphp, but not together. As I understand, suphp binary should be called from FCGIWrapper directive, but it always says, that SCRIPT_NAME variable is not... (0 Replies)
Discussion started by: FractalizeR
0 Replies

7. Linux

problems in linux mail server setup

hi i want to set up LInux mail server for intranet purpose. i used following document as reference Linux Mail Server softwares used are : Postfix # pre installed Procmail # pre installed Fetchmail # pre installed SpamBayes Mutt #... (1 Reply)
Discussion started by: zedex
1 Replies

8. UNIX for Dummies Questions & Answers

Create Folder and setup Apache

Hi, I'm a new person in here and also newbie. When I create a home folder for User and let them install any things they want in their own folder but there is one problem and i don't know how to resolved it. I post with a captured picture about this problem ... (1 Reply)
Discussion started by: cthinh
1 Replies

9. Solaris

problems with Apache

I have a Solaris 8 box and need to install Apache 2.0.55 on it. First thing I tried was compiling from source code. During the make phase, I got the following errors: Then I tried downloading the binaries. I tried the one available from Apache's site and the one from sunfreeware.com, with... (3 Replies)
Discussion started by: GKnight
3 Replies

10. UNIX for Dummies Questions & Answers

Problems with Apache setup

I downloaded Apache 1.3.27.tar.gz into my SCO u/install directory. However, to begin with, I couldn't untar the file using the " tar xvf apache-1.3.27.tar.gz" command, so I used winzip from a windows computer on our network. Winzip untarred the file and I transferred the files to the SCO... (2 Replies)
Discussion started by: cstovall
2 Replies
Login or Register to Ask a Question

Featured Tech Videos