Visit Our UNIX and Linux User Community


Network Interface


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Network Interface
# 1  
Old 06-05-2001
Question Network Interface

Hi !

Does anyone know how can i get information about my network interface ... if it works in half or full duplex mode !!

Thx in adivance !

Witt
witt
# 2  
Old 06-06-2001
What flavour of UNIX are you running?
alwayslearningunix
# 3  
Old 06-06-2001
In most UNIX systems, <B>ifconfig</B> is a good place to start. The actual usage is system dependent. Try:

Code:
man ifconfig

# 4  
Old 06-07-2001
In most case 'ifconfig' will not give this info. Same happens with 'dmesg'. In this case you can try 'mii-diag' program which reports the link status.

http://www.scyld.com/diag/index.html


HTH


# 5  
Old 06-07-2001
MySQL

Thanks !!

Witt Smilie
witt
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #61
Difficulty: Easy
A computer on a LAN segment is uniquely identified by its MAC address.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Adding a network interface to a bonded interface

I have a RHEL 5 system with a bonded interface configure using only one network port (eth0). So I have config file for ifcfg-bond0 and ifcfg-eth. I'd like to configure eth5 to be the second SLAVE in the bond. My question is, after I modify ifcfg-eth5, can I add eth5 to the bond0 interface without... (1 Reply)
Discussion started by: westmoreland
1 Replies

2. Solaris

No network cable But Network interface is UP and Running

I've one Netra 240 After changing main board and system configuration card reader, Network is not accessible any more, Network interfaces are always UP and Running even when there is no cable connected to Network interfaces. I tried to restart and plumb/unplumb with no luck. ifconfig -a... (7 Replies)
Discussion started by: samer.odeh
7 Replies

3. IP Networking

network interface -

Hello, Please, how can i create a network interface with a routable IP address on linux (ubuntu) ? AND How can i desactivate an interface? Thank you so much for help. (1 Reply)
Discussion started by: chercheur857
1 Replies

4. IP Networking

Network interface-

Hello, Please what's the difference between: AND Thank you so much (3 Replies)
Discussion started by: chercheur857
3 Replies

5. UNIX and Linux Applications

Access to network interface (Mac-network)

Hi, I'm a italian student. For my thesis I develop a gateway with protocol 6lowpan. For that I must access to network interface to develope my personal stack based on standard 802.15.4. Can you help me? I need an explanation for that. (0 Replies)
Discussion started by: berny88
0 Replies

6. Solaris

configure zones to have different network interface and network

i need to configure a zone to use different interface (bge2) than global and have connected to completely different network switch & to use its own defaultrouter and hosts file .. is it possible ..if so ..how ? Thanks (9 Replies)
Discussion started by: skamal4u
9 Replies

7. Solaris

Network interface problem

Hi i have replace a NIC card on solaris 10 when i give the following command ifconfig -a it just show the lo0 (only loop back with inet 127.0.0.1) when i give the following command to config the interface, ifconfig elxl0 plumb ifconfig: plumb: elxl0: no such interface please help... (11 Replies)
Discussion started by: malikshahid85
11 Replies

8. Solaris

Network interface not found ?

Hello, I have just installed Solaris 9 x86 in a VMWare and the 1st problem I have is to enable the networking. I can only see the loopback interface and nothing else. - I dont have any /etc/hostnames.xxx - ifconfig -a shows only the loopback - kstat -c net shows only the loopback ... Any... (11 Replies)
Discussion started by: Tex-Twil
11 Replies

9. Solaris

Network Interface Issue

Hi all, Here im facing problem with NIC Interface with my X86 Version of Solaris Express, even after loading module for that Interface. So please check this below mentioned log for your use and get back to me ASAP. - - - -- --... (0 Replies)
Discussion started by: baraghun
0 Replies

10. AIX

Problem with a Network Interface

Hi every body, I have a Fiber Channel interface (fcs2) in AIX 5.2. This interface was fine & up but for some reason I could not return this interface UP again after I set it DOWN. When I tried to set this interface UP I encountered the following error: Method error... (7 Replies)
Discussion started by: aldowsary
7 Replies

Featured Tech Videos