LiLo in Red Hat 8

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers LiLo in Red Hat 8
# 1  
Old 11-13-2002
LiLo in Red Hat 8

I am about to go buy myself a wireless card for my Red Hat laptop. But I am going to have to recompile the kernel to run it in linux, and I heard that the GRUB bootloader gives you troubles when recompiling kernel. So, I booted off the cd to upgrade. I attempted to install LiLo and everything seemed to go alright, but at the end it said, "No kernel dependencies were upgraded, the bootloader was not changed."
So I attempted to do it again, so I redid it and installed some new kernel dependancies and the end result was the same, I attempted a few more times and nothing have worked. Am I missing something?
# 2  
Old 11-13-2002
What problems do Grub give you when you're switching kernels?
To "install" LILO, you should be able to run /sbin/lilo, assuming you have a correct /etc/lilo.conf file...

I think Redhat has a command called "liloconf", or something similar to that... Is should walk you through with a menu...
# 3  
Old 11-14-2002
LivinFree is right.

The lilo would have been installed when you first installed RH. What you need to do now though is to edit the /etc/lilo.conf file. When you have corrected and added the right lines then run /sbin/lilo (or just 'lilo' from the current directory can work sometimes).

You should run the lilo command to make sure that lilo is working fine and the updates have been made correctly.

If you need to find out how to edit the lilo do a search here I know the question has been answered before for a fact as I asked it ages ago.

# 4  
Old 11-14-2002
Thanx, I'll give that a shot...
# 5  
Old 11-14-2002
Ok, that worked to get LiLo going, problem is, It wont recognize any edits to the config, when I edit and run lilo it complains that something is above cylinder 1024. Also, I tried to make grub the bootloader again, and it doesnt seem to want to take over form lilo...?
# 6  
Old 11-15-2002
Due to your hardware (well, actually your BIOS) LILO has to be near the "front" of your disk.
To be more accurate, the /boot partition has to be within the first X gigs of disk...

To try installing Grub, you may have to uninstall LILO first - use the command "/sbin/lilo -u", then try installing Grub...

Keep a boot disk handy!
# 7  
Old 11-15-2002
Yep, always got a bootdisk.

Actually, i fixed the cylinder limit problem by inserting a force lba32

Still a syntax error in there somewhere but I think I can solve that, thanks for the help
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

how to know if i use "Red Hat Enterprise Linux" or "Red Hat Desktop" ?

how to know if i use "Red Hat Enterprise Linux" or "Red Hat Desktop" ? (2 Replies)
Discussion started by: ahmedamer12
2 Replies

2. Red Hat


Hello, How do I see what IP addresses are connected to my machine? thanks (2 Replies)
Discussion started by: sonomao
2 Replies

3. Red Hat

Red Hat E 3

I'm am working with a Red Hat Enterprise 3 server. This is a dedicated server that is supposedly dedicated to one domain, but I have been tasked with trying to figure out if there are files on this system that are being accessed by other IP's. Does anyone know if how I would go about finding... (0 Replies)
Discussion started by: chrisPlusPlus
0 Replies

4. Linux

red hat ee 2.6.9-42

hello. I would be greatfull if someone could tell me how will i see what dns server and gateway my red hat server uses. I tryied to find out by typing ifconfig command but i got : -bash: ifconfig: command not found , although man ifonconfig gives output with info about using that command. Is... (3 Replies)
Discussion started by: tonijel
3 Replies

5. UNIX for Dummies Questions & Answers

Red Hat 9 help

please help me how to install softwares in linux.i have a ethernet internet connection.i try to open the site on LAN to download internet client.but i cannot as our lan supports only internet explorer....i downloaded the linux client by booting thru XP......but i cannot c my NTFS partition thru... (0 Replies)
Discussion started by: shobhit143
0 Replies

6. Linux

Red Hat?

I have a Red Hat upgrade disk. I installed it and it corrupted my entire hard drive! I had gotten the disks out of a Dummy's book at my local library. Trying to install 'Red Hat', has cost me $100.00 in damages. (The cool part is my friend gave me that $100.00 part) Ah...A 120gig Hard Drive. Just... (3 Replies)
Discussion started by: hdk_mkr
3 Replies

7. UNIX for Advanced & Expert Users

Red Hat 9.0 Upgrade

I just upgraded my RedHat 8.0 system to 9.0. The upgrade included a new kernel and several package updates. I upgraded by simply inserting installation CD and rebooted, selected upgrade system option. When I rebooted after the install I get the following message: INIT:Id "x" respawning too fast:... (6 Replies)
Discussion started by: google
6 Replies

8. UNIX for Dummies Questions & Answers

Red Hat 7.2.....

I just installed red hat 7.2 on my laptop. it's dual booted with xp and red hat. when i boot in to linux it boots up to the screen to ask me my name and pass....i put in root and my password. after this it goes to a blue screen and sits there. the after about 2 minutes it comes up with a fatal... (1 Reply)
Discussion started by: muzscman
1 Replies

9. UNIX for Dummies Questions & Answers

Red Hat and LILO

Hi well ive got a slight prob with LILO, ive been trying to delete my linux partition and merge my entire hard drive back into one but when I do so LILO is still there, even after I erase the linux partition and I was pretty sure that it was on the boot record or something anyway, but all it... (2 Replies)
Discussion started by: Drainy
2 Replies
Login or Register to Ask a Question