Visit Our UNIX and Linux User Community


Apache hates me


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Apache hates me
# 1  
Old 11-02-2002
Apache hates me

Hi as you can tell from the number under my name im pretty new here, but i do have a question. This apache server is agrivating me. First off i am running SuSe 8 upgraded from 7.3 and I downloaded installed apache 2.0.43, PHP 4.2.3 and MySQL 3.23.53a-1.i386 installed it all. I did make sure to change the ServerName to its proper designation. Now when i try to run apachectl start i get the following message;

Syntax error on line 9 of /etc/httpd/suse_loadmodule.conf: Cannot load /usr/lib/apache/libphp4.so into server: libsnmp-0.4.2.1.so: cannot open shared object file: No such file or directory /usr/sbin/apachectl start: httpd could not be started

I checked out suse_loadmodule.conf to see if i infact infact it was trying to load somthing that i did not have. Everything was fine everything trying to be loaded was not only present but pointed in the right direction. I did how ever not find libsnmp-0.4.2.1.so it turns out the version i have is libsnmp-0.4.2.3.so. So i assume that is where my problem is. Now my question is a semi two parter. How do i make the apache loader look for libsnmp-0.4.2.3.so instead of libsnmp-0.4.2.1.so so that i can get the ball rolling here, if i am wrong and that is not the issue what is and how can i go about fixing it? All the instructions i have read only suggest perfect conditions and offer no trouble shooting advice.

That is all i wanted to know, i hope its as small of a problem as i think but if not oh well thats the price of doing business some days.


Cerberus
# 2  
Old 11-03-2002
I not trying to make just a band-aid fix, but sometimes, it will have to do until you find a real fix (the first thing I would do it is uninstall all version of PHP, then reinstall the current version, but I digress).

You could try making a soft link from the current version to the version it's looking for...

I hope someone has a better answer...
# 3  
Old 11-03-2002
thank you very much for your suggestion it is really appreciated! I ended up breaking somthing, so i reloaded suse 7.3 and the web server and php mod seems to be working great now! Good times but now mysql doesnt seem to be running right so im off to search the forum. thanks again.






Cerberus
# 4  
Old 11-03-2002
As I recall the following PHP book has a chapter on setting up both Apache and MySQL:

http://www.amazon.com/exec/obidos/tg...37409?v=glance

Or it might have been this MySQL book:

http://www.amazon.com/exec/obidos/tg...37409?v=glance

I have both, BTW.
# 5  
Old 11-03-2002
Quote:
Originally posted by Cerberus
i reloaded suse 7.3 and the web server and php mod seems to be working great now! Good times but now mysql doesnt seem to be running right so im off to search the forum. thanks again.
I am also using SuSE 7.3 and when I installed the MySQL rpm it didn't work too -- the owner and group of some files were not correct out of the box so mysqld didn't load. I got the solution from alt.os.linux.suse last year searching the newsgroup, hopefully it's not yet deleted.

To save me from further trouble (even though I have applied the fix) I removed the rpm and replaced it with a binary tarball distribution from MySQL. It works great, even with a 4.0.3 beta release.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #453
Difficulty: Easy
The TiVo digital video recorder is based on the Linux kernel and GNU software.
True or False?

9 More Discussions You Might Find Interesting

1. Red Hat

Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-la

Have no idea on what the below error message is: Process not running: /opt/java15/jdk/bin/java -classpath /opt/apache/apache-ant-1.7.0-mod/lib/ant-launcher.jar org.apache.tools.ant.launch.Launcher -buildfile build.xml dist. Any help? (3 Replies)
Discussion started by: gull05
3 Replies

2. Web Development

Apache module development on apache 2.2

Hi, I'm new to developing modules for Apache. I understand the basics now and can develop something simple which allows a 'GET' request to happen, but what I want to do is actually 'POST' information to my site. I know the basic POST Request works and I can see that it is post by looking at... (2 Replies)
Discussion started by: fishman2001
2 Replies

3. Shell Programming and Scripting

Tru64 "find" command hates me.

I want to search for all the .c .h and .pc files with find and it doesn't seem to agree with me. I tried: find . -name "*.|pc" find . -name "*.(|pc")" find . -name "*." -name "*.pc" nothing works. If I just want all .c and .h files the character group works great. I.E. find . -name "*."... (2 Replies)
Discussion started by: DreamWarrior
2 Replies

4. UNIX for Dummies Questions & Answers

Apache

Our Apache server keeps shutting down every 30 minutes. Any ideas on why? I nor the developers can figure it out. (1 Reply)
Discussion started by: ebethea27703
1 Replies

5. Linux

GTK+ hates me

I am very new to the linux environment. I have been interested in it for years but have just recently had the courage to pop that install disk into my PC. Because of it's ease of installation, I installed Mandrake 9.1 and I'm running KDE3.1 for my GUI. Right now I'm trying to conquer the world... (5 Replies)
Discussion started by: n0data
5 Replies

6. UNIX for Advanced & Expert Users

Apache

I am tring to configure Apache so that it displays the ip address of users browsing the web in the header. mod_header is installed on my apache as default. I tried including the following in httpd.conf file but no joy Header set remoteip %{REMOTE_ADDR} I have also tried Header add... (3 Replies)
Discussion started by: hassan2
3 Replies

7. UNIX for Dummies Questions & Answers

apache

on my webserver, and im sure many of you who also run one see this all the time, but the majority of my access log is filled with attempted exploits from computers compromised by some virus (NIMBDA?) and anyway i know this is harmless to an apache/linux webserver, but its annoying, anyway, on... (5 Replies)
Discussion started by: norsk hedensk
5 Replies

8. UNIX for Dummies Questions & Answers

apache

how must httpd.conf be configured to exec the php files? (2 Replies)
Discussion started by: user666
2 Replies

9. UNIX for Dummies Questions & Answers

i get the strangest feeling that lilo hates me.

i need to get rid of lilo's splash screen. i've heard that you can edit your /etc/lilo.conf and add this line: <b>append="splash=0"</b> anyway, i did that and i still have a splash screen. any idea why that didn't work, or what is another way to disable the splash screen? okay, -nydel (1 Reply)
Discussion started by: nydel
1 Replies

Featured Tech Videos