Visit Our UNIX and Linux User Community


applicatoin cannot started, becos daemon did not run


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers applicatoin cannot started, becos daemon did not run
# 1  
Old 11-01-2002
applicatoin cannot started, becos daemon did not run

hi, i had an applicatoin which is not running cos one of its daemon is not running.. i get the applicatoin to run by running the daemon first... its manual job... so quite cumbersome..

i have backups in the night, with the crontab -l entry with logs written. the logs indicated successful backups and startup of daemons.

so what could be wrong..

i am running HP-UX acs_lpa B.11.00
yls177
# 2  
Old 11-01-2002
daemon or one-time script?

I think you are asking about a startup script and not a true daemon, because they run all the time like inetd or initd.

You will need to tell us how the app normally gets started. Does it run from an rc3.d directory at system boot? My Oracle team starts up their app from the rc3.d directory at startup.

Also, how do you go about manually start it up? Is this truly a daemon that runs all the time or is it just an app startup script that runs only once?

Give us some background on what is a normal startup for this application.



Smilie
# 3  
Old 11-02-2002
HOWEVER, the (script or daemon) that is causing the application not to run had been resolved. i checked the crontab -l entry and realised that the original script had the (script or daemon) started FIRST before the database. Based on my young BUT hungry unix knowledge, i knew (hope that i am right) that i need to start the database before the (Script or daemon...) and off i went..

AND the next day, bingo, my uses had no problem with logging to the application and i checked my enforeced log entries.. and they logged fine...


So to pursure this continuous pursue of unix excellence, i tried to find this rc3.d and had no choice to but to do the below

i issued this find / -name rc3.d -print

then got the below

/sbin/rc3.d
NFS server (pid885@/net) not responding still trying


okay, a list of questions... ;D

1) this rc<number>.d is the run-level in unix?

2) when i do a ls-ltr rc3.d, i get a list of entries and TWO of them are
lrwxr-xr-x 1 root sys 23 Dec 19 2000 S100nfs.server -> /sbin/init.d/nfs.server
lrwxrwxrwx 1 root sys 16 Mar 14 2001 S900mqm -/sbin/init.d/mqm

and i think the above entries are related to the error of "NFS server (pid885@/net) not responding still trying"

which i get from dmesg as belows..

<myservername> vmunix: NFS server (pid885@/net) not responding still trying
yls177
# 4  
Old 11-02-2002
First, It is very important that any database startup before the application assoc with it will be able to run properly. My understanding is that an App tries to send threads out to the DB to establish connection to it. So this can't be done if the DB is not running.

Second, the /sbin/rc3.d directory is a representation of what processes start based on runlevel for HPUX. There is one for each runlevel in HPUX. (/sbin/rc0.d thru rc4.d) the last one, rc4.d, is generally used only for development and testing of scripts at least for me.

My DBAs have the DB start in /sbin/rc3.d at boot time and the lsnrs for data as well. Yours may be started differently, via crontab. My DB runs 24/7 so that may be the difference.

All other major UNIX brands have something similar to this. Where processes are either started or killed based on the runlevel and whether the system is going up or coming down.

Smilie

Last edited by Kelam_Magnus; 11-02-2002 at 03:04 PM..
# 5  
Old 11-05-2002
NFS server (pid885@/net) not responding still trying

hi, i am still stuck with the above error.. any help? thanks
yls177
# 6  
Old 11-05-2002
Your server is trying to mount an NFS mount from some server which it cannot contact - it continues to try because this was a soft mount (if it can't mount it then backgrounds the job to keep trying to mount).

Check your /etc/fstab to see what may be trying to mount. Also look for any auto mounts (such as home directories). Check that the nfs daemons are running.
# 7  
Old 11-05-2002
If you are the master server, I beleive that you need to make sure that the other system has the directory that you are trying to get to. It is possible that it is non-existent.

If your host is the client, the other host needs to check the /etc/exports file and re-export the list with exportfs so as to update it.

YMMV Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #240
Difficulty: Easy
In 1973, a transatlantic satellite link connected the Norwegian Seismic Array (NORSAR) to the ARPANET, making Norway the first country outside the US to be connected to the network.
True or False?

10 More Discussions You Might Find Interesting

1. HP-UX

EVM daemon can't started

Whenever I tried to login as a root the following message is consecutively appearing esmd: System Error: The EVM daemon has failed and cannot be restarted I check the patches which and all previously installed. But those are correctly present. And I replace the evmstop and evmstart script... (0 Replies)
Discussion started by: siva3492
0 Replies

2. Shell Programming and Scripting

How to make a bash or shell script run as daemon?

Say i have a simple example: root@server # cat /root/scripts/test.sh while sleep 5 do echo "how are u mate" >> /root/scripts/test.log done root@server # Instead of using rc.local to start or another script to check status, I would like make it as daemon, where i can do the following: ... (2 Replies)
Discussion started by: timmywong
2 Replies

3. UNIX for Advanced & Expert Users

job is started with sshd daemon; wish to know its implementation details

Hello Gurus, In solaris server, one folder say /appl/prod/usr/sendme get files those need to be processed. The script named checkFile.sh can process the each file. This script checkFile.sh is not scheduled in crontab. But whenever file puts in sendme folder, the checkFile.sh is called and... (1 Reply)
Discussion started by: get_chandrakant
1 Replies

4. AIX

RPC daemon can not be started.

We encounted the following err msg and then use to fix this issue. But before I finish the ipcrm cmd,the AIX systerm was restarted by using . After this,the cicscp cmd failed with the following: I've tried execute it under debug mode,but got no useful information. Who... (0 Replies)
Discussion started by: tiger_wen
0 Replies

5. Shell Programming and Scripting

script to run as a daemon

Hi, I have one query that is suppose if I have a script that pick up some files from source folder and put it into destination folder , and I want this script to run after every 1 hour, to make it configurable as per that I have options like crontab and nohup but when I test this script I have to... (2 Replies)
Discussion started by: nks342
2 Replies

6. Shell Programming and Scripting

run this script as a daemon process

Hi, HI , I have a simple script that moves files from one folder to another folder, I have already done the open-ssh server settings and the script is working fine and is able to transfer the files from one folder to another but right now I myself execute this script by using my creditianls to... (3 Replies)
Discussion started by: nks342
3 Replies

7. Shell Programming and Scripting

Creating a daemon to run in background

I am trying to create a service to always run and monitor a script that has a tendency to hang, we could not find what is causing it to hang so are in the process of completely reprogramming just about everything, however, that will take upto 6 months. So I need to create this to monitor the... (5 Replies)
Discussion started by: ukndoit
5 Replies

8. Red Hat

Killing child daemon started by parent process

Hi All, Hope this is right area to ask this question. I have a shell script (bash) "wrapper.sh", which contains few simple shell command which executes a "server.sh" (conatins code to execute a java server) as a daemon. Now what I want to kill this "server.sh" so that the server should... (2 Replies)
Discussion started by: jw_amp
2 Replies

9. Shell Programming and Scripting

Run shell script as a daemon

I have simple shell script that I run as cron job every hour of the day. I would like to make it a daemon that runs far more frequently like every 30 seconds or so, but I have never made daemon before. How can I do this? -Sam (7 Replies)
Discussion started by: Sammy_T
7 Replies

10. UNIX for Dummies Questions & Answers

I would like to know Would you run the ‘identd’ daemon on UNIX servers?

Would you run the ‘identd' daemon on UNIX servers? can you please Explain. thanks in advance! (3 Replies)
Discussion started by: xoxouu
3 Replies

Featured Tech Videos