Linux space problem


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Linux space problem
# 1  
Old 10-21-2002
Question Linux space problem

I am very new to Linux and trying to install Oracle 9.2 on Red Hat Linux 7.2. My problem: /tmp needs to be larger in order to install Oracle. It is 64MB now. How can I resize this? I'm totally confused !!

Thanks.
# 2  
Old 10-22-2002
It's been a while since I last used linux but in FreeBSD you can "grow" your partitions. I'm guessing that this feature would be available in the latest versions out there.

If your dual booting are you able to mount your C: and create a directory there so Oracle can use it instead of /tmp under linux?

Don't know much about Oracle so I don't know if you can point it to any other directory other than /tmp.

Smilie
# 3  
Old 10-22-2002
normally in linux / is the only partition and that is all sub dirs except if you made a different partition table then /tmp is a drive/partition. partition magic can handle linux partitions and resize them (atleast ext2 ). so you could make that partition bigger. and other option is let it point to an other drive. but that let you loose 64mb if your tmp is that big. (ln -s /mnt/partition /tmp) not sure if it is perfect. but that would make /mnt/partion point to /tmp and everything you write there will be written to /mnt/partition. if that is bigger it will be done.
# 4  
Old 10-22-2002
Something I was thinking of was creating a temp sub-dir under a filesystem with more space and then using a softlink ot the new temp sub-dir while installing Oracle.

After that, you can destroy the softlink and delete the newly created sub-dir and continue down the road.

The only problem that I can see with this is that it might interfere with other processes.

I reckon that you could drop to single user, tar the current /tmp and create the new sub-dir, un-tar the archive, create the symlink and go back to multi-user and see what happens.

YMMV.
# 5  
Old 10-22-2002
YMMV???

Smilie
# 6  
Old 10-22-2002
Your Milage May Vary...
# 7  
Old 10-22-2002
Quote:
Originally posted by Kelam_Magnus
YMMV???

Smilie
UberSecret code words. If you didn't get the memo, you don't need to know. Smilie


SmilieSmilieSmilie
 
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. AIX

Problem space used on AIX 5.3

Hello everyone, Sorry for my English but i'm French. I have a problem on an AIX 5.3 server on the occupation of a file system. When i run a df -m, this is what i get : Filesystem MB blocks Free %Used Iused %Iused Mounted on /dev/fslv09 3936.00 340.94 92% 7255 ... (8 Replies)
Discussion started by: Veis
8 Replies

2. What is on Your Mind?

Is Unix/Linux used in space exploration?

I was looking at some Wikipedia articles on spacecrafts and robotic probes and found a reference of an OS named "VxWorks" which I have never heard of before; according to the article this OS has been used in a few NASA projects. So now I'm wondering what OS flavor or branch all those amazing... (8 Replies)
Discussion started by: verdepollo
8 Replies

3. UNIX for Dummies Questions & Answers

File Space Problem

I have a file which have 2 columns. chris doc,male test,female So in order to store the content of the first column i am doing this :- for line in $( cat $test.csv ); do FIRST_COLUMN_VAR=$( echo $line | cut -d"," -f1 ) SECOND_COLUMN_VAR=$( echo $line | cut -d"," -f2 ) ... (18 Replies)
Discussion started by: chris1234
18 Replies

4. UNIX for Advanced & Expert Users

Swap space problem

Hy! Recently i had a problem with one of mine Tru64 machines. It started to kill processes because of low amount of swap space. It said that it went below 10 %. But when i ran swapon -s it said: In-use space: 12 % So, the system couldn't accept any new ssh connections plus it killed most of... (1 Reply)
Discussion started by: veccinho
1 Replies

5. UNIX for Dummies Questions & Answers

Space problem in files

Hi, I have a file containing a list of entries. Want to do ls on them. for a in `cat <list.txt>`; do ls $a; done; Now some entries contain spaces. How do i incorporate space in $a. Quoting $a in "" doesn't help. Thanks (6 Replies)
Discussion started by: vibhor_agarwali
6 Replies

6. Shell Programming and Scripting

Everywhere space problem

Solved.... (1 Reply)
Discussion started by: redbeard_06
1 Replies

7. UNIX for Advanced & Expert Users

Swap Space Problem?

Over the last couple of days my laptop has been stalling terribly on bootup and when starting up applications (even a terminal takes ages to come up) Whilst trying to figure out whats happened I noticed that nothing is being swapped out. Output from top command shows that I have approx 500mb... (2 Replies)
Discussion started by: silvaman
2 Replies

8. Filesystems, Disks and Memory

problem with swap space

I have sun solaris 8 for intell with 128m physiccal ram and swap of 148. Oracle requires to have 512M swap space. Is there a way I can change the swap space on intell machine without repartioning the box:? what if i create a link to /swap from another place???? pls advise Jigar (1 Reply)
Discussion started by: jigarlakhani
1 Replies

9. UNIX for Advanced & Expert Users

Problem with space

I am in the initial stage of learning UNIX. I got PC with Intel SUN SOLARIS S/W. I am planning to install Oracle on the same machine. I have created /export with more than 3gb space, when I have installed the OS. As a Oracle user when I am trying to create a directory I am able to get only 512... (4 Replies)
Discussion started by: suraj
4 Replies
Login or Register to Ask a Question

Featured Tech Videos