Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers strange
# 8  
Old 11-13-2002
I am confused... if the update.db is used to locate files on Linux, does that mean any files that I add during the day will not be visible until the slocate.db is run at the end of the day or whenever it is supposed?
I tested it out and actually Ic annot locate the files I created a moment ago as root until I run updatedb. Am I missing something or is there a problem with my machine?


# 9  
Old 11-13-2002
From the locate man page:

You can also use the environment variable LOCATE_PATH to set the list of database files to search.
Please post the output of this command when you are root:


Then su or login as a non-root user and do the same thing. Cut and past the output into your next reply Smilie
# 10  
Old 11-13-2002
By the way, yes, you do need to update the DB before it'll see any files...
Also, seeing that you are using slocate, there are some things to keep in mind.
slocate stores user permissions to make sure a normal user can't see files they shouldn't... Try doing something like "slocate exec" as a normal user, then execute the same query as root - you'll usually get more matches as root...
# 11  
Old 11-14-2002
Livin Free:
u/s your point about not being able to find the same number of files as a user than as root. But the problem remains... I cannot locate at all as an ordinary user.

The permissions of my slocate.db is 640. Is that the reason of this problem. I do know sometime back I was able to locate as an ordinary user as well. So I don't know why this issue crept up.

>>You can also use the environment variable LOCATE_PATH to set the list of database files to search.

This Env variable is not set. I draw a blank both as root and as myself.
# 12  
Old 11-14-2002
640 is what I have...
I have the slocate directory 750, and slocate.db file 640.
Both are owned by root, and their group is "slocate".

The /usr/bin/slocate binary is owned by root, group "slocate".
The binary is Set GID - is yours?
# 13  
Old 11-15-2002
I have 751 permissions set on /usr/bin/slocate/ directory(there is a symlink to slocate which has 777 permissions... this is what I could interpret as I could see ) . U think I should change this to the one as yours. The owner and group are the same as yours.
I was unable to change the mode from 751 to 750... I get a msg

chmod: /usr/bin/locate: operation not permitted.

I am issuing this as root (I am on a vnc xTerm).
thanks for the help
# 14  
Old 11-15-2002
Seems to me you should (properly) set your LOCATE_PATH environmental variable first before working on changing permissions, etc.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

strange numbers when df a fs

Hi, when i execute a df, look what such a strange numbers appear Does anybody know why these numbers appear??? is it critical?? is there a way to mend it? df -k Filesystem kbytes used avail capacity Mounted on /dev/md/dsk/d704 2033295 18446744073707800956 3722957... (3 Replies)
Discussion started by: pabloli150
3 Replies

2. UNIX for Advanced & Expert Users

strange output with du

Can someone please explain why I get two outputs with the du command? The first one gave me one. I also didn't ask for the second directory so why did it give that directory? $ du -h "/media/Part 1/Desktop/playlist" 775M /media/Part 1/Desktop/playlist $ du -h "/media/Part... (1 Reply)
Discussion started by: cokedude
1 Replies

3. Solaris

Strange Messages

Dear Solarizer, Every time i log in to the sheel i always got this messages, How to stop this messgaes permanently. tpx@plood/export/home/ $ Jul 29 11:35:00 plood sendmail: unable to qualify my own domain name (plood) -- using short name Jul 29 11:35:00 plood sendmail: unable to qualify... (3 Replies)
Discussion started by: tpx99
3 Replies

4. Shell Programming and Scripting

A Strange Behaviour!!!

Can some-one give me a view to this : I have a directory in an unix server, having permissions r-xr-xr-x .This directory is basically a source directory. Now there is another directory basically the destination directory which has all the permissions. Note:I log in as not the owner,but user... (5 Replies)
Discussion started by: navojit dutta
5 Replies

5. Shell Programming and Scripting

Strange one (likely something simple...)

Right folks... this is probably something simple that I'm missing as it's early, but can anyone tell me what's going on here: The Script: cougar:/usr/hxscripts>vi ~/test.ksh "/usr/home/branch/users/tech/test.ksh" #!/bin/ksh LOGDIR=/usr/hxscripts/LOGS/logmeoff/ # Logging directory,... (6 Replies)
Discussion started by: alexop
6 Replies

6. Shell Programming and Scripting

Strange Logic

I am trying to read a file and skip few records based upon the following two columns. Pipe delimiter used between the two columns. Column1|Column2 Property|CutOff Target|11111 Min|9999 Max|10000 Comment|This is a test Property|Weight Target|222 Min|3434 Max|77777 UOM|mm ... (5 Replies)
Discussion started by: ganesh123
5 Replies

7. Solaris

Something strange...

Hi all, Thanks for any replies and for reading in advance. We have upgraded one of our database instances to 10g on a Solaris 8 box, anyhow the other day it started trying to ping loads of weird IP addresses that we don't use, since our systems all run on pretty similar IP's. It all behind... (0 Replies)
Discussion started by: B14speedfreak
0 Replies

8. AIX

Strange ls results..

Multipart question.. Can anybody explain why this happens : -rw-rw-r-- 1 fnsw fnusr 1531061 Feb 13 21:45 filename1.log -rw-rw-r-- 1 fnsw fnusr 1760706 Feb 10 22:10 filename2.log -rw-rw-r-- 1 fnsw fnusr 1525805 Aug 16 2005 filename3.log -rw-rw-r-- 1... (3 Replies)
Discussion started by: dbridle
3 Replies

9. Shell Programming and Scripting

Strange question

Good day. I whant to put in a "readkey" function into my script. My script will be running in "real time". Basicaly I whant to add a eg. "Press X to exit" statement into my script. More or less like the read command, but I don't whant it to wait for the user to press enter. eg. Readkey. If no... (5 Replies)
Discussion started by: Blooper
5 Replies

10. UNIX for Dummies Questions & Answers

Strange error

Hi all, i executed a script. cat <filename> | grep <pattern> | awk '{print $1}' | read a i get the answer when i execute it in the shell env (no problem with that) as ./<name>.ksh when i tried the same in cron (as an entry in cron) value is not being read in the variable a through... (1 Reply)
Discussion started by: matrixmadhan
1 Replies
Login or Register to Ask a Question