.rhosts and rsh command

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers .rhosts and rsh command
# 1  
Old 09-26-2002
.rhosts and rsh command

Hello all,

Ok. Here it the scope I have two Redhat 7.2 machine which I use to test things on. I have a home directory which is NFS mounted via NIS. I have a .rhosts file in the directory with the name of the machine and username, with permission 600. Be when I try to run a rsh command I get permission deny. I do not have anything in my hosts.allow, hosts.deny nor hosts.equiv. I'm stuck as to understaning why I'm unable to run rsh command. THANKS IN ADVANCE
# 2  
Old 09-26-2002
Which type of user are you logging in as??
# 3  
Old 09-26-2002
I'm log in as a normal user uid 33 gid 530. This user is not a sudoer.
# 4  
Old 09-26-2002
You might checkout this site. -mk
# 5  
Old 09-26-2002

I have looked in to that already. To my understanding if you DON NOT have any entires in your hosts.allow, hosts.deny or hosts.equiv. The deamon would look in your home directory for your .rhosts file if there were no entires in thoses files. This file should tell the deamon that the machine and hostname is OK and will grant permission. My question is why I'm I not about to do this even tho I have a .rhosts file in my home directory. Did I setup my in.rshd wrong. Should I add my user name in the /etc/xinetd.d/rsh file to the user? DNS is not a problem. I can ping to it ( the rsh to machine). ANYONE??
# 6  
Old 09-28-2002
Please check the /etc/inetd.conf

All the ftpd,rshd,telnetd entries are made in that file

This entry should be there in the HOST machine

Most probably the rshd portion is commented..

Some SYSADMINS won't allow rshd for security reasons

If you can change that file remove the comment portion

# 7  
Old 10-07-2002
This may be a basic question, but do you have the rpcd running? I believe that may be the cause of your problems.

Also, try another userID on each of the two boxes without NFS mounted home directories and put a .rhost in each home dir and see if that will allow you to run rsh.


Hope it works!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

After reboot the .rhosts file in nobody nobody

Hi All, I have a station in solaris 10 in a environnemet NIS. after reboot of the station the file ". rhosts" has the UID / GID nobody. Could you please help me to find the solution? Thx. Vince (0 Replies)
Discussion started by: Vince78
0 Replies

2. Shell Programming and Scripting

rsh command - ksh

Hello, I am trying to run a remote file (y.ksh) using rsh. In this action i want to use an environment variable TOOL=/home/macc1 i am running the rsh from profile macc on server1. rsh server2 -l macc1 "$TOOL/y.ksh" but i can see that the executable command = /home/macc/y.ksh and not... (1 Reply)
Discussion started by: LiorAmitai
1 Replies

3. Shell Programming and Scripting

rsh command

Hi Does anybody know how to to return the exit code of a remote command when using rsh? I know that "rsh" has no built-in ability for that. The echo $? is showing the results of the rsh command. Not the remotely executed command. I am trying to get the return code of psef command from... (4 Replies)
Discussion started by: aoussenko
4 Replies

4. Solaris

Problems with rsh command

Hello guys, I have a script in a Linux server, from where I go to 3 Sun servers and run process. Now i have done an upgrade and increase 1 Sun server more, now i need to run the shell in the Linux Server (into the shell is rsh command), but when i try to do ir with the new Sun server, i hace the... (3 Replies)
Discussion started by: lestat_ecuador
3 Replies

5. Linux

rsh command

we want to execute remote script via rsh (we just only should use rsh except others),but rsh command can not set environment variable for specify user, then scripts can not be executed correctly,anyone knows how to fix this problem? thanks. (8 Replies)
Discussion started by: Frank2004
8 Replies

6. UNIX for Dummies Questions & Answers

rsh command

Hi, I am a beginner and i want to seek help I want to use the rsh command. Is there a possibility that i can do it without the system password I am planning to make a csh script that could browse/copy files from diferent workstations. thank you.... (5 Replies)
Discussion started by: wramonzon
5 Replies

7. Red Hat

rhosts file...

Hi all, Thanks for reading and any susequente posts.... ... I am running a RedHat Ent 3 server. Anyhow I have to do an rlogin to install some software on the box. The problem is that the solaris box I am trying to do the install from carn't get an rlogin. I have tested this with other... (1 Reply)
Discussion started by: B14speedfreak
1 Replies

8. Shell Programming and Scripting

RSH command

Hello, I am trying to determine 2 things on a remote host. 1. Is file a directory or file 2. Does the file or directory exist Not too familiar with "find" command although I believe that may be a possible way. I have tried: remsh "$HOST" test -e /home/test.script && echo "yes" This... (3 Replies)
Discussion started by: bestbuyernc
3 Replies

9. UNIX for Dummies Questions & Answers

rsh command

Hi, I'm performing a data migration from an Ingres db to an Oracle db. The ingres database lives on a unix host running "UNIX(r) System V Release 4.0 (SunOS 5.5.1) ", while the Oracle database lives on another unix host running "SunOS 5.8". Part of the migration is to remotely run Oracle's... (1 Reply)
Discussion started by: strpeski
1 Replies

10. UNIX for Dummies Questions & Answers

Rsh command

Newbie here, I want to add a line to our 3D rendering scripts that will send an email to the animators once a scene has finished rendering. The 3D scripts are on the client hosts and the sendmail setup on the server. I tried using a rsh line in the script as follows rsh root@blah echo... (2 Replies)
Discussion started by: flamethrower
2 Replies
Login or Register to Ask a Question