Visit Our UNIX and Linux User Community


how to read a tape?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers how to read a tape?
# 1  
Old 09-25-2002
how to read a tape?

Dear all,

I have searched the topics and have not found an answer to my problem.
I wish to view the content of a backup-tape. I use the command cpio with the following parameters: -itcB and to round it all of: < /dev/rmt/0cbn for the tape.

cpio -itcB < /dev/rmt/0cbn
Result:
cpio: I/O error on "input", errno 12, Not enough space
1 errors

Am I missing something here?

Carl.
# 2  
Old 09-25-2002
Hammer & Screwdriver

Try cpio with the command -icBvt
# 3  
Old 09-25-2002
Thanks!

Executing this command (cpio -icBvt) will give me the following error: cannot open.
Now, this might be because the label of the tape has been deleted. I will try this tomorrow after the backup has run.

Keep you posted.
# 4  
Old 09-25-2002
cpio vs tar?

I am just curious why you use cpio vs tar. Are there advantages for your environment over using tar? Was this just the way it was setup when you took over the backups?

I know that cpio is very good for moving directory trees and files. I used this extensively in my last job.

Just curious... Smilie
# 5  
Old 09-25-2002
Hi,
Why not using ufsdump and ufsrestore I know that they are extremely powerful. We use them in our system.
# 6  
Old 09-26-2002
Wow, what a lot of people helping me out.
Okay, I'm a real newbie, so help me out here...

We use savegrp to perform a backup of our unix-system. I don't know if this has anything to do with the commands failing?

About all other suggestions: I'll check them out to find the correct parameters/commands for my purposes.

It's still not working, but I really appreciate all your suggestions. Keep on unix!
# 7  
Old 09-26-2002
What is your O/S i.e Solaris, Aix, SCO etc

most versions of Unix have the cpio and tar commnads. To make sure your tape drive is working to begin with, create a file in /tmp Lets say call it backuptest (touch /tmp/backuptest)

use either command to write to the tape

tar cvf /tmp/backuptest > /dev/rmt/0cbn
To read it back, rewind the tape then
tar tvf < /dev/rmt/0cbn

or

find /tmp/backuptest -print | cpio -ocBvdum >/dev/rmt/0cbn
To read it back, rewind the tape then
cpio -icBvt </dev/rmt/0cbn

If you use AIX, I would suggest using the mksysb (Full system backup command)
If you use Solaris, I would suggest using the ufsdump command
and for SCO proberly best to use tar.

Hope it helps
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #765
Difficulty: Medium
Cache read misses from an instruction cache generally cause the longest delays because the processor, and in particular the thread of execution, has to wait until the instruction is fetched from main memory.
True or False?

9 More Discussions You Might Find Interesting

1. AIX

Ejecting tape on AIX & Some Tape commands

I am trying to use this command to eject the tape mt -f /dev/rmt/0 unload but it gives me error mt -f /dev/rmt/0 unload mt: 0511-575 unload is not a recognized subcommand. Usage: mt Subcommand Valid subcommands are: weof eof fsf bsf ... (5 Replies)
Discussion started by: filosophizer
5 Replies

2. AIX

Tape drive problem - no process to read data written to a pipe

Hi Everyone, The machine I'm working on is an AIX 5.3 LPAR running on a P650. oslevel -r shows 5300-08. I'm trying to take a backup to a SCSI tape drive, which has been working up until this point. I know of nothing that has changed recently to cause this problem. But when I try to take a... (0 Replies)
Discussion started by: need2bageek
0 Replies

3. AIX

LTO3 Drive to read LTO3 tape with LTO4 content

Dear all experts, I have a LTO3 tape drive and thinking of upgrade to LTO4 drive. Before we proceed to upgrade, I have 1 question to ask. As I will use the backup tape to restore into other server (pSeries p550), I have the problem of if I backup in LTO4 tape in future, how can I restore the... (1 Reply)
Discussion started by: kwliew999
1 Replies

4. UNIX for Dummies Questions & Answers

Read a "Tape" File with no extension, in Windows

I've been sent a file by a client that has no dot extension, which I'm told should be a MSSQL7 database with information I need to get out and ultimately export for upload to another system. My issue is that I have no idea what to do with this file. The properties indicate it's a Unix executable... (1 Reply)
Discussion started by: buccacom
1 Replies

5. SCO

Tape Status shows 2 Hard errors and 5 Underruns on new tape

when I do a tape status /dev/rStp0 I get the following on a new tape and I have tried several: Status : ready beginning-of-tape soft errors : 0 hard errors: 2 underruns: 5 My BackupEdge has stopped backing up my system because it asks for a new volume yet my total system data is under 20... (5 Replies)
Discussion started by: psytropic
5 Replies

6. UNIX for Dummies Questions & Answers

Can UNIX data on tape be read in Windows??

Hello All: We have acquired a business (UNIX system) and inherited data which is on SDLT tapes. We'd like to read this data and save it in Windows format, if possible. Anyone in the know on how to do that, if feasible? Please give your suggestions. Regards (2 Replies)
Discussion started by: yourstruly
2 Replies

7. UNIX for Dummies Questions & Answers

Mounting DLT tape and to backup file to tape

Hi there: I'm new here Can anyone help me: I have DS15 Alpha server : Unix 5.1B Now i need to connect a DLVT VS80 1U Rackmount Tape Drive unit. What is the exact comman to mount the DLTape IV?? How do i make backuo @ copy file to the tape? Thanx to all (0 Replies)
Discussion started by: ayzeayem
0 Replies

8. UNIX for Advanced & Expert Users

Space free on tape /delete a single file on tape

Hi, I' using a sun solaris server, I would like to known if there is the possibility to control how many space is free on a tape and how I can delete a single file on a tape. Thanks DOMENICO (3 Replies)
Discussion started by: Minguccio75
3 Replies

9. Post Here to Contact Site Administrators and Moderators

Using the DD command to read an ISeries tape

An ultrium 2 tape was sent to our site to extract the data. The problem is that they did not send instructions on how it was backed up, block size, etc. Since then I found out that they used the DD command. I tried running the following but it extracted only 3 lines worth of data. It appears... (1 Reply)
Discussion started by: osuna
1 Replies

Featured Tech Videos