Visit Our UNIX and Linux User Community


what is /dev/pts/1


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers what is /dev/pts/1
# 1  
Old 09-24-2002
what is /dev/pts/1

hi, i ran tty and get this /dev/pts/1?

what does /dev/pts/1 indicates about my terminal and the device files? thanks
yls177
# 2  
Old 09-24-2002
That is your terminal device (psuedo terminal 1).
# 3  
Old 09-24-2002
The purpose of "tty" is to echo you the name of the terminal you're currently logged on to. Yours happens to be /dev/pts/1
# 4  
Old 09-25-2002
re:

is there any difference between terminal device and psuedo terminal ? thanks
yls177
# 5  
Old 09-25-2002
A terminal device is a dummy terminal. Just a monitor and a keyboard connected directly to the unix machine through a serial port. It does nothing except provide a way for you to work directly on the unix machine.

A pseudo terminal device is a program, such as telnet, which fools unix programs into thinking you are sitting at a dummy terminal connected through a serial port. In reality, you're using Windows and a program which emulates a terminal window inside of Windows.

It has to do with the internal workings of unix and is more of a concern for programmers when they're making programs like telnet...
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #146
Difficulty: Easy
In 1983, Richard Stallman announced the GNU (short for "GNU's Not Unix") project, to create a proprietary, commercial software Unix-like system.
True or False?

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Problem with PTS

Hello, Im working with an m4000 server, with solaris 11. the problem is when users connect to the server, I have the range from pts/65 to pts/128 "blocked". The system does not take any pts of that range. Usually a close all the connections and the problem is solved, but this time that solution... (3 Replies)
Discussion started by: salvador_cast
3 Replies

2. Solaris

Lun remove, stuck in /dev/dsk and /dev/rdsk

So, we removed a LUN from the SAN and the system is refusing to remove the references to it in the /dev folder. I've done the following: devfsadm -Cv powermt -q luxadm -e offline <drive path> luxadm probe All those commands failed to remove the path. The drive stills shows up as <drive... (13 Replies)
Discussion started by: DustinT
13 Replies

3. UNIX for Dummies Questions & Answers

Sending alt-n to /dev/pts/1 from process bound to /dev/pts/2

Hello, i am using finch (unix commandline instant messaging client using libgnt) which is running connected to /dev/pts/1 Now I would like to "remote control" the program by sending the key combinations normally typed on the keyboard from a programm in another shell. So I tried:... (0 Replies)
Discussion started by: mentos
0 Replies

4. UNIX for Dummies Questions & Answers

pts and tty

hi iam very new to linux can anyone tell me about pts and tty acctually today morning i logged into my pc at 9:51 when i have given #who it has given sam tty7 9:51 sam pts/1 10:11 so what does it mean (1 Reply)
Discussion started by: praneel2k
1 Replies

5. Solaris

What is /dev/tty /dev/null and /dev/console

Hi, Anyone can help My solaris 8 system has the following /dev/null , /dev/tty and /dev/console All permission are lrwxrwxrwx Can this be change to a non-world write ?? any impact ?? (12 Replies)
Discussion started by: civic2005
12 Replies

6. UNIX for Dummies Questions & Answers

Switching the active pts?

My apologies in advance if this question has already been asked or if I use incorrect terminology; I have tried searching for nearly an hour without any luck. Is there any way to change the active TTY for a session? I was monitoring a long (~5 hour) process through an SSH connection and the... (4 Replies)
Discussion started by: tspicher
4 Replies

7. UNIX for Advanced & Expert Users

one of the mount pts 100%

Hi all, recently we had a critical error like one of the mount points /online was 100% full. Even when we deleted three ( 3 ) 0.5 GB files available space in /online mount was not increasing rather df -k for /online continued to show as 100% full. what could be the problem, even... (6 Replies)
Discussion started by: matrixmadhan
6 Replies

8. UNIX for Dummies Questions & Answers

finger, getting name and pts from ip addr

im ultra new at unix and was wondering if its possible to create aliases of the write command that send messeges to users using an ip address. i was thinking to use the '|awk' with the command finger but as i've said im a total newbie. thanks a lot in advance. (2 Replies)
Discussion started by: swag:
2 Replies

9. UNIX for Dummies Questions & Answers

who -uH, kill the process at different pts/tb

i log in as root and is in pts/11 , do a who -uH, got the below root pts/11 Dec 11 08:01 0:10 11588 root pts/12 Dec 11 09:09 0:03 12001 now do a ps -ef | grep pts/12, get the below root 12133 12107 0 09:18:22 pts/13 0:00 vi myoracle root 12107 12105 ... (3 Replies)
Discussion started by: yls177
3 Replies

Featured Tech Videos