stepping through ascii file

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers stepping through ascii file
# 8  
Old 08-29-2002
I just retested it and it continues to work for me. You could not have made the change that you said since the string $target does not appear anywhere in my post. Put it back the way I wrote it. And specify FULL as the argument when you run the script.
# 9  
Old 08-29-2002
I don't understand - when I tried your script it wouldn't work either. It waits for input and when I type a word in and hit enter, it just keeps waiting for more input..

What command in your script tells the script what file to search in?
# 10  
Old 08-29-2002

Smilie The solution that auswipe provided worked. Thank you all for your help.
# 11  
Old 08-29-2002
Originally posted by rehoboth
Smilie The solution that auswipe provided worked. Thank you all for your help.
*Jumps on desk and beats chest, co-workers look puzzled*


Glad it worked for ya.
# 12  
Old 08-29-2002
Originally posted by oombera

What command in your script tells the script what file to search in?
You're supposed to redirect it in:

./script FULL < someinputfile

or maybe pipe it in:

someotheutility | ./script FULL
# 13  
Old 08-30-2002
Ok. I got that working too. Thank you everyone for your input.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Convert Hex to Ascii in a Ascii file

Hi All, I have an ascii file in which few columns are having hex values which i need to convert into ascii. Kindly suggest me what command can be used in unix shell scripting? Thanks in Advance (2 Replies)
Discussion started by: HemaV
2 Replies

2. UNIX for Dummies Questions & Answers

After Ftp'ing file to destination how to check the file if it is in correct ASCII and not corrupted

Hi Folks, While transferring file from FTP software like Filezilla the files gets corrupted. Is there any way I can check if the recently transferred file is in ASCII and not corrupted. I have tried using file -i filename command which does tell if the file character set is ASCII or binary... (6 Replies)
Discussion started by: Khan28
6 Replies

3. Shell Programming and Scripting

Perl Debug Stepping Answering Questions

I am new to perl and want to get a little better understanding of debugging code in perl. I have a perl script that has questions to be answered like: he following PERL modules are recommended: Crypt::DES Crypt::PasswdMD5 IO::Pty Net::Write::Layer2 String::CRC32 Attempt to install... (0 Replies)
Discussion started by: metallica1973
0 Replies

4. Cybersecurity

Firewall bypass or stepping stone security question

Hi, I really do not know how to describe this problem; but, I think it's a firewall issue. My Distro is Slackware 12.0 (somewhat updated). My company firewall uses Netfilter and the e-mail server uses Sendmail. Let's say the firewall's Ext IP = A and Internal DMZ IP = B. The firewall's... (0 Replies)
Discussion started by: cc_ew
0 Replies

5. Solaris

stepping through newfs

On a RAID-5 solaris 9 server, we replaced a bad disk. Upon boot up, a mount point failed: vxvm:vxvol: ERROR: Volume IQ_Staging is not startable; some subdisks are unusable and the parity is stale With Sun tech support, we tried vxvol start and vxvol resync, but it remained... (3 Replies)
Discussion started by: abstractrick
3 Replies

6. SCO

Stair-stepping printing

Hi, We have a Unix 3.2v5.0.5. I installed a printer via scoadmin, HP network printer manager with network peripheral name an ip-adress. I have a lot of trouble, the printer do stair-stepping. I know it is because of the translation LF to CR/LF. But it is impossible to set this correct in... (2 Replies)
Discussion started by: haezeban
2 Replies

7. Shell Programming and Scripting

convert ascii values into ascii characters

Hi gurus, I have a file in unix with ascii values. I need to convert all the ascii values in the file to ascii characters. File contains nearly 20000 records with ascii values. (10 Replies)
Discussion started by: sandeeppvk
10 Replies

8. Linux

Stair stepping

Is there a command line flag to lpr or a utility similar to the Unix 'xtod' command to fix stair stepping when printing? Under Unix I would: # cat textfile | xtod | lp -d lineprinter Anything like that for linux? Thanks (1 Reply)
Discussion started by: lochraven
1 Replies

9. Shell Programming and Scripting

Rsync script in cron from stepping on itself

I have the following rsync script that I use for syncing MySQL files from one server to another. I run the script at 20 minutes past every second hour in cron. I want to make sure that the script completes in it's entirety before it is set to kick off again. For example, when the script starts at... (3 Replies)
Discussion started by: sunsysadm2003
3 Replies

10. UNIX for Dummies Questions & Answers

Scripting stepping stones.

It's safe to say that I have had no scripting / programming experience before. I took a job as an AIX / Linux administrator, and I have found myself up to my ears in bash scripting. I'm starting to really catch on, I've become a casual linux user, to a hopeful future power user. I was... (2 Replies)
Discussion started by: syndex
2 Replies
Login or Register to Ask a Question