Visit Our UNIX and Linux User Community


tar expanding trouble


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers tar expanding trouble
# 1  
Old 08-26-2002
Data tar expanding trouble

Hello,

I have just download a .tar.gz
when I run:
$tar x *.tar.gz
or even
$tar z *.tar.gz

this is the error I get
tar: can't open /dev/sa0 : Device not configured

How do I reconfigure the device so that it expands the file in it's current location?

Thanks so much for your help!
# 2  
Old 08-26-2002
I haven't fooled with tarred files much yet, but:

What about that .gz extension? Try this:

1. create a temporary directory somewhere and move the tarred file into it
2. tar zxf filename.tar.gz

Reference:
https://www.unix.com/showthread.php?...threadid=4805
# 3  
Old 08-26-2002
Thanks man!!

That worked
# 4  
Old 08-26-2002
The gz is a zip that you should take off first.

i.e. gunzip filename.tar.gz you canthen pipe that through tar do do both in one command line.
# 5  
Old 08-26-2002
Just for clarification, some versions of tar can automagically uncompress the file when it sees the z flag. The f flag tells it where to look - the default is usually a tape device on your system (in the OPs case, /dev/sa0, which is not attached to a tape drive).

Check your man page for tar to see if your tar acts in this way.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #268
Difficulty: Easy
In 1936, Turing published his paper 'On Computable Numbers, with an Application to the Entscheidungsproblem'. In this paper, Turing reformulated Kurt Godel's 1931 results on the limits of proof and computation, replacing Godel's universal arithmetic-based formal language with the formal and simple hypothetical devices that became known as Turing machines.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Longlist files without expanding

Hi, I want to long list files within a file.tar.Z/file.tar.gz file. I tried these: I'm working on HP UX 11iV3 OS tar -tvzf file.tar.gz -->not working as 'z' is not supported gunzip -c file.tar.gz | tar tvf - -->does this unizip the tar file? i don't want it to be unzipped. ... (1 Reply)
Discussion started by: sam_bd
1 Replies

2. Red Hat

Trouble with .tar creation over NFS mount

Hello, I am trying to backup a directory to an NFS mount. But after mounting the "tar" command is failing. 1. Created folder for mount point: test1 2. Mounted desired mount: # mount -t nfs server_name2:/backup/WMSAPP_backup -w /test1/ # df -h Filesystem Size Used Avail Use%... (5 Replies)
Discussion started by: ikn3
5 Replies

3. Shell Programming and Scripting

tar command to explore multiple layers of tar and tar.gz files

Hi all, I have a tar file and inside that tar file is a folder with additional tar.gz files. What I want to do is look inside the first tar file and then find the second tar file I'm looking for, look inside that tar.gz file to find a certain directory. I'm encountering issues by trying to... (1 Reply)
Discussion started by: bashnewbee
1 Replies

4. Solaris

expanding RAM

our sparc server has only 1Gb RAM. Since RAM is not very expensive anymore, it seems like a good idea to upgrade it. will it make server (and database on it) faster? I hope it would less 'abuse' hard drive.. (6 Replies)
Discussion started by: orange47
6 Replies

5. Linux

Expanding slice

Hi all I am testing backupPC as a backup solution for machines, as far as i knew, backuppc cannot combine more than storage from different slices so it have to be in one slice my question is, what is the easy way to offer a virtual logical drive expanded/expandable to backuppc, i mean i want to... (1 Reply)
Discussion started by: XP_2600
1 Replies

6. Shell Programming and Scripting

expanding alias from a variable

Hi ! I am making my first steps to make a script. Therefore i try to make a scp command more easier. Given is the following alias: 14='admin@x-abcd-def.xyz Now i want to let the script read three var's from the console to use them in the script and then build the scp string. echo... (7 Replies)
Discussion started by: locutus01
7 Replies

7. UNIX for Dummies Questions & Answers

Expanding variables with Ed Bash 3.2.33

Hi, The following code finds the line containing fruits in test.txt and replaces instances of apple with banana. ed -s test.txt <<< $'/fruits/s/apple/banana/g\nw' What I want to do is put variables in the place of fruits, apple and banana. I have tried replacing ' with " to get... (2 Replies)
Discussion started by: de_la_espada
2 Replies

8. UNIX for Dummies Questions & Answers

tar -cvf test.tar `find . -mtime -1 -type f` only tar 1 file

Hi all, 4 files are returned when i issue 'find . -mtime -1 -type f -ls'. ./ora_475244.aud ./ora_671958.aud ./ora_934052.aud ./ora_934050.aud However, when I issued the below command: tar -cvf test.tar `find . -mtime -1 -type f`, the tar file only contains the 1st file -... (2 Replies)
Discussion started by: ahSher
2 Replies

9. AIX

expanding the size of vg

Hi, I have created the lun of 15gb and assigned to aix,but now I want to expand the size of lun 15gb to 30gb, I am having following queries. 1)wheather i have to umount that partition on aix side before increasing the size of lun on storage side or directly I can increase directly size... (2 Replies)
Discussion started by: manoj.solaris
2 Replies

10. Shell Programming and Scripting

Expanding shell variable

I have a question about expanding shell variables. Given the following piece of script: a="Some text" b="Other text" for i in a b do string1=$i echo $string1 --> returns 'a' string2=EXPRESSION_WITH_$i echo $string2 --> returns 'Some text' done ... (2 Replies)
Discussion started by: lonar
2 Replies

Featured Tech Videos