bash in netbsd

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers bash in netbsd
# 1  
Old 07-29-2002
bash in netbsd

i recently downloaded and installed bash on my netbsd box (1.5.2) and set my shell and my root shell using user mod to change the shell, command executed under root. bash is installed from my user home directory (home/joe) and i moved the bash executable to /bin/ and everything is fine, except i get complains from netbsd that bash isnt a valid shell, worse, i can login as root, but can not su to root from any other user, i know i did something wrong how do i fix?
# 2  
Old 07-29-2002
Is bash in /etc/shells?
# 3  
Old 07-29-2002
haha nope its not, it will be as soon as i get up to walk downstairs! i knew it was something simple, thanks
# 4  
Old 07-29-2002
uh oh............

i put bash in etc/shells and also changed the permissions of bash to match those of the previous shell (csh), but i still cant su, i could su before i set the shell as bash and on my lin box i can su, what else could be wrong?
# 5  
Old 07-30-2002
ok when i su from my user, bash says :
$ >su root
su: bash: No such file or directory
bash is there though, and when i login everything is fine, but when i su thats when things get messed up.
# 6  
Old 08-01-2002
Hammer & Screwdriver

I think: maybe your bash has problem. Let's reinstall bash from package or use another Shell
# 7  
Old 08-01-2002
maybe so, i think maybe the problem could be cause bash is installed in my home directory? i was too anxious and didnt care to copy the tgz to another directory, well ill try it and let you guys know how it went, thanks for the help
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. BSD

NetBSD on OLD laptop

I want to install NetBSD on the Compaq LTE 5000. ("Of course it runs NetBSD!!") But the laptop does NOT have a CD-ROM drive. How can I solve?? Thanks for any reply! :) PS: I hope i'm posting in the right item... (2 Replies)
Discussion started by: mghis
2 Replies

2. Virtualization and Cloud Computing

NetBSD on VirtualBox

Hello, guys! I use Ubuntu 9.04 as desktop operating system and I want to make some tests on NetBSD. I tried to install as a virtual sistem on VirtualBox but it doesn't want to install. You can see the error in the attached file. Do you guys have any clue about what the problem could be? (3 Replies)
Discussion started by: Sergiu-IT
3 Replies

3. UNIX for Dummies Questions & Answers


which better freebsd and netbsd for server unix (0 Replies)
Discussion started by: salehudinayubi
0 Replies

4. BSD


i have install netbsd but don't have gui?what happen?i want to a mount external usb hard drive but failure?what should i do? (5 Replies)
Discussion started by: ibnusina202003
5 Replies

5. BSD

Anyone using NetBSD pkgsrc on FreeBSD?

I confess, I'm getting a hair frustrated with the FreeBSD ports system. Is there a reasonably headache-free way of migrating all my installed apps to pkgsrc? Is it advisable or not? Or should I just change my systems over to NetBSD? Or stop worrying an learn to love FBSD ports? (0 Replies)
Discussion started by: criglerj
0 Replies

6. BSD

NetBSD Ports

They put NetBSD on a Dreamcast. Thats just awesome. What can't they put it on!? (1 Reply)
Discussion started by: Phobos
1 Replies

7. UNIX Desktop Questions & Answers

Starting X in NetBSD

Hi I have NetBSD and i am having a trouble Starting X. It keeps asking me for the config file and I run the text confing file but it messes up. I really want to be able to run the Graphical Setup. I read about the Graphical setup from a book but they didn't tell how to start it. help please!? (9 Replies)
Discussion started by: vertigo
9 Replies

8. UNIX Desktop Questions & Answers

NetBSD Troubles

HI, I just installed NetBSD i386 v. latest. I am having a few problems: For some reason X just won't start!? Another is I can't access My CDROM or Floppy. Thanks in advance! (3 Replies)
Discussion started by: vertigo
3 Replies
Login or Register to Ask a Question