umount, device busy, but..

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers umount, device busy, but..
# 1  
Old 07-26-2002
umount, device busy, but..

I'm trying to unmount a file system, but umount says the device is busy. A fuser -c /myfs tells me that nothing on this fs is in use. Any idea?

Oh, and btw, why isn't my signature beeing displayed? Show user's signature is enabled and I have entered one :/
# 2  
Old 07-26-2002


umount -f
# 3  
Old 07-26-2002
Thx, but -f isn't an available option for umount.
# 4  
Old 07-26-2002

Please be sure that fuser is getting executed from /usr/bin

have u checked path etc...

# 5  
Old 07-26-2002
It's beeing executed in /usr/sbin.
Starting it with the full path returns the same result.
# 6  
Old 07-26-2002
Rather than "fuser -c /mysys", Try the block special file without the -c. Something like:
fuser /dev/dsk/c0t3d0s6

Also try lsof if you have it. I have better luck with lsof than I do with fuser.
# 7  
Old 07-26-2002
what os are you using?


fuser -ck

the k option will kill any process or users using up the filesystem

then you could umount

Do a man umount for available options

on solaris 8 umount -f will force a filesystem to unmount.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Mount : Device busy

mount -f nfs 1234:/export/ert /der/fr/ert mount : /der/fr/ert: device busy normally I will then do an fuser filesystem and kill the pids, which I did. now if I do an fuser /der/fr/ert I get the mount point and no pid > fuser /der/fr/ert /der/fr/ert: but it... (1 Reply)
Discussion started by: goya
1 Replies

2. HP-UX

Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)

Hi, Unable to make tape backup, please help. /opt/ignite/bin/make_tape_recovery -a /dev/rmt/?mn -I -v -m tar -x inc_entire=vg00 * Creating local directories for configuration files and archive. ======= 04/25/16 16:28:08 IST Started /opt/ignite/bin/make_tape_recovery. (Mon... (4 Replies)
Discussion started by: anuragr
4 Replies

3. SCO

NFS umount shows the "Device busy (Error 16)"

Hi there After making a backup copy of it sometimes happens that when I want to unmount an NFS indicates the error:umount: /path_mount busy: Device busy (Error 16) if I run lsoff, I can not find the process that is blocking the application. I'm using OpenServer 5.0.2c as one NFS server ... (14 Replies)
Discussion started by: flako
14 Replies

4. Linux

Umount of a "busy" disk

A product I am working on manages storage. We are currently porting it from Solaris to Linux. The product allows its user, among other things, to add and remove file server volumes, where these volumes are exported using the NFS or the CIFS protocol. The problem is that when the user requests to... (5 Replies)
Discussion started by: dhzdh
5 Replies

5. Shell Programming and Scripting

Umount an entire device with multiple file systems

I wish to umount in a bash script a specific device (/dev/sdb for example) that has multiple mounted file systems. how will I go about doing this? Also is there a way to get a list of removable devices currently connected and offer the user a selection of them? (The devices themself not their... (2 Replies)
Discussion started by: temp4746
2 Replies

6. Solaris

CDROM will not eject - says device busy

Hi, I've seen similar posts on this board about ejecting CDROMs but I've tried the solutions people suggested but still cannot eject the CD. It's stuck in a production box so I can't reboot it... bash-3.00# eject -f cdrom /vol/dev/dsk/c0t0d0/sol_10_106_sparc/s0: Device busy bash-3.00#... (14 Replies)
Discussion started by: jimmy54321
14 Replies

7. UNIX and Linux Applications

/dev/ttyS2 device or resource busy

Ciao a tutti!!! il mio problema questo: sto cercando di inviare dei comandi AT da PC a cellulare utilizzando il bluetooth e cygwin e vorrei visualizzare le risposte nella shell bash. Per farlo apro due terminali utilizzando le seguente istruzioni: xterm & Sul primo scrivo cat /dev/ttyS2 ... (1 Reply)
Discussion started by: blianna
1 Replies

8. UNIX for Dummies Questions & Answers

Device or resource busy??

Hi, I'm trying to do a sharity mount to mount a terastation network drive. I'm getting a Device or resource busy message after my mount command. Please see output below... # /usr/local/sharity3/bin/sharity mount smb://labbackup01/bakup_data /mnt/labbackup01 Device or resource busy.... (2 Replies)
Discussion started by: orahi001
2 Replies

9. HP-UX

Cannot umount - device busy

Anyone have any idea why I cannot umount a directory even though fuser shows no process attached to it? fuser -cu /data/oracle/GMPSHRDM/export /data/oracle/GMPSHRDM/export: umount /data/oracle/GMPSHRDM/export umount: cannot unmount /data/oracle/GMPSHRDM/export : Device busy umount:... (2 Replies)
Discussion started by: keelba
2 Replies

10. Programming

[FreeBSD] ptrace( ) - Device busy

Hello, I'm trying to obtain process memory contents using ptrace( ) on FreeBSD 4.7. I know this is neither portable nor clean, yet I'd really like to get it to work... I read the manual help page and did a google search, but couldn't find anything helpful. First, the code I'm using to read an... (5 Replies)
Discussion started by: Driver
5 Replies
Login or Register to Ask a Question