Visit Our UNIX and Linux User Community


deboucha28


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers deboucha28
# 8  
Old 07-26-2002
deboucha28

Thanks. But I did (dir) the system replies: not found. Do I need a boot floppy disk in order to do that, if so How do I create a boot floppy disk. Thanks again.
# 9  
Old 07-26-2002
Once you boot cdrom -s and get to the # prompt, you should be able to do a ls -F (ls is the UNIX command to list files (like DIR in DOS))

To change directory the command is cd. cd to / to insure you are at the top level.
Example:
# cd /

Then follow the instructions on mounting the boot device to /a (link was given in earlier response).
# 10  
Old 07-26-2002
deboucha28

Thank you very much for your expertise, I don't mean to be a dodo bird, I follow the guide lines and did everything you told me. Now I did vi passwd and the machine replies [I don't know what kind of terminal you are on - all I have is Unknown]
{using open mode}
"passwd" [Read only] 16 lines, 571 characters
root:x:0:1:Super-User:/:/sbin/sh.
Now, the link earlier said to remove the x OR encrypted password from the root account - it will be the second field (colon separated fields) I have tried to remove the "x" but I haven't any luck. Your Help is greatly appreciated. Thanks a zillion time.
# 11  
Old 07-26-2002
Yea, it's those little things we forget like setting the term.

To set the TERM:
TERM=vt100; export TERM

vi the /a/etc/shadow file - the second field should be the encrypted password -
root:1kqcFxxj6W29s:11890::::::

Once that is removed save the file (Escape, :, wq!). cd to /, unmount the drive (umount /a) and then either init 0 or Stop-A to kill the server down to the boot prompt ( ok prompt).
# 12  
Old 07-29-2002
Hello again! I've followed all the steps, but for some odd reason I am still not able to reset the password. These are the steps that I have followed.

#ls -F
I got: etc/ kernel/ var/
I did: #cd /
" : #mount /dev/dsk/c0t0d0s0 /mnt
" :#TERM=vt100
" #vi passwd

One of hte instruction said to remove the "x" I have tried and its not working. Can anyone please help me. Thank you
# 13  
Old 07-29-2002
If you are booting off of cdrom, then / is the last place you want to be. You are mounting the 'problem' disk as a different filesystem. You will want to edit the shadow file in /a/etc, not /etc. Attempting to vi /etc/shadow will do nothing since
1. it's not the one you need
2. a cdrom is read-only.

Do this:
ok boot cdrom -s
Once you are booted with a # prompt -
# mount /dev/dsk/c0t0d0s0 /a
(If c0t0d0s0 is your boot device - if not, change to the appropriate disk)
#cd /a/etc
#TERM=vt100; export TERM
#vi shadow
In the shadow file, remove the second field in the root entry (should be the top one). The fields will be separated by :.

Save the file and then check that it worked by
# head /a/etc/shadow
You should see something like this -

root::11890::35:14:::
daemon:NP:6445::::::
bin:NP:6445::::::

# umount /a
# init 0
ok boot -s
This will boot single user off your disk - it will either send you straight to a # prompt or ask for a password. If it asks for a password, hit return. If you get the # prompt, you did it.

If not, then you didn't
1. follow the steps.
2. edit the correct file or you don't use a shadow file
3. didn't mount the true boot device to /a when booted from cdrom.
# 14  
Old 07-29-2002
Thank you for guiding me thru all the steps. One more question, how do I remove the second field in the root entry? On the bottom it says " shadow" [Read only] 16 lines, 373 characters.
Thanks again.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #142
Difficulty: Easy
Version 4 Unix was rewritten in C in 1977.
True or False?

Featured Tech Videos