Visit Our UNIX and Linux User Community


Xlib: Invalid MIT-MAGIC-COOKIE-1


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Xlib: Invalid MIT-MAGIC-COOKIE-1
# 1  
Old 07-24-2002
Xlib: Invalid MIT-MAGIC-COOKIE-1

Anyone:

I have a very annoying problem on one of our servers (running Solaris 8). when ever I try to run "xhost +" with the display set at "localhost:0.0" I get the following error:
xhost +

Xlib: connection to "finappprod:0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
xhost: unable to open display "finappprod:0.0"

echo $DISPLAY
finappprod:0.0

I've tried to recreate the /.Xauthority file by doing:

xauth generate $DISPLAY . trusted

but I get the same error. I also found this script on the web:

#!/usr/local/bin/perl

randomkey=`perl -e 'for (1..4) {
srand(time+$$+$seed);
printf("%4.5x", ($seed = int(rand(65536))));
}
print "\n";'`

xauth add `hostname`/unix:0.0 . $randomkey
xauth add `hostname`:0.0 . $randomkey

This scrip does create the /.Xautority file, but I still get the "Invalid MIT-MAGIC-COOKIE-1 " error message when running "xhost +"

Any ideas?

I'm now at a dead end.....
Smilie((((
# 2  
Old 07-25-2002
I checked on SunSolve - nothing there for your problem that I could find. I also attempted to recreate your issue - could not.

1. Are you logged into the system from the console when doing this?
2. Are you using a local user account, NIS, NIS+?
3. Are you setting localhost:0.0 as the DISPLAY or the system name:0.0? If localhost, is it defined in /etc/hosts?
4. What is your XFILESEARCHPATH equal to?
XFILESEARCHPATH=/usr/openwin/lib/locale/%L/%T/%N%S:/usr/openwin/lib/%T/%N%S
5. Does this work with other accounts on this system?
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #387
Difficulty: Medium
The Unix apropos utility locates commands using a neural network.
True or False?

10 More Discussions You Might Find Interesting

1. What is on Your Mind?

Changed Forum Cookie Prefix (You May Need to Reload Your Cache)

Today we changed the prefix of our cookie and cleared the session table and all is working fine, at least on my end because I cleared my browser javascript cache. If you experience any strange behavior (you should not), please clear your javascript cache before posting a bug here. Note: I... (0 Replies)
Discussion started by: Neo
0 Replies

2. What is on Your Mind?

Cookie to Turn on and Off Site Animations

Hi, I've been thinking about the issue of mouseovers, hovers, and site animations for thread previews and forum descriptions, etc. What I think I will do is to add a cookie and a switch in the navbar where the user can set site animations to on or off; and then use that cookie to control all... (0 Replies)
Discussion started by: Neo
0 Replies

3. Shell Programming and Scripting

Cookie authenticationn

I am trying to wget to retrieve a file from an ubuntu server. I believe I need a cookie authentication, but am am having trouble. I am reading the maual and it is not making sense. I have also tried wget http://..... --username=... --password=... Thank you. (2 Replies)
Discussion started by: cmccabe
2 Replies

4. Shell Programming and Scripting

Problem with wget and cookie

Dear people, I got a problem with an scrip using wget to download pdf-files from an website which uses session-cookies. Background: for university its quite nasty to look up weekly which new homeworks, papers etc. are available on the different sites of the universites chairs. So I wanted a... (1 Reply)
Discussion started by: jackomo
1 Replies

5. Shell Programming and Scripting

wget - cookie with expiration date

How can I create a cookie with expiration date using either wget or curl? I am able to use cli wget, cli curl, or php curl. I don't see that the cookies I have created contain an expiration date, and I have a problem logging into a forum that looks for the expiration date. (2 Replies)
Discussion started by: locoroco
2 Replies

6. AIX

module has an invalid magic number

Hello everybody: I have a trouble running an application which connects to an Oracle server, I got this message: Dependent module /opt/oracle/product/10.2/lib/libclntsh.so could not be loaded. The module has an invalid magic number. Running ldd MyApp doesn't report missing symbols, I've... (1 Reply)
Discussion started by: edgarvm
1 Replies

7. Shell Programming and Scripting

Suchen und Ersetzen mit AWK

Hallo, ich habe mir mit meinen dürftigen Programmierkenntnissen ein Script zusammengebastelt über das ich in einem bestimmten Odner mit AWK alle Dateien eines Verzeichnis durchsuche und bestimmte Bezeichungen aller Dateien ändern kann. Es funktioniert auch soweit, nur hätte ich gerne auch die... (1 Reply)
Discussion started by: ruffi
1 Replies

8. Shell Programming and Scripting

problem for CGI create Cookie!!!!

Hi Everyone, I am facing the problem to create the cookie in CGI (bash script). Is it possible can create in cgi? or javascript better? Anyone got the sample to create the cookie in cgi(bash script)? Just the login will do ->> USERNAME and PASSWORD after create how to store into the... (2 Replies)
Discussion started by: ryanW
2 Replies

9. Shell Programming and Scripting

cannot use the same script to read cookie

Hi all, I am using the following code to read a cookie. when this script is hosted on a unix server(solaris) it runs perfect. but when executed on a windows machine cannot retrieve the cookie. --------------------------------------- # Modules used use CGI; # Create an object of CGI... (0 Replies)
Discussion started by: azmathshaikh
0 Replies

10. Linux

Cant locate CGI/Cookie.pm

hi frnds i m getting this error whenever i m trying to run otrs in my web browser. http://ipaddr /otrs/index.pl " 500 Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your... (1 Reply)
Discussion started by: naik_mit
1 Replies

Featured Tech Videos