Visit Our UNIX and Linux User Community


Stupid filename - can't delete it


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Stupid filename - can't delete it
# 1  
Old 06-18-2002
Error Stupid filename - can't delete it

I have created a file with a stupid filename with a perl script, and now I can't delete it. The file's called -s-c.log. When I try to delete it, I get that:

<>/home/ahi $ rm -s-c.log
UX:rm: ERROR: Illegal option -- s
UX:rm: ERROR: Illegal option -- -
UX:rm: ERROR: Illegal option -- c
UX:rm: ERROR: Illegal option -- .
UX:rm: ERROR: Illegal option -- l
UX:rm: ERROR: Illegal option -- o
UX:rm: ERROR: Illegal option -- g
UX:rm: TO FIX: Usage: rm [-firR] file ...

The system is running NCR Unix. Thx for any help.
# 2  
Old 06-18-2002
Try

rm -- -s-c.log

the -- should stop it reading the -s as options to the rm command
# 3  
Old 06-18-2002
Great, that worked. Thx.
# 4  
Old 06-20-2002
Another one that can be used for different types of dodgy filenames is

rm -i *

This won't always work for all bad chars...but it is an interactive removal....so no good if you have heaps of files....good somethines though.
# 5  
Old 06-20-2002
also, using quotes will solve the problem most times. Except with the - character.

Another way is to use the \ this will disable special chars so that the shell doesn't interpret them as a special char.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #951
Difficulty: Medium
The first known description of a self-reproducing computer program in science fiction was in a short story written in 1970.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

delete numbers in a filename

I have some files where numbers are part of like eg 1add1.txt 23sub41.txt etc I want to remove numbers from the filenames(whereever it may be). I used echo `ls *.txt | sed -e "s///"` But its removing first digits like 1add1.txt becomes add1.txt My intention is to make 1add1.txt... (3 Replies)
Discussion started by: villain41
3 Replies

2. UNIX for Dummies Questions & Answers

Delete filename with month -2

KSH - I've got a script that is generating a number of log files like this: y=`date +"%y"` m=`date +"%m"` $LOG_DIR/tuscprof_tbl_$y$m.log I only want to keep the current 2 months' worth of files (current month and prior month). So I'm trying to come up with a way to delete any that... (1 Reply)
Discussion started by: dstinsman
1 Replies

3. Shell Programming and Scripting

What are the differences between 'bash' and 'sh'

Hopefully this doesn't come off as too much of a "newbie" question or a flamebait. But I have recently begun working with a Sun Solaris box after having spent the past five years working with RedHat. From what i can tell, thing look fairly similar and the 'man' command is some help. But I've... (7 Replies)
Discussion started by: deckard
7 Replies

4. UNIX for Advanced & Expert Users

How to remove a file with a leading dash '-' in it's name?

Somehow someone created a file named '-ov' in the root directory. Given the name, the how was probably the result of some cpio command they bozo'ed. I've tried a number of different ways to get rid of it using * and ? wildcards, '\' escape patterns etc.. They all fail with " illegal option --... (3 Replies)
Discussion started by: GSalisbury
3 Replies

5. UNIX for Advanced & Expert Users

Can't delete the user from command line

Hi All, I try from command line to delete a user (Solaris8) and I get the following error: UX: userdel: ERROR: Cannot update system files - loggin can not be deleted. Any suggestions will be helpful. The root (/) file system has enough free space. Regards, Slava (4 Replies)
Discussion started by: spavlov
4 Replies

6. UNIX for Dummies Questions & Answers

quoting echo 'it's friday'

echo 'it's friday' why appear the > (3 Replies)
Discussion started by: yls177
3 Replies

7. UNIX for Dummies Questions & Answers

I can't delete some files

I've been trying to delete a file with a space in it like this: Nothing 1.jpg I can't copy/delete it or anything like that.I've tried "Nothing_1.jpg" but that didn't work.Anyone know how to do this? (4 Replies)
Discussion started by: DISTURBED
4 Replies

8. Shell Programming and Scripting

Clearify what it means under 'WHAT' when hit the 'w'-command

I wonder how I shall read the result below, especially 'what' shown below. The result was shown when I entered 'w'. E.g what is TOP? What is gosh ( what does selmgr mean?)? login@ idle JCPU PCPU what 6:15am 7:04 39 39 TOP 6:34am 6:45 45 45 TOP 6:41am ... (1 Reply)
Discussion started by: Aelgen
1 Replies

9. Programming

i can't use 'make' in my computer?

I need to compile a file,but 'make' does not work.please tell me how to use it or need which tools? (3 Replies)
Discussion started by: dsun5
3 Replies

10. UNIX for Dummies Questions & Answers

Don't hate me because I'm stupid...

Hi all, I don't know the first thing about Unix, but I would like to learn. I would like to know what the difference between Linux and Unix is, and where I can obtain a copy of either. Thanks :o (8 Replies)
Discussion started by: ThisIsNewToMe
8 Replies

Featured Tech Videos