Visit Our UNIX and Linux User Community


Cron problem?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Cron problem?
# 1  
Old 06-06-2002
Cron problem?

here's the scoop..

I have a ksh shell script written, that when I run it manually, it works wonderful, when I let it run via cron, it runs (tells me I have it set up correctly) but yet it doesn't run correctly (it only runs part of the commands with the script). what gives?

I've got the #!/bin/ksh thing in the begining of my script....

thanks in advance!

Todd
# 2  
Old 06-06-2002
In the script, are you using the full path to all of the command?
# 3  
Old 06-07-2002
I tried that and still no luck. I think the issue lies in an enviroment variable though the line of code that isn't executing is that of another application. I fully qualified the path and still no luck...
# 4  
Old 06-07-2002
If you suspect a possible environment issue, try turning on xtrace ("#/bin/ksh -x") mode inside of your script and letting cron run it. All the trace will then be mailed to you by the cron scheduler. Examining that may show you what is the issue.

Alternatively you can have the cron dump all "visible" output to a couple of log files.

#cron entry
01 * * * * /scriptpath/script >/logs/good.out 2>/logs/badout

(substitute the appropriate schedule of course)

Lastly, unless your .profile has some interactive (requires responses from you) elements you could always source that at the beginning of your script
#!/bin/ksh
#capture any command line params first
some_var=$1
# etc
. ${HOME}/.profile

(is what I do for most of my scripts at work)

That way the environment is the same under cron and when you run it manually.

Just suggestions

Good luck.
# 5  
Old 06-07-2002
thanks Random! sourceing my .profile fixed it!!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #635
Difficulty: Medium
The iPhone 6 and 6S were available in three sizes at launch: 32, 64, and 128 GB.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Execution problem with Cron: Script works manually but not w/Cron. Why?

Hello gurus, I am making what I think is a simple db2 call from within a shell script but I am having difficulty producing the desired report when I run the script shown below from a shell script in cron. For example, my script and the crontab file setup is shown below: #!/bin/ksh db2... (3 Replies)
Discussion started by: okonita
3 Replies

2. Solaris

Problem with cron

Just wanted to know, what happens if a user exists in both files cron.allow and cron.deny. Will the user be able to set cron? Thanks, Deepak (7 Replies)
Discussion started by: naw_deepak
7 Replies

3. Shell Programming and Scripting

Problem with Cron

Hi i am new here and have a quick question. i am receiving ./project.sh: line 12: syntax error near unexpected token `newline' ./project.sh: line 12: `echo "`date +"%F %R"` `md5sum /etc/passwd`" >> ' error message here is my script. could you please help! #!/bin/bash # PROGRAM:... (4 Replies)
Discussion started by: mas1888
4 Replies

4. UNIX for Dummies Questions & Answers

Cron Problem

Hello folks, I've got a few cron jobs listed under a particular user id. They are running fine but then they are creating a new process every time they are running. Any idea folks? (3 Replies)
Discussion started by: King Nothing
3 Replies

5. UNIX for Dummies Questions & Answers

cron problem

I'm using Red Hat and I need to get cron working and I'm not sure what the problem is. As a test I've done the following: 1) In /etc/cron.d I've created a file called date with the following contents 2) */1 * * * * root date >> /root/thedate 3) This works perfectly. It sends the date every... (1 Reply)
Discussion started by: kerpm
1 Replies

6. Shell Programming and Scripting

cron problem

Hi frnds... I m facing very irritating problem already waisted my 2 days.. I have a following script..( i am pasting only the main code) ftp -ivn 213.194.40.77 <<FTP user $user $password binary cd $FileDir/out lcd $localpath get $file rename $FileDir/out/$file $FileDir/tmp/$file... (7 Replies)
Discussion started by: clx
7 Replies

7. UNIX for Dummies Questions & Answers

Cron problem

Hi, I've just done a school boy error. I was trying to edit the crontab but instead of using: crontab -e I used crontab -r without realising. Then went to look at the crontab but ntohing their. Looked int he manual and -r removed the crontab. Is their any way of getting this back?? ... (3 Replies)
Discussion started by: tez
3 Replies

8. UNIX for Advanced & Expert Users

cron problem!

The cron daemon on one of my HP boxes is giving the following error: I checked the queuedefs man page, and it has left me a bit confused. The man page says: So this means that no more than 100 cronjobs can be run at one time (we do not use at and batch on this system). The... (4 Replies)
Discussion started by: blowtorch
4 Replies

9. UNIX for Dummies Questions & Answers

CRON problem

I am having a problem running a shell within CRON. It will run successfully if I do not inject a .profile into the entry. However, the second I place a . profile in front of the shell, the job does not execute. Any ideas? (4 Replies)
Discussion started by: VooDooMan
4 Replies

10. UNIX for Dummies Questions & Answers

Cron problem

Hi, I want to run my shrip for every 30 min.. if i enter crontab -l i am getting following.. 00,10,20,30,40,50 * * * * /home/arbuser/temp2/perform/per.sh 00,15,40,35,50 * * * * sh home/arbuser/temp2/perform/per.sh if I enter like this : ps -ef |grep cron root 311454 1 0... (3 Replies)
Discussion started by: redlotus72
3 Replies

Featured Tech Videos