Visit Our UNIX and Linux User Community


How to set the CVSROOT in the .cshrc file?


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers How to set the CVSROOT in the .cshrc file?
# 1  
Old 06-05-2002
Data How to set the CVSROOT in the .cshrc file?

I am learning the CVS in Unix now, but in the book it said I need to add the CVSROOT to the end of the .cshrc file. I had use emacs to edit it and add CVSROOT=/CVS, but when I run script .cshrc then it said CVSROOT=/CVS: Command not found. I had already think that for a hour, so could any person could help me? Thx
# 2  
Old 06-05-2002
The csh syntax to set an environment variable is like this:
setenv CVSROOT /CVS

Put that line in your .cshrc file. Actually, if I used csh, I would put it in my .login file. The .login file is executed once at login time and once an environment variable is set there is no need to keep resetting it. But putting it .cshrc will work.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #883
Difficulty: Easy
A computer security vulnerability is a weakness in design, implementation, operation or internal control.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

CSHRC and PATH problem please help

I'm doing some IVR programming and it uses Solaris 10. I know little about Unix, or CSH, but I think it's a problem with my .cshrc file. I was getting an error: "nstancehomedir/sqllib/bin/db2fupdt: Command not found" and also "set: Syntax error" when I log in. I found db2fupdt in 2 directories,... (2 Replies)
Discussion started by: jstevanus
2 Replies

2. Shell Programming and Scripting

Source.cshrc file inside Perl

I have a file which is basically .cshrc It contains lines such as: setenv <variable> <value>... set path=(<dir> <dir>) source <another_file>... (1 Reply)
Discussion started by: kshitij
1 Replies

3. UNIX for Dummies Questions & Answers

After modifying .cshrc file, ls: Command not found

I am using Redhat 4.1.2, tcsh shell To add a program to my path, I added the following line to my .cshrc file: set path = (/home/R/R-2.11.0/bin/ /home/R/R-2.11.0/library) It worked, I am able to run the program I wanted. But the pathway above overwrote all other existing paths - so I can no... (1 Reply)
Discussion started by: Euphoria
1 Replies

4. Shell Programming and Scripting

alias defining problem in .cshrc file

Hi folks, I'm trying to define the following command as alias in .cshrc file: ls -ltr | grep ^d | awk '{print $9}' | xargs du -hs I defined it as the following: alias nirdirs '`ls -ltr | grep "^d" | awk "{print \\$9}" | xargs du -hs`' I've got the following error when I've run the alias:... (7 Replies)
Discussion started by: nir_s
7 Replies

5. Shell Programming and Scripting

Problem with my .cshrc

Hello everyone, I write a ~/.cshrc for set class path to run my java application. The file is listed below. setenv YFILTER_HOME ~/yfilter-2.0 setenv PATH "$YFILTER_HOME/bin:$PATH" setenv CLASSPATH... (1 Reply)
Discussion started by: perl0101
1 Replies

6. Virtualization and Cloud Computing

.cshrc file

Hi All, I was hoping someone could help me with the following query I have please in relation to NX Nomachine. Is there a way to get my .cshrc file in say my “US” home dir” to run when I login to another server e.g say a UK server? Any advise would be much appreciated, thanks (3 Replies)
Discussion started by: zainster
3 Replies

7. UNIX for Dummies Questions & Answers

doubt in .cshrc

what kind of information is there .cshrc ? I want to set an alias in the form of =>#alias setprompt 'set prompt=">>$user<<@`hostname`:${cwd}% "' Ex. alias pr 'cd /home/username' when I make the change and try to do $pr ... its saying pr: command not found Is there any way I can... (0 Replies)
Discussion started by: priyam
0 Replies

8. UNIX for Dummies Questions & Answers

.cshrc flie help

How can I set up my .cshrc file to do as the posix shell does the escape+k to scroll my command history Thanks Oh BTW, Hi I'm new to the forum. (2 Replies)
Discussion started by: Lefty
2 Replies

9. UNIX for Dummies Questions & Answers

how to specify header directory in .cshrc

in my .cshrc file, i can set my library files directory like this : setenv LD_LIBRARY_PATH "/usr/openwin/lib" now i want to specify my header files directory. please teach how to set it and what/how is the syntax thank u (1 Reply)
Discussion started by: champion
1 Replies

10. Shell Programming and Scripting

cshrc

where are my .cshrc files ? (4 Replies)
Discussion started by: cubicle^dweller
4 Replies

Featured Tech Videos