One line of cron is not working - PLS Help

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers One line of cron is not working - PLS Help
# 1  
Old 05-21-2002
Data One line of cron is not working - PLS Help

Hi all,
I have spent 2 hours going through the forum and have not found an answer to my question, I hope someone can help.

I have cron setup to run two commands, one at 1am and one at 3 am, the one at 1 am works but not the one at 3 am. The time is set as:

0 1 * * * /path/to/file
0 3 * * * /path/to/file

The second command I was told to call it with cron as http:// but I have tried it 4 different ways and it still does not work. It I pull it up in my browser it works just fine, but not from cron. It is something like the following, (all 4 ways I have tried it):

0 3 * * *, m,,

0 3 * * *,email2%40mydomai,,

0 3 * * * /user/myaccount/web/cgi-bin/myscript/myscript.cgi?pssw=scriptpassword&action=command&, m,,

0 3 * * * /user/myaccount/web/cgi-bin/myscript/myscript.cgi?pssw=scriptpassword&action=command&,email2%40mydomai,,

Like I said above I know cron works because I have another job on the first line that worked just fine. Any help here would be appricated.
# 2  
Old 05-21-2002
Here are a few troubleshooting questions.

1) Can you run this from the command line? and not as you have in example #3 mid-way down your post?

2) Is your first cron entry also calling from http or from a unix file?

3) Just a guess but I don't know if cron can interpret the ? in your cron entries. You may need to put a \ before that ?.

Hope these help you!!

# 3  
Old 05-21-2002
Answers to the questions:
1) No
2) .cgi file, with server path.
3) tried that and it didn't work.

The command works fine from a browser, what I need to be able to do is run it from my server with Cron. Any ideas on how that might be done (guesses are welcome)

# 4  
Old 05-22-2002
Answers to the questions:
1) No
If you can't execute it on the command line, how is cron supposed to know how?

If you can find a way on the command line (using lynx, for example), you can add that line to cron.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

NIS stop working... pls. help.

I am on the NIS client server. when I do ypwhich. I get this err.msg. > ypwhich Domain not bound on svrnyP1 Any idea. I am able to ping the NIS master server. On the /var/adm/messages. I see this... Oct 16 12:52:36 svrnyP1 ypbind: NIS server not... (2 Replies)
Discussion started by: samnyc
2 Replies

2. Shell Programming and Scripting

Script not working in cron but working fine manually

Help. My script is working fine when executed manually but the cron seems not to catch up the command when registered. The script is as follow: #!/bin/sh for file in file_1.txt file_2.txt file_3.txt do awk '{ print "0" }' $file > tmp.tmp mv tmp.tmp $file done And the cron... (2 Replies)
Discussion started by: jasperux
2 Replies

3. Shell Programming and Scripting

Script is not working from cron while working manually

Hello, I am facing a very strange problem when I run my script manuallu ./Fetchcode which is using to connect with MKS integrity from linux end it workks fine but when I run it from cron it doesn't work.Can someone help me 1) How could I check my script when it is running from cron like... (3 Replies)
Discussion started by: anuragpgtgerman
3 Replies

4. Shell Programming and Scripting

Need Help with greping two line from a file Pls help ASAP

Hi all - I''m in a little bit of jam - If you can please help I have a file that has the following content ( please see below) I need to read the file and then get this result in this format ------------- To put out in this format name: sophis Total: 22328 name: tca ... (2 Replies)
Discussion started by: mnassiri
2 Replies

5. Shell Programming and Scripting

What's wrong with this command line pls?

I executed the following command and got Arg List too long. find /dir1/dir2/LOG_* -prune -type f -mtime +3 -exec echo {} \; What's that about? (2 Replies)
Discussion started by: bbbngowc
2 Replies

6. Shell Programming and Scripting

line separate (pls)

Hello everybody I made code to move some files to another place for example(I moved MM file TO BIN folder ) and the MM path I put it in different file e.g(0:HOME/unixstuff/MM) so my question is who I can separate the path line and use the number 0: and MM as parameter because if I want to... (2 Replies)
Discussion started by: falm
2 Replies

7. Shell Programming and Scripting

If not working...pls help:URGENT

Following is d code snipet #!/bin/ksh retVal=`sqlplus -s user/passwd\@oracle_sid <<EOF SET SERVEROUTPUT ON SIZE 100000 DECLARE STATUS_VALUE VARCHAR2(1); BEGIN SELECT temp1 INTO STATUS_VALUE FROM sai; DBMS_OUTPUT.PUT_LINE(STATUS_VALUE); END; / exit; EOF` echo "Return Value... (4 Replies)
Discussion started by: sainathdeg
4 Replies

8. Shell Programming and Scripting

How to get it in single line. pls help

Hi, when i am executing this script, i am getting the values of TID and Intime in different lines. How can i print both output values in a single line. please advise _____________________________ #!/bin/ksh export Path="/abc/def/ghi"; Home="/abc/jkl/prt"; cd $Path cat $Home | while read... (3 Replies)
Discussion started by: Prat007
3 Replies

9. Shell Programming and Scripting

Pls. Help my script not working as it should

I'm using nested for loops to gather ping IP addresses from a hostlist and also changing the packet size via a packet size list. The final results of (RTT and SDEV) will need to be grep'd out using awk into variables and then printed in columns (the packet sizes going across with IP address going... (1 Reply)
Discussion started by: cocoabeauty1
1 Replies

10. Shell Programming and Scripting

Running a Cron Script only @ Startup Pls Help!!

Hi friends i have a script "" which is stored in "/var/lib/pgsql" directory. I want it to run as a cron so that it executes every time the system starts. I tried the follwing method I logged in as the root user and typed "crontab -e" The file was completly blank so i put the... (3 Replies)
Discussion started by: perk_bud
3 Replies
Login or Register to Ask a Question