Visit Our UNIX and Linux User Community


URGENT : fsck in HPUX


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers URGENT : fsck in HPUX
# 1  
Old 05-13-2002
Question URGENT : fsck in HPUX

Experts!!!
I have an urgent solution for a problem with the HP Unix workstation.
I am not able to check the file system for a particular volume.
when i tried with
$> fsck -o full /dev/vg00/rlvol9
Returns..
full file system check required... exiting...
$>

How do i recover the file system for this situation.

Best Regards,
Anent
# 2  
Old 05-13-2002
Anent,

I believe that you need to umount this filesytem before you can fix the raw Logical Volume.Here is a link that details your exact problem. BTW, this website www.itrc.hp.com will help you answer specific HPUX questions.

http://forums.itrc.hp.com/cm/Questio...9cd0f9,00.html


Here is the man page entry.


-o Specify VxFS file system specific options. These
options can be a combination of the following in a


comma-separated list:

full Perform a full file system check. The default is
to perform an intent log replay only. Since the
VxFS file system maintains an intent log, a
complete check is generally not required. If the
file system detects damage or the log replay
operation detects damage, an indication that a
complete check is required is placed in the
super-block, and a full check is performed.
nolog Do not perform log replay. This option may be
used if the log area was physically damaged.

When a full check is performed, the following inconsistencies are checked:

+ Blocks claimed by more than one inode or the free list.

+ Blocks claimed by an inode outside the range of the file
system.

+ Incorrect link counts.

+ Size checks:
- Incorrect number of blocks.
- Directory entry format.

+ Bad inode format.

+ Blocks not accounted for anywhere.

+ Directory checks:
- File pointing to unallocated inode.
- Inode number out of range.
- Linkage to parent directory.
- Hash chain linkage.
- Free space count.

+ Super-block checks:
- Checksum mismatch.
- More blocks for inodes than there are in the file
system.

+ Structural Files:
- Fileset headers.
- Object Location Table (OLT).
- Inode list files.
- Inode allocation summary files.
- Attribute files (including Access Control Lists).
- Attribute link counts.

+ Bad free block list format.
+ Total free block and/or free inode count incorrect.


Orphaned files and directories (allocated but unreferenced) are, with the user's concurrence, reconnected by placing them in the lost+found directory. The name assigned is the inode number. The only restriction is that the directory lost+found must already exist in the[COLOR=skyblue]
# 3  
Old 05-13-2002
What type of filesystem is it? "-o full" is only for vxfs.
# 4  
Old 05-14-2002
Thanks Kelam_Magnus and Perderabo,
Here I do tried all those options to get rid of the problem. But the same error message is returned.
Perderabo : its vxFs file system only.
I thank you for your valuable response.

Thanks,
Anent
# 5  
Old 05-14-2002
In that case I would suspect that your fsck is broken. Have you installed the recommended patches?
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #778
Difficulty: Medium
Harmonic analysis is a branch of mathematics concerned with the representation of functions or signals as the superposition of basic waves.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

URGENT Reading a file and assessing the syntax shell script URGENT

I am trying to write a shell script which takes an input file as an arguement in the terminal e.g. bash shellscriptname.sh input.txt. I would like for the file to be read line by line each time checking if the .txt file contains certain words or letters(validating the syntax). If the line being... (1 Reply)
Discussion started by: Gurdza32
1 Replies

2. Solaris

unable to repair the / filesystem. Run fsck manually (fsck -F ufs /dev/rdsk/c1t0d0s0)

What can I fix this issue? I have ran below commands but everything is same.:confused: WARNING: Last shutdown is later than time on time-of-day chip: check date. The / file system (/dev/rdsk/c1t0d0s0) is being checked WARNING - unable to repair the / filesystem. Run fsck manually (fsck -F... (4 Replies)
Discussion started by: getrue
4 Replies

3. Solaris

Urgent !! SVM, subdisks "UNEXPEXTED INCONSITENCY; RUN fsck MANUALLY

Hi, I am getting this error while server booting up, not sure how to fix this. Unable to mount these file systems /dev/md/rdsk/d51: No such device or address Can't open /dev/md/rdsk/d51: No such device or address /dev/md/rdsk/d51: CAN'T CHECK FILE SYSTEM. /dev/md/rdsk/d51: UNEXPECTED... (1 Reply)
Discussion started by: bobby320
1 Replies

4. HP-UX

pwage-hpux-T for Trusted HPUX servers

I'm sharing this in case anybody needs it. Modified from the original solaris pwage script. This modified hpux script will check /etc/password file on hpux trusted systems search /tcb and grep the required u_succhg field. Calculate days to expiry and notify users via email. original solaris... (2 Replies)
Discussion started by: sparcguy
2 Replies

5. Shell Programming and Scripting

Need Script to Use CPUs on a HPUX server to simulate Workload Manager on HPUX.

I am running HPUX and using WLM (workload manager). I want to write a script to fork CPUs to basically take CPUs from other servers to show that the communication is working and CPU licensing is working. Basically, I want to build a script that will use up CPU on a server. Any ideas? (2 Replies)
Discussion started by: cpolikowsky
2 Replies

6. Solaris

fsck -o

Hello I am getting this in dmesg: /mount1: unexpected free inode 1262865, run fsck(1M) -o f What are the options I should use with fsck? thanks (2 Replies)
Discussion started by: melanie_pfefer
2 Replies

7. UNIX for Advanced & Expert Users

URGENT,URGENT- Need help tape drive installation

Hi, I am trying to attach tape drive to sun V890 running Solaris 9 on it. I have installed HBA(qlogic) in slot 1 of 0-8 slots and booted the system. I do not see HBAin prtdiag output. The tape drive is not attached to HBA. The tape drive I am going to attach is Sony AIT3. 1.How can I make... (3 Replies)
Discussion started by: sriny
3 Replies

8. Programming

HPUX and Compaq problem-urgent

Hi All Following is the lines of code which simply makes a structure of 1 bit member and 7 bit is unused.Then the structure is initialised with char pointer.The output on HPUX(BIG Endian) and Compaq(Little Endian) are different.On HPUX it gives zero and Compaq it gives 1. I never thought that the... (7 Replies)
Discussion started by: Shobhit
7 Replies

9. Filesystems, Disks and Memory

fsck -y

Once in a while, I would think it advisable to run fsck -y to check the disk. Should I sign in as su or sudo? What is the difference and which is preferred? Thank you in Advance! (4 Replies)
Discussion started by: rpatrick
4 Replies

Featured Tech Videos