Visit Our UNIX and Linux User Community


HP 9000 runnig Unix


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers HP 9000 runnig Unix
# 1  
Old 04-10-2002
HP 9000 runnig Unix

I have aquired the dutties of looking after our MRP system
We have a HP 9000D running Unix With MINX as tha MRP system
Our last IT System adim. had crashed the system before he left
and sense then we have not been able to log on to the system at the console or remotely. tha error reads minx 460 not found
and it wants us to log on as root to run fsck manualy.
the real problem is that we can not access the root the sysytem says the root has been disabled. How do I fix this problem so I can enter the system to do a manual fsck on the files that have errors.
any Help would be great.
# 2  
Old 04-10-2002
First of all, let me say that there is a great website for HPUX.
www.itrc.hp.com Go to the search page and type in your problem and click on the criteria you want to search for answers. The forum and manuals are good ones to pick.

Okay, here's the situation. Is this running HPUX? What version? What is the MINX product? Is that an application?

I will assume you have a version of HPUX.

You will have to do one or more of several things.

Regarding the disabled root, You can fix this when you log back in to single user mode. Just create a password for root using " passwd root " command.

First, we will try the easiest thing. Reboot the box, power off and power on again. When the box is coming back up, there will be a point to break in and stop the boot process. Do this.


Now, depending on what version of unix you are running, you will want to get to single user mode.

If you have a menu there, type in whatever it asks for to get you to single.

In HPUX, type " hpux boot -is " or " hpux -is ".

When you get there, perform fsck on all the filesystems. Do a man on fsck if you have another box. Here is some of that man page.


fsck(1M) fsck(1M)
NAME
fsck (generic) - file system consistency check and interactive repair

SYNOPSIS
/usr/sbin/fsck [-F FSType] [-m] [-V] [special ...]
/usr/sbin/fsck [-F FSType] [-o FSspecific-options] [-V] [special ...]

DESCRIPTION
The fsck command audits and interactively repairs inconsistent
conditions for HP-UX file systems on mass storage device files
identified by special. If the file system is consistent, the number
of files on that file system and the number of used and free blocks
are reported. If the file system is inconsistent, fsck provides a
mechanism to fix these inconsistencies, depending on which form of the
fsck command is used.

special represents a special device (e.g., /dev/rdsk/c1d0s8).
Options
fsck recognizes the following options:

-F FStype Specify the file system type on which to operate (see fstyp(1M) and fs_wrapper(5)). If this option
by matching special with an entry in that file.
system type is determined from the file /etc/fstab
by matching special with an entry in that file.
If there is no entry in /etc/fstab, then the file
system type is determined from the file
/etc/default/fs.

-m Perform a sanity check only. fsck will return 0
if the file system is suitable for mounting. If
the file system needs additional checking, the
return code is 32. If the file system is mounted,
the return code is 33. Error codes larger than 33
indicate that the file system is badly damaged.
*********************************************

Now, if that doesn't work you will need to have a CDROM or backup tape to restore from. Reboot the box, and have either the CDROM or tape in the system. Break in as before during the boot cycle, and boot from the tape or CDROM.

You may have to reinstall via the CDROM if you don't have a tape or can't restore from it.

My fear is that your old admin has sabotaged your box. Smilie
You may have to reinstall, if when you get to single and see that filesystems are missing.

Please respond with your progress!!Smilie
# 3  
Old 04-10-2002
I tried to do what you Suggested I was able to get to the single user mode and to ru fsck all went well but the /dev/vg01/rminx460 could not open
As for the change of the root I did passwd it asks for the old password I entered it and it said SORRY.

So the system is still not operating.

The system is HPUX I don't know what version
The Minx System is an MRP system that runs in unix
it is an old system not used any longer.
Thanks for the help.
# 4  
Old 04-11-2002
If you're in single-user, you should already be root, right?
If "passwd root" doesn't work, you could always edit the /etc/passwd file. There will be an entry at the top similar to this:
root:[random junk here]:0:0:Root:/:/sbin/sh

Where the seemingly-random junk is, between the second and third colon ( : ) is the encrypted password. Simply remove everything in there so it looks like this:
root::0:0:Root:/:/sbin/sh

Now root has no password. Try changing it now.

I don't know very much at all about LVM, as it seems to suggest you might need help with as far as the /dev/vg01/rminx460 entry goes.
Is there any chance he simply wiped the disks in anger (possible if he harmed the system purposely in any other way), or even simply remove the disk? If you can get /usr mounted, you should be able to use: "/usr/sbin/fstyp /dev/vg01/rminx460" to see if a recognizible filesystem exists there...

Hope this helps a little... Maybe someone better with HP-UX can provide more info...
# 5  
Old 04-11-2002
Good point! Livinfree!

After you do that, try the fsck again. Then try to find the /dev/vg01/rminx460. What filesystem is this related to?

If this is a root-related disk, you might have to reload from a CD or tape.

Don't give up now!

BTW, if the old SA has maliciously crashed/sabotaged your system, your company can and should bring charges against them.

Just my opinion though...

Smilie
# 6  
Old 04-11-2002
OK I have done all
But I am not able to access the rminx460
I have the last Tape back up
But I do not know how to run the sysytem from the tape
Any Help!!
# 7  
Old 04-11-2002
It depends on how the tape was created. Also, is it a backup of the root volume or of the whole box?

If this is HPUX, look in /usr/sbin or one of the other binary directories for a command that may work.

tar, frecover, and make_recovery are three commands that can work on HPUX boxes.

If you can do a " uname -a " and print the output here.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #237
Difficulty: Easy
Paul Baran was the first to build a theoretical model for communication using packet switching.
True or False?

9 More Discussions You Might Find Interesting

1. HP-UX

HP 9000 340 help

Hi all, I've salveaged a fully working HP 9000 340 model with hard disk and floppy drive. It boots up and I get to the login screen. I don't have any usernames or passwords. Anyone know any hacks for the version of Unix it runs? Is there anyway I can reset the root password? Via Floppy? ... (0 Replies)
Discussion started by: robbo007
0 Replies

2. Solaris

PSU info M4/5/8/9000

I need to find out PSU info for some M class severs, normally prtdiag -v show's the relevant PS info, however these M classes don't seem to go down to that level !? Anyone any ideas , no physical or console access available at this stage :( thx... (3 Replies)
Discussion started by: itsupplies
3 Replies

3. UNIX for Dummies Questions & Answers

runnig script from window machine

i want to run a script from window machine the script is ksh for i in $(cat some.txt) do rm $i done exit i have it saved as a file say progremove & made it chmod 7777 how do i run this script from a window machine vie a batch file telnet -l username servername then what... (2 Replies)
Discussion started by: sjumma
2 Replies

4. Shell Programming and Scripting

runnig a perl program from a different dir..

hi, This is perl, v5.6.1 built for MSWin32-x86-multi-thread in win2000advanced server,... i have all my perl programs in d drive.. i like to run perl programs from a different drive(ex : c drive..) that is simple in unix.. but i dont know how to do that in win.. do u know how to do... (3 Replies)
Discussion started by: sekar sundaram
3 Replies

5. Shell Programming and Scripting

Runnig a Windows command from UNIX

Hi, I need to execute a Windows command from UNIX crontab ( or similar utility). We are evaluating the schedular applications that will easily solve this issue although it will be a while by the time the tool selection happens and I need something to implement this solution in the iterim. ... (1 Reply)
Discussion started by: ashpon
1 Replies

6. UNIX for Dummies Questions & Answers

Runnig Remote Shell

Please I need your help. I want to run remotely a unix shell that run a java process, from a Visual Basic Client. Thanks mac33 :) (4 Replies)
Discussion started by: mac33
4 Replies

7. UNIX for Dummies Questions & Answers

HP 9000 workstation configuring

Hi, I have an HP9000 rp7420 running 11.i. I managed to mess up the console and can no longer get it to act as the console. When resetting the MP it seems to works, and after booting partition I can telnet into the box. Can anyone direct me to configuring the console HP700/96 is the model.... (0 Replies)
Discussion started by: ukitus
0 Replies

8. UNIX for Advanced & Expert Users

UPS for HP-9000

Hello Everyone I run 4 HP 9000 servers with HP-UX 11.0 on all 4, with an Infomix Database. About 6 months ago one system starting acting real weird it will display the message that it lost power (which did not) and it would shutdown, Then roughly 30 seconds later it would then say power has... (4 Replies)
Discussion started by: JackieRyan26
4 Replies

9. IP Networking

runnig squid at boot up

Hi Does any body know how i can run a program at bootup? I have squid (cache server) installed on my PC but after boot up i should run it manually but i want it to run automaticly is there a way? I used to do it by entering the address ina file but i've forgotten it now. But i remember that ... (2 Replies)
Discussion started by: hessam
2 Replies

Featured Tech Videos