timer_gettime unresolved error


 
Thread Tools Search this Thread
# 1  
Network

I have used get_time() in my program but when I try to compile it it is giving the following error:
ld:
Unresolved:
timer_gettime

# 2  
One possible approach:

(1) Go to all your library directories.

(2) Run your favorite system command to list the
contents of the routines in the libraries.

(3) See if you can find the lib with your function.

(4) Make sure the path of that archive is in either
your LDPATH or in your ldconfig file.

(5) If you add the path to the ldconfig file, then
you must rerun ldconfig. Easy to test with
the LDPATH environmental var.

If you do not find the archive in 1 - 3 then you have
to either:

(1) Locate the lib for your OS and install.

(2) Find the correct source tree for your OS.

(3) Rewrite the source with the appropriate libs.

There may be better approaches. You can also check
the README files and Makefiles for lib information,
configuration suggestions, etc. Normally, modern
distributions with check for this using a configure
script.

Perhaps another forum poster has a better idea.
# 3  

make sure you are using '#include <time.h>'



[Edited by Neo on 10-27-2000 at 10:19 PM]
# 4  
Data

I had included #include<time.h>


[Edited by Neo on 10-27-2000 at 10:02 PM]
# 5  
I have searched the library and found the file but the problem is when I first ran a posix thread program I had similar error for pthread_create at that time I had used
cc -o thr1 thr1.c -pthread

Is there any general way for getting rid of these unresolved problems.


[Edited by Neo on 10-27-2000 at 10:20 PM]
# 6  
<P>
If the error is coming from ld() then adding an
include (#include foo.h) will not solve the problem
because the error occurs during the linking phase,
linking objects, and not the preprocessing and
compiling phase.
<P>
Since the poster indicates that the error came from
ld() then they are missing a compiled object and either
the object is missing or the path to the object is missing
in the linking phase.

 

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

9 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

> 5 ")syntax error: operand expected (error token is " error

im kinda new to shell scripting so i need some help i try to run this script and get the error code > 5 ")syntax error: operand expected (error token is " the code for the script is #!/bin/sh # # script to see if the given value is correct # # Define errors ER_AF=86 # Var is... (4 Replies)
Discussion started by: metal005
4 Replies

2. AIX

Unresolved symbols

Hello experts , i have some strange problem, i wanted to create a shared object in AIX 5.3 for which i have compiled all my .cxx to .o which worked fine and then i created the .so from them , but when i do nm -Bo sample.so , i have many unresolved symbol, including printf... (0 Replies)
Discussion started by: vin_pll
0 Replies

3. UNIX for Advanced & Expert Users

database connection (unresolved sqlcxt)

i have a little pro*c code (as shown below) to connect an oracle database. (in unix solaris platform) in the preprocessor compilation step everything is ok. but when i try to compile the code using cc i get the error below: ld: Unresolved: sqlcxt i think there is a problem while linking... (3 Replies)
Discussion started by: gfhgfnhhn
3 Replies

4. HP-UX

Unresolved symbol problem

Hi I am trying to make an executable which has informix esqlc and .per files. I am using informix version 9.3. The make is successful, but when i execute, i get an error message /usr/lib/dld.sl: Unresolved symbol: ibm_lib4gl_loadint4 (code) from RVprnrecvr Abort(coredump) I searched for... (4 Replies)
Discussion started by: venkatakrishnan
4 Replies

5. Programming

unresolved symbol on AIX 5.2

Hi, want to port an executable from AIX 5.3 to AIX 5.2. This seems to be no problem, when i build one executable. But in another case i have to link one library statically and the rest is loaded at runtime. This works for AIX 5.3 but on AIX 5.2 i get the following error ... (2 Replies)
Discussion started by: pm_user
2 Replies

6. UNIX for Dummies Questions & Answers

unresolved symbol ???

when I make ncftp 111.111.1.2 I just get problems like ... /usr/lib/dld.sl unresolved symbol:inet_ntop (code) does anybody know what is the problem and how to solve this? thx.. (2 Replies)
Discussion started by: svennie
2 Replies

7. Programming

How To Find Unresolved symbol in shared library?

1 . I use Digital Unix V4.0F 2 . I compile a programe which use a shared library . But when I run it( prog.out) , the shell told me that "Fatal Error : /sbin/loader : unresolved symbol in lib3cZap.so" But When I compile proj.out and lib3cZap.so , the compiler said nothing . And I ls -l... (1 Reply)
Discussion started by: chenhao_no1
1 Replies

8. Programming

Unresolved Symbol on HP UX & oracle7

Hi everyone, I have a problem. I do not succeed to linking the oracle7's library for my .so and a Unresolved Symbol :sqlcxt error returns me when I call program. this is my makefile. cc -Ae -I/usr/include/curses_colr -L/usr/lib -DUSE_TERMIOS -D_FILE64 -DDYNAMIC_LIBRARIES_SUPPORTED... (2 Replies)
Discussion started by: luckycs
2 Replies

9. Programming

c++ unresolved symbol

I have this problem: # make gcc -g -D_REENTRANT -DDISABLE_MJPEG=1 -I. -o encmain.o -c encmain.cc ld: 0711-317 ERROR: Undefined symbol: std::string::_Rep::_S_max_size collect2: ld returned 8 exit status but from /usr/local/include/g++v3/bits/basic_string.h : namespace... (0 Replies)
Discussion started by: thalex
0 Replies

Featured Tech Videos