Visit Our UNIX and Linux User Community


PPP in netcfg


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers PPP in netcfg
# 1  
Old 04-03-2002
Question PPP in netcfg

Hi!

I'm using RedHat 7.1 and I have some prolems with connecting with ppp. I have run modemtool and told that I'm using ttyS0. Whe I then try to set up a PPP connection using netcfg the PPP option is not there. I have all the other alternativs except PPP. What have I missed?
# 2  
Old 04-03-2002
Are you using regular ol' dialup ppp? Or are you using PPPoE / PPPoA? If you just want dialup, use the tool "rp3" in the GUI or "wvdialconf" / "wvdial" from the command line (rp3 is somewhat of a frontend to both tools). Check the man pages for all three for more info.
(Note: if you happen to be with any AT&T service, you may need to use "Stupid Mode = 1" in wvdial.conf... don't ask me why, but evidently AT&T does something stupid... This is from experience with that provider.)
# 3  
Old 04-03-2002
How do you know what ppp is installed? When I try to use wvdial it claims that the number, username and password is invalid.
# 4  
Old 04-03-2002
Try:
whereis pppd
(mine is in /usr/sbin)
/usr/sbin/pppd --version

As for the wvdial problem, did you already manually edit the /etc/wvdial.conf file? Make sure to plug in valid values for number, username and password.
Post back if it still doesn't work...
# 5  
Old 04-04-2002
One step further

Hi!
After playig aroud with the AT commands in wvdial.conf I got the modem to un hook and dial the number. I'm using

ATW (Makes the modem wait for dialtone) ATD [Number] (Dials the number) Smilie

to do this. Now the problem is that after dialing the number the modem dissconnects and tells that modem is not respoding. How do I make it wait until it gets an answer and then makes the "handshaking", sends the login and password?

Smilie
# 6  
Old 04-04-2002
Did you use the wvdialconf tool to detect your modem? It should have set the AT commands correctly for you.
I don't know why it would hang up before starting pppd...
# 7  
Old 04-04-2002
I'm totaly new to linux, but a friend that is more experienced in FreeBDS had a look at it without beeing able to solve the problem.
Since the replies I got yesterday I have reinstalled RH 7.1 (and all the packages) to make sure that nothing is missing.
When Linux starts it query the modem (I could see the lights flashing). After that i started the netcfg (mabey unneccesary if Linux already has detected the modem). After that I ran the "Internet Conector" in Gnome, to set up the account. After that when I tred to conect through RHppp there was an error but I cat exactly recall what it was now. Any way, after that I tried to run wvdialer. It sent some AT commands to the modem but the modem never uhooked or dialed any number and then it returned invalid phonenumber, invalid password, invalid username. After this I erased the AT commands and put in ATW ATD [number] and now it unhooks, dials the number but unconects immediatly without waiting for any kind of answer.

I'm not sure if ay of this makes you ay wiser but hopefully it will.

Best regards!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #12
Difficulty: Easy
CPU stands for 'Computer Processing Unit' and controls all of a computer's functions, acting as the brain(s) of computers.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

No SMS notifications once ppp up

Hi all, I have an Siemens IoT2020 with a Sim7000e cellular board that I connect via USB to the board and connect to Telstra Cat-M1 network. I can send and receive SMS and do so using Node-Red but can also do with Minicom etc. When connected I get : root@iot2000:~# dmesg | grep USB ACPI:... (0 Replies)
Discussion started by: antc
0 Replies

2. UNIX for Dummies Questions & Answers

Not able to dial specific number using ppp

Hi all, I'm working on ppp establishment. When I tried calling a number using ppp, I could establish a PPP connection successfully. But, when I tried calling another ISP number, it is asking for authentication details whereas that is not the case with the other number. It throws an error saying... (0 Replies)
Discussion started by: sai2krishna
0 Replies

3. IP Networking

Load Balancing ppp

Hello everybody How can i Load Balance two slow ppp(gprs) connections with iptables . (4 Replies)
Discussion started by: rink
4 Replies

4. Shell Programming and Scripting

SLIP/PPP questions

Hello all.. I need to script SLIP dial-up connections and wanted ask others about the following; - does pppd support SLIP (noticed some releases do and some don't) - if pppd doesn't support SLIP can bash variables be passed to a dip script (e.g. phone-number, ip-address) - or is another... (0 Replies)
Discussion started by: LAVco
0 Replies

5. Solaris

install PPP on Solaris 9

Background: I have been running Solaris 8 on an Ultra5 with 128MB and 4GB disk for years without upgrade. If it ain’t broke, don’t fix it. Now my ISP has upgraded their software, and no longer talks to my old (asppp!) software. Sun no longer ships newer versions of Solaris 8. So I bought Solaris... (1 Reply)
Discussion started by: sandee
1 Replies

6. UNIX for Advanced & Expert Users

ppp errror message in logs

I am getting this message in the log file. Apr 29 15:32:02 router ppp: Warning: Label COPYRIGHT rejected -direct connection: Configuration label not found This repeats every so often, the link is up however...Any ideas why i am getting this. Its freebsd 6.1 and pppoE. Frank (1 Reply)
Discussion started by: frankkahle
1 Replies

7. IP Networking

CCP In PPP

Hi, I am using linux-2.6.10 mandrake. In which i am establishing PPP sessions with the peer.During the PPP negotiations i negotiate even CCP-deflate compression option. I just wanted to know the amount of memory which is being used in kernel space by the compression algorithms,when a ccp... (0 Replies)
Discussion started by: sriram.ec
0 Replies

8. UNIX for Dummies Questions & Answers

Error in connecting PPP connection

when i connect to SCO-Unix from Windows98 through PPP, the terminal window comes up asking for user name and password, when i enter PPP user name and password, it disconnects. kindly help me to sort out the problem in connection. thanks Nagendra Jaiswal (2 Replies)
Discussion started by: nagendrajaiswal
2 Replies

9. IP Networking

How to get Caller Id in PPP

hello I am workin with PPP to send data from dos machine to unix & Linux machine using FTP with help of fax & voice modem(Caller id Enabled & Exchange provides facility). i need to identify phone(number) connect with Dos machine i.e. to identify from where data is send. so i want to get the... (0 Replies)
Discussion started by: yspl
0 Replies

10. IP Networking

PPP Network through TCP/IP

I have two unix systems. One is Redhat Linux and the other is Sun Solairs. I am runing PPP on my Linux machine but not on my Solaris machine. TCP/IP connects the two machines. I want to pick up PPP on both machines simultaneously with only one dial up connection on my linux machine. ... (4 Replies)
Discussion started by: Photon_Blast
4 Replies

Featured Tech Videos