Visit Our UNIX and Linux User Community


rpm hell!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers rpm hell!
# 1  
Old 03-26-2002
rpm hell!

I've just installed redhat 6.2 on one of my systems and am trying to install the gcc c compiler after downloading an rpm from the redhat site. The damn thing gives me:

only major numbers <= 3 are supported by this version of RPM

what do I do, it does the same with the latest rpm of php

help!
# 2  
Old 03-26-2002
Upgrade RPM first.
Then upgrade other packages.
Check at ftp://ftp.rpm.org/pub/rpm/dist/ for a newer package (they're in the 4.0.* tree now) and install. Please post back with any questions.
# 3  
Old 03-26-2002
which one should I download?

there are loads and it makes no sence to me!

how am I supposed to install this?
# 4  
Old 03-27-2002
Install one that has a version number greater than three.

My guess (assuming that you're on Intel-compatible {i386} hardware) would be that you need this RPM:
ftp://ftp.rpm.org/pub/rpm/dist/rpm-4....4-7x.i386.rpm
If you can't install that via rpm, you may have to do it the old fashioned way:
ftp://ftp.rpm.org/pub/rpm/dist/rpm-4....4.i386.tar.gz

Post back to let us know how you are doing with that.

Also, try not to get too dependant on RPM - it's not very flexible to the end user (What if I want to install samba in /opt, not /usr/lib , for example?), and so far as I know, only Linux systems use it. If you want a new app that isn't released by a Linux vendor / software writer (which includes lots, if not most, of the great software out there), you'll have to use something other than RPM.
# 5  
Old 03-27-2002
thanks m8.
I just want to check though
when I tried to install the new rpm
I get this message.

dependancy problems
rpm requires popt =1.6.4
rpm requires rpmlib <=3.0.4-1
libz2.so.1

and others

should i carry on or what.
# 6  
Old 03-27-2002
Yeah, it looks like you'll have to install those too...
Or Update; that would be more correct to say, since you have them, they're just older versions...

I guess instead of updating world+dog just to get gcc installed, could you settle for an older version of gcc?
# 7  
Old 03-27-2002
lol.

Your right but I don't know where to get an older version of the compiler.

I bet you do though.Smilie
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #652
Difficulty: Easy
Puffy is the mascot of Linux Mint.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Rpm issue with autoconf-2.63-1.AIX6.1.noarch.rpm

dears i am trying to install the autoconf-2.63-1.aix6.1.noarch.rpm but its shows the below error message . P700_dev/svn/dependencies>rpm -i autoconf-2.63-1.aix6.1.noarch.rpm error: failed dependencies: m4 is needed by autoconf-2.63-1 P700_dev/svn/dependencies> (6 Replies)
Discussion started by: thecobra151
6 Replies

2. Shell Programming and Scripting

How to make RPM not write to RPM database if RPM fails to deploy?

How to make RPM not write to RPM database if RPM fails to deploy? IE I create an rpm spec file that contains the following if then exit 1 fi My rpm will fail at deployment, but if I do rpm -qa , I can see the rpm in the rpm db (3 Replies)
Discussion started by: 3junior
3 Replies

3. Shell Programming and Scripting

Extract RPM name from path to .rpm file

It's the end of the day and I just can't get my head around this. I'm trying to extract just the name of the RPM from the path to a .rpm file. So from: /home/me/rpm/RPMS/i386/nagios-our-plugins-1.2-6.i386.rpmI need to extract 'nagios-our-plugins'. I can't get the awk syntax right: awk '{... (5 Replies)
Discussion started by: aussieos
5 Replies

4. UNIX for Dummies Questions & Answers

Confussed as hell

:eek: (1 Reply)
Discussion started by: Kevinfine
1 Replies

5. SuSE

How to install .src.rpm ? ( source rpm )

Hi, I have got few RPM's from rpmfind.net ( mainly gcc ). But it seems to be src files instead of the image. so I think we have to build the src files according to target machine using rpmbuild. Can any one help me with 1) Various options of rpm build that have to be taken care 2)... (3 Replies)
Discussion started by: Sivaswami
3 Replies

6. Shell Programming and Scripting

hell & mathematics

I've been able to generate output based on the code scarfake provided me (thanks again man). A little background so everyone more or less knows whats going on: I needed code that would propagate a database with 100,000 entries, for capacity testing purposes, something like a stress test. ... (5 Replies)
Discussion started by: ogoy
5 Replies

7. Shell Programming and Scripting

hell and sqlite

Hi everyone, I have a requirement that requires me to fill an sqlite database with 100,000 entries (no duplicates). I will start out by giving the command that will insert the values necessary to populate the database: # sqlite /var/local/database/dblist "insert into list... (2 Replies)
Discussion started by: ogoy
2 Replies

8. Linux

Converting source rpm to binary rpm

Hi, I need to install an rpm file,but I only have '.src.rpm' version of it. I want to convert it to a binary rpm. so I tried this rpm --rebuild somethin.src.rpm But I am gettin '--rebuild:Invalid option' as output Is there another way to rebuild source rpm.? Thanks in... (2 Replies)
Discussion started by: eamani_sun
2 Replies

9. Linux

Failed dependencies of rpm / how does RPM check for ?

Hey, I've a problem installing a package. rpm -ivh brings the errors: libjvm.so is needed by libverify.so is needed by But I have installed the Java SDK like requested and the files are on the disk. But I have no idea how to find out, why rpm cann't find them. I have also... (2 Replies)
Discussion started by: mod
2 Replies

10. Programming

fork()ing hell!!

Hello I am having serious trouble with the fork command, i basically want to create 9 or 10 child processes and store their pid numbers in array while the children stay resident until i kill() them later , i cannot seem to control how many are made as they all seem to create their own children. ... (16 Replies)
Discussion started by: theultimatechuf
16 Replies

Featured Tech Videos