Visit Our UNIX and Linux User Community


problems with make


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers problems with make
# 1  
Old 03-22-2002
Network problems with make

I have installed gcc 295.3 and make 3.79.1 and I am attempting to compile the apache installation. I can run ./configure and no errors occur. However, when I try to run make it complains that it is unable to find the ar command. Here is the output after entering make. Any help is appreciated.

# make
===> src
make[1]: Entering directory `/home/kgrady/apache/apache_1.3.24'
make[2]: Entering directory `/home/kgrady/apache/apache_1.3.24/src'
===> src/os/unix
gcc -c -I../../os/unix -I../../include -DSOLARIS2=280 -DUSE_EXPAT -I../../lib/expat-lite
NEEDED `../../apaci` os.c
gcc -c -I../../os/unix -I../../include -DSOLARIS2=280 -DUSE_EXPAT -I../../lib/expat-lite
NEEDED `../../apaci` os-inline.c
rm -f libos.a
ar cr libos.a os.o os-inline.o
make[3]: ar: Command not found
make[3]: *** [libos.a] Error 127
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/home/kgrady/apache/apache_1.3.24/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/home/kgrady/apache/apache_1.3.24'
make: *** [build] Error 2
# 2  
Old 03-22-2002
The problem is not with make.
The problem is that make cannot find the "ar" command
to create the library archive "libos.a"

You need to verify that you do infact have this command
executable installed and next, where it is installed and make
sure you can get to it from your PATH.
# 3  
Old 03-22-2002
That did

I needed to add /usr/ccs/bin to my path. Worked like a charm. Thanks

By the way, this site has been a great resource for me. Every question I have had regarding unix has been answered here.

Great site.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #745
Difficulty: Medium
The Austrian Computer Kit (ACK) is a retargetable compiler suite and toolchain written by Andrew Tanenbaum.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Problems with using grep to make backups to a different directory

I am trying to program a script that is using grep to find lines in a file in my home directory, and then use a pipe command to copy what is shown into different files in a different directory to create backup files. When I run it, though, it only creates a copy of the file that grep was going... (7 Replies)
Discussion started by: sammythesp3rmy
7 Replies

2. Programming

Issue with make, no rule to make target etc.

I have been trying to split up my src directory to clear out files that are not re-compiled very often. Now I have the following setup in my trunk, trunk/bld trunk/src/ trunk/src/src_server trunk/makefile.linux In the make file, I have compile rules SOURCELOC = src # compile src c++... (4 Replies)
Discussion started by: LMHmedchem
4 Replies

3. Solaris

Problems with make install

Hi all, I'm working on a server with Solaris 10 and I'm trying to install the pptp client version 1.7.2. So, the generation of the execute file is ok, I run the command 'make' and I got the pptp file. Now I have to run the command 'make install' to install the software, but it stops at the... (3 Replies)
Discussion started by: idro
3 Replies

4. UNIX for Dummies Questions & Answers

Difference between configure/make/make install.

Hi, While installation of apache on linux, we perform the below tasks. 1) Untar 2) configure 3) make 4) make install. I wanted to understand the difference and working of configure/make/make install. Can any one help me understanding this? Thanks in advance. (1 Reply)
Discussion started by: praveen_b744
1 Replies

5. Solaris

Gani Network Driver Won't Install - make: Fatal error: Don't know how to make targ...

I attached a README file that I will refer to. I successfully completed everything in the README file until step 4. # pwd /gani/gani-2.4.4 # ls COPYING Makefile.macros gem.c Makefile Makefile.sparc_gcc gem.h Makefile.amd64_gcc ... (1 Reply)
Discussion started by: Bradj47
1 Replies

6. UNIX for Dummies Questions & Answers

problems using 'make' install

I am tring to install DBD::Oracle on Solaris 9 box, I issued command type cc type gcc but both are not found. then i manually searched for gcc, i found it and create a symbolic link to it in my directory. $ perl Makefile.pl (works ok) $ make (retuns error below) LD_RUN_PATH="" cc -G... (1 Reply)
Discussion started by: jameskay
1 Replies

7. Linux

Error in issuing a make and make install

Hi, Recently I install a package and try to do a make and make install. However, in the make it gives me below error:- make:Nothing to be done for 'install-exec-am' make:Nothing to be done for 'install-data-am' Can anyone please explain to me what does this mean? I have been trying... (1 Reply)
Discussion started by: ahjiefreak
1 Replies

8. Solaris

Problems with Make

I seem to be having some problems using make - I am getting the following error code: make: Fatal error: Command failed for target `machine.o' So far I have tried to install top from the tar file. I gunzip the file - and then used tar xvf. This all works fine but i then use the make command... (1 Reply)
Discussion started by: frustrated1
1 Replies

9. UNIX for Advanced & Expert Users

Problems with gnu make

I am running a make file through the gnu make tool and i am getting the following error jsh1035c:/users/egate453/admegate/kapil/samples $ make -f GNUmakefile queue_c make -f ./GNUmakefile queue_c in_objdir=1 build_root=/users/egate453/admegate/kapil/samples make: Entering directory... (2 Replies)
Discussion started by: handak9
2 Replies

10. UNIX for Advanced & Expert Users

'make' problems (compliation problems?)

I'm trying to compile and install both most recent version of 'make' and the most recent version of 'openssh' on my Sparc20. I've run into the following problems... and I don't know what they mean. Can someone please help me resolve these issues? I'm using the 'make' version that was... (5 Replies)
Discussion started by: xyyz
5 Replies

Featured Tech Videos