Installation with no /usr access

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Installation with no /usr access
# 1  
Old 02-07-2008
Installation with no /usr access

I want to install a software program on a computer cluster that I have remote access to. I don't have /usr access on the cluster. I am allowed to put software on the cluster, apparently not on /usr tree.
What folder should I put program executables into so that I can access them from all my other folders on the /home/myfolder tree?
# 2  
Old 02-07-2008
That is normal -- writing to /usr is a huge security risk.

If you are the only one running the code, then put it in your home directory. Otherwise it will have to go someplace publicly accessible. Each site has its own guidelines. You need to put the binaries where they will not get clobbered by cleanup routines.
/var/tmp and /tmp are possible.

Some places will allow you to submit your code to the sysadmin, and after secuity analysis, have him compile it into something like /usr/local/bin or maybe /opt/local/bin.
# 3  
Old 02-07-2008
Thanks Jim,
I think I knew about the restricted access reasoning, but when I install to /var or /tmp/var how do I access the executables?

I just get an error that says
-bash: merlin: command not found
when I try to execute a command in a folder other than where I put the executables.

# 4  
Old 02-07-2008
You'll need to either add the installation dir to your path or just run it fully qualified.

In the case of /var/tmp or /tmp, whatever you do, do NOT add these to your path, it's really dangerous as you could inadvertantly execute any code put there by anyone.

If it's only you using it, I'd suggest making a bin dir (or something similar) under your home directory and adding that to (the end of) your PATH environment variable (under sh, PATH="${PATH}:/home/you/bin" ; export PATH)

If you really want to use /var/tmp or /tmp, keep in mind that those directories are usually cleaned out periodically so your data will eventually be removed without warning. If you still want to procede, you can run things in there by typing /var/tmp/programname (or /var/tmp/whatever_subdir_you_used/programname)
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. OS X (Apple)

OSX: ./Users/myname OR. /usr/myname ? 1) what is the truth on UNIX ./usr/ directory.

OSX uses its own directory strecture on the BSD core, for example /Users/Bob_Alice/. but legacy Unix structure /usr/... remains. Adding confustion, some Unix books say /usr/ was never intended for specific users. and others show it being used for Bor or Alice. I am not sure where to put my third... (5 Replies)
Discussion started by: michaelayres
5 Replies

2. Proxy Server

How to use Squid on Linux to control certain IP to access Web Server and certain IP cannot access?

Dear all experts here, :) I would like to install a proxy server on Linux server to perform solely to control the access of Web server. In this case, some of my vendor asked me to try Squid and I have installed it onto my Linux server. I would like know how can I set the configuration to... (1 Reply)
Discussion started by: kwliew999
1 Replies

3. BSD

FreeBSD: /usr/bin/ld not looking in /usr/local/lib

I'm not sure if this is the default behavior for the ld command, but it does not seem to be looking in /usr/local/lib for shared libraries. I was trying to compile the latest version of Kanatest from svn. The script seems to exit without too much trouble: $ ./ checking... (2 Replies)
Discussion started by: AntumDeluge
2 Replies

4. Linux

Office installation on Linux without root access

Need Assistance in finding office open source for REDHAT linux. Need to be compiled as non-root user . If possible I also need instructions for installation. (6 Replies)
Discussion started by: ajayram_arya
6 Replies

5. Solaris

samba read write access to owner and no access to other users

Hi All, I want to configure samba share permission so that only directory creator/owner has a read and write permission and other users should not have any read/write access to that folder.Will that be possible and how can this be achieved within samba configuration. Regards, Sahil (1 Reply)
Discussion started by: sahil_shine
1 Replies

6. Windows & DOS: Issues & Discussions

seteuid access denied - openSSH installation

Hi, I have installed openssh in one of my windows servers following SUA community guidelines. I can successfully install and generate RSA DSA keys. But I cannot SSH to server from my Solaris machine. Below is the output from ssh -v <server>. Also I tried to SSH from the K-shell to localhost... (0 Replies)
Discussion started by: vkk
0 Replies

7. Solaris

How do I link ld in /usr/ucb/ to /usr/ccs/bin?

Hi all, below is the problem details: ora10g@CNORACLE1>which ld /usr/ucb/ld ora10g@CNORACLE1>cd /usr/ccs/bin ora10g@CNORACLE1>ln -s /usr/ucb/ld ld ln: cannot create ld: File exists ora10g@CNORACLE1> how to link it to /usr/ccs/bin? (6 Replies)
Discussion started by: SmartAntz
6 Replies

8. Solaris

installation of Solaris: installation bypasses network config.

hello solaris friends, I've tried installing Sun Solaris 10.0, but everytime it seems to bypass the network config. screen that looks similar to's the url: I'm able to install it all the way through but I get no... (2 Replies)
Discussion started by: cadmiumgreen
2 Replies

9. UNIX for Dummies Questions & Answers

Need help to access/mount so to access folder/files on a Remote System using Linux OS

Hi I need to access files from a specific folder of a Linux system from an another Linux System Remotely. I know how to, Export a folder on One SCO System & can access the same by using Import via., NFS in the Sco Unix SVR4 System using the scoadmin utility. Also, I know to use mount -t ... (2 Replies)
Discussion started by: S.Vishwanath
2 Replies
Login or Register to Ask a Question