Dusty pizza box, help!

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Dusty pizza box, help!
# 1  
Old 03-05-2002
Question Dusty pizza box, help!

I picked up a Sparcstation 2 at property disposition and strangely enough it boots and attempts to load SunOS 4.1.4 (Solaris 2.1 from what I understand). Before the OS can finish loading it gives an .unknown error in reboot fsck . Then it says WARNING - file systems have NOT been remounted read-write. Use fsck to fix any file system problems, rebooting the system if any problems are found with a mounted file system. After file systems have fsck'ed cleanly, you can remount file systems and finish single-user setup using "/etc/rc.single". After that it says -: stty: not found So, what exactly does this miean? I'd like to use the existing OS that is installed if I can get around it's problems, just to fool around with and learn more about Unix. The other idea I had was to load a more recent OS, suchas 2.5.1, or 2.6. Another idea would be to use some sort of version of linux, and recommendations? If I do decide to load a fresh OS, is it possible to have an INTERNET install, or would it need to be on my local network? I suppose there isn't any one single unix OS that could fit on a disk or two is there? Any help would be greatly appreciated.
# 2  
Old 03-05-2002

I have no clue what that error means, but if your thinking of trying a new OS your stuck with Solaris. From what I understand Solaris is the only OS that will work with SPARC processors. Go to www.sun.com to download the latest version for free.

For part of your other question, yes there is a version of Linux smaller than 2 discs (CD's or floppies!), its called Coyote Linux, and its only about 1 MB, there is also another version that is about 20 or 30 MB.

Sorry I couldn't give you an answer to your error problem, Im new to Unix too.


# 3  
Old 03-06-2002
There are Linux versions that work on Sun hardware. Also, check out NetBSD (I think).

The error simply means that fsck (File System ChecKer) was not able to run automatically. You have to run it manually. The reason stty was not found (It's a command), is that most likely, your /usr and other important filesystems were not mounted.

See if /etc was mounted... It should have been, at least read-only. If so, look in (it may be different for SunOS) the fstab file for a list of your normally mounted filesystems, and run fsck manually on each of them. You can find the manual page for fstab on the web here:

Hopefully, someone who better understands SunOS can help more...
# 4  
Old 03-06-2002
I tried accessing the /etc directory, but the system replies with Permission denied. I get the # sign when I try this, but when I enter a command it proceeds to the next line with the > symbol. Before the system gives the WARNING (initial message post) it tries to mount sd1g /usr/etc/fsck but it can't (there isn't a disk on that ID). Maybe there was a second disk in the machine and it was taken out before I received it? I think I'll move the disk to that ID and see what happens. After it attempts to mount the system replies with mount: giving up on: /usr Then says checking file systems /usr/etc/fsck: no such file or directory. I'm confused, maybe this is too much for a newblar like me ANY OTHER IDEAS?
# 5  
Old 03-06-2002
WOo-HOo!!! That worked! I changed the SCSI ID on the hard disk and moved it to the other scsi channel and it worked! Boots all the way to login! Now I just need to crack the login and password.... It's an old Merit server....ANY IDEAS NOW!??!?

# 6  
Old 03-07-2002
The jist of it requires booting into single-user mode, mounting at least the / filesystem, and either editing the password file and nulling out the password field for root, or by simply using:
passwd root
and changing it.

See if you can search the forum for more info...
# 7  
Old 03-07-2002
THE MOMENT OF TRUTH!!! You know you're a computer geek when you get excited about learning something new about something as cheesy as gaining access to your own computer! I really appreciate your help on this one LivinFree. I searched the forum and read a post that a german fellow made (Treunfels?). Anyway, everything I needed to know was right there! I would like to thank all those people who replied to that german guy. Neo said it best with his last reply for that post, "GOOD TEAMWORK..." (or something like that) Thanks again LivinFree!

Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. How to Post in the The UNIX and Linux Forums

Copying , renaming the file from windox box and ftp to Linux box

Hello my dear friends, Two file are auto generated from mon - fri at different directories on same windows box.Every day i have to copy the file, rename it (specific name)and ftp it to linux box specified directory. is it possible to automate this process,If yes this has to be done from windows... (1 Reply)
Discussion started by: umesh yadav
1 Replies

2. Shell Programming and Scripting

Notify when the script run(hourly)on my jump-box only when there is a failure on my remote-box

Team, Presently I have a script, which i have set up cron on one of my Jump-boxes,and gives me the output on every hourly basis,fetching the data from the remote machine.Basically it gives me the list of all active users logged and its count once we execute the script.Here the count is... (6 Replies)
Discussion started by: whizkidash
6 Replies

3. Red Hat

How to access redhat Linux box graphically from windows box?

Hi I have a linux box and need to access from windows graphically # uname -a Linux pc-l416116 2.6.18-155.el5 #1 SMP Fri Jun 19 17:06:47 EDT 2009 i686 i686 i386 GNU/Linux What components do I need to install on Linux and windows to do that? TIA (6 Replies)
Discussion started by: magnus29
6 Replies

4. Web Development

How to copy a selected value of list box into a text box in html form?

hi, i have a list box , a text box and a button in a html form. list box displays some values, when a user selects a value from the list box and press the button. the selected value should be copied to the text box value. can any1 give me a html and javascript code to do this facility. ... (1 Reply)
Discussion started by: Little
1 Replies

5. Shell Programming and Scripting

ftp file starting with particular name on Windows box to Unix box using shell script

Hello all ! I'm trying to write a shell script (bash) to ftp a file starting with particular name like "Latest_" that is present on a Windows box to UNIX server. Basically I want to set this script in the cron so that daily the new build that is posted on the Windows box can be downloaded to the... (2 Replies)
Discussion started by: vijayb4u83
2 Replies

6. Solaris

Need to copy printers from Sol8 box to Sol10 box-No luck so far

I need to copy the printers currently installed on a Sol8 box to a Sol10 box. I tried copying the printers.conf file from the Sol8 box and that worked until I went through the file and changed the server name to that of the Sol10 box. Another post on this forum suggested copying the entire... (1 Reply)
Discussion started by: todis
1 Replies

7. UNIX for Advanced & Expert Users

Access files from prev box after SSH to another box

i'm not much of an advanced unix programmer but I'm trying to write a script to access files on box1 after ssh from box 1 to box2. when ssh is invoked in the script i'm getting logged into box2 and losing complete touch with box1 which is normal i guess. but my main aim with my script is when i... (3 Replies)
Discussion started by: pharos467
3 Replies

8. Shell Programming and Scripting

Script to Reboot a linux box from a windows box

HI All, I need a script to reboot a linux box from a windows box. The script needs to run automatically whenever a sitescope alerts with an error message. Have searched for this in the forums, but could not get something relative. Pls. let me know the various alternatives we have to do... (2 Replies)
Discussion started by: Crazy_murli
2 Replies

9. UNIX for Advanced & Expert Users

How to FTP a file generated at UNIX Box to NT Box

Hi all, I am generating a file on the Unix machine , now i want to FTP the same file to the NT machine. how can i do that and the application currently upon which i am working is a JAVA based application. I need your help. regards Ruchir (2 Replies)
Discussion started by: Ruchir
2 Replies

10. UNIX for Advanced & Expert Users

VPN client (windows Box),and Server (Unix Box)

If I want to access unix box via VPN tunnel,from windows box. What sould I configure on the windows client PC, and what should I enable on the Unix Server box ? I am using Solaris V10 intel platform, and I am using windows XP, and 2003 for client (0 Replies)
Discussion started by: zillah
0 Replies
Login or Register to Ask a Question