Visit Our UNIX and Linux User Community


Installing Perl Module Term::ReadKey??? HELP!!!


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Installing Perl Module Term::ReadKey??? HELP!!!
# 1  
Old 02-28-2002
Question Installing Perl Module Term::ReadKey??? HELP!!!

I'm new to UNIX.....

I'm trying to test a software that requires Perl. I installed Perl 5.004_04 without any problem on a UNIX SCO OpenServer Machine.

The software I'm testing also requires some Perl Modules (Net::Telnet, Test::More, Net::Telnet::Cisco & Term::ReadKey).

I installed Net::Telnet & Test::More, but when I tried to install Term::ReadKey I get some error lines like this one:

In file included from ReadKey.xs:4:
/usr/local/bin/perl5/5.00404/i486-pc-sco3.2v5.0/CORE/time.h:14: time.h: No such file or directory

I checked the path and the file is in there.

The module version is 2.18

What I'm doing wrong.... What should I do?????

Please help!!!!!
# 2  
Old 02-28-2002
Re: Installing Perl Module Term::ReadKey??? HELP!!!

Quote:
Originally posted by rrivas
I'm new to UNIX.....

In file included from ReadKey.xs:4:
/usr/local/bin/perl5/5.00404/i486-pc-sco3.2v5.0/CORE/time.h:14: time.h: No such file or directory
It is possibly complaining about line 14 in time.h under CORE.
# 3  
Old 03-01-2002
one question.. after unpack perl have you run "perl makefile.pl" . If you did and you still encounter the same problem, try to visit this page http://www.perldoc.com/perl5.6/lib/Term/ReadKey.html
# 4  
Old 03-01-2002
Yes, I did run "perl Makefile.PL".... I will visit the link to see if I can solve this issue.

Thanks.
# 5  
Old 03-01-2002
I visit the site, but I just get more confused!!!!!
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #554
Difficulty: Medium
Using printf() in C, %d formats a decimal variable or literal.
True or False?

10 More Discussions You Might Find Interesting

1. Proxy Server

Problem with Installing Perl Module in Fedora 20

Hi, I have downloaded Audio::Beep. I tried to install it through CPAN but i got YAML error. Then I have tried to install it manually. I tried all the instructions provided in README file. It worked but when i am compiling , it still gives me error: # ls acct21.pl~ imap(2).pl ... (15 Replies)
Discussion started by: zak100
15 Replies

2. Solaris

Installing ZIP module for PHP

Hi Guys, I am using SOLARIS 10 and I want to install ZIP module for PHP. I went to this link http://pecl.php.net/package/zip and I choose zip-1.12.3.tgz, the latest "stable" release, and then transferred it to my server. Then I went to my path /usr/local/apache2/conf then untar the... (1 Reply)
Discussion started by: Phuti
1 Replies

3. Ubuntu

What to copy in /lib/module while installing new kernel?

I was trying to install new kernel in my backtrack which was having kernel 3.2.6. i tried installing 3.8.5. I refered to book linux kernel in nutshell i followed every step. after i rebooted (i had set new kernel in default as my backtrack doesn't display options to select while booting) it... (3 Replies)
Discussion started by: kg_gaurav
3 Replies

4. Shell Programming and Scripting

Password Protection using Term::ReadKey

Hi Friends, I execute a perl script with password as input but i wish not to print the password when i give the input. Instead when i provide the password it could be shown as "****" instead of original password. I know we can use Term::ReadKey or IO::Prompt for this, but just wanted to know if... (0 Replies)
Discussion started by: nmattam
0 Replies

5. Shell Programming and Scripting

Installing perl module

Hi, I want to install WWW:Mechanize module. Followed the following steps: 1. wget http://www.cpan.org/authors/id/C/CO/CORION/Bundle- WWW-Mechanize-Shell-0.29.tar.gz perl Makefile.PL make make test make install (Got the below message) Appending installation info to... (1 Reply)
Discussion started by: Anjan1
1 Replies

6. Shell Programming and Scripting

Installing Perl Module

Hi All, When I tried to install Math::Pari module in a AIX 5.3 server,I am getting the following error. # pwd /usr/local/bin # cd Math-Pari-2.010709 # perl Makefile.PL Did not find GP/PARI build directory around. Do you want to me to fetch GP/PARI automatically? (If you do not, you... (2 Replies)
Discussion started by: surjithss
2 Replies

7. UNIX and Linux Applications

help: error in installing perl module DBD::mysql

Hi, I am trying to install perl module DBD::mysql and don't know how to resolve the following: # make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/00base.............ok 3/5install_driver(mysql) failed: Can't load... (3 Replies)
Discussion started by: Yogesh Sawant
3 Replies

8. Shell Programming and Scripting

Can I use a Perl Module without installing it?

I am trying to write a program that will use templates, so I figured I would use the Text::Template CPAN module... ...only problem is that I cant force my "clients" to install this module, cause they are clueless. Is there anyway that I can NOT install it for the whole machine, but install it... (1 Reply)
Discussion started by: jjinno
1 Replies

9. Shell Programming and Scripting

Search term and output term in desired field

Hi All, I have an input_file below and i would like to use Perl to search for the term "aaa" and output the 3rd term in the same row as "aaa".For Example, i want to search for the term "ddd" and would want the code to ouput the 3rd term in the same row which is "fff". Can somebody help ? ... (28 Replies)
Discussion started by: Raynon
28 Replies

10. Programming

Create a Term & Run chars on this Term

hi floks ! i'd like to know how can i transmete a character or a string from my source code to a term and make it interpret or un by the shell wich is running in my term. I'd like to create a Term from my code (and get its file descriptor) and then transmete each char typed on the keyboard to... (1 Reply)
Discussion started by: the_tical
1 Replies

Featured Tech Videos