Visit Our UNIX and Linux User Community


Arrg... SunOS 5.8 i386


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers Arrg... SunOS 5.8 i386
# 1  
Old 02-15-2002
Arrg... SunOS 5.8 i386

I set up a cheap-o box here to play with...
I disabled all of my r* services, and plenty of other stuff...
(Sure does install a lot of stuff running by default!).

I use Reflections X from my NT Workstation to connect. Up until I disabled those services, it worked fairly well. Now I connect and log in to CDE, my background will flash momentarily, then I drop a juicy core file in my home directory... I am able to telnet in now although I wasn't able to before... I would get hung connections - odd. The core file is from "dtwm", but I have no idea what's causing it...

Any ideas / pointers?
# 2  
Old 02-15-2002
This is most likely due to a reference to a missing definition in the front
panel description file. This could be /usr/dt/appconfig/types/C/dtwm.fp, but
if you have done any customization of the front panel, it could be
in /etc/dt/appconfig/types/C/dtwm.fp, $HOME/.dt/types/dtwm.fp,
or perhaps $HOME/.dt/types/fp_dynamic/*.fp.

For example, if the front panel description file references an action
that is not defined in the action database, then dtwm will dump core.

Setting the resource "dtwm*useFrontPanel: False" allows the window manager
to start. However, there will, of course, be no front panel.

To fix this, you will need to locate the reference being made that does
not exist in the appropriate database.

Often times it's the case where the sdtimage.dt file is corrupt. This file
is located under /usr/dt/appconfig/types/C . This file is in the SUNWdtim
package on the CDE cd. Just readd this package with the "pkgadd" command.
thehoghunter
# 3  
Old 02-19-2002
Thank you for your reply. I'll give this a try hopefully later on tonight...

I did also notice that a few other processes (like the system monitor) had dumped core as well, and all of them do have a spot in the panel. I guess it just seems wierd that I turned off a bunch of services, and my box just dropped... (sigh) at least there's failsafe session / telnet.

Will let you know how it goes...
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #32
Difficulty: Easy
There are 9 pins in a basic serial port.
True or False?

10 More Discussions You Might Find Interesting

1. SCO

I need a box to run SCO 3.2 5.0.5 i386 with...

need it to be able to run Seagate STT8000A tape drive. Any suggestions where to go. (5 Replies)
Discussion started by: Mike Gomes
5 Replies

2. Solaris

Ethereal Solaris i386

Hello guys, I am trying to install ethereal in Solaris10 based on i386 system. But i can find only packet for sparc. Any idea? Thanks a lot! (2 Replies)
Discussion started by: @dagio
2 Replies

3. UNIX for Advanced & Expert Users

ioctl() system call on Linux-i386

Greetings, Please help me with the following : Where can I find what means exactly and how to use each of the second argument of the ioctl() system call in Linux/386 : FIOxxx (file IOCTL requests), SIOxxx (socket IOCTL requests), TCxxx TIOxxx (terminal IOCTL requests) ? ... (1 Reply)
Discussion started by: aigoia
1 Replies

4. Solaris

Solaris I386 ifconfig devices ??

I want to configure my Network card. On solaris 9 i386. How to know the good Network device. I use prtconf to display the device list. I'm searching the device name. Like ifconfig device_name plumb thanks you (2 Replies)
Discussion started by: simquest
2 Replies

5. UNIX for Advanced & Expert Users

Migration of binary file from Sunos 5.8 to Sunos 5.9

I have compiled binary file using "cc" on SunOS 5.8 and the same binary file i have copied to SunOS 5.9 and it is giving me core dump error.I want to know whether migration of compiled code from lower version to higer version created this problem. how can i solve this problem.I am pasting the core... (1 Reply)
Discussion started by: Arvind Maurya
1 Replies

6. UNIX for Dummies Questions & Answers

Installing php-4.3.3-2.i386.rpm

Ok when i try to run the install the is what i get How can i fix this can anyone help (8 Replies)
Discussion started by: Blackrose
8 Replies

7. Filesystems, Disks and Memory

UNIX -openbsd /i386

UNIX -openbsd /i386 I think i have messed up with the bios or something. i am seeing this message as soon as the system boots up //////////////////////////////////////////// Password = Please Enter The System Logon: /////////////////////////////////////////// First i though that it... (1 Reply)
Discussion started by: hrk2006
1 Replies

8. BSD

UNIX -openbsd /i386

I think i have messed up with the bios or something. i am seeing this message as soon as the system boots up //////////////////////////////////////////// Password = Please Enter The System Logon: /////////////////////////////////////////// First i though that it was due to changing the... (1 Reply)
Discussion started by: hrk2006
1 Replies

9. UNIX for Dummies Questions & Answers

What are the differences among i386, i486, i586?

I know it is a silly question, but when I tried to order or download some linux distributions, they have the options for i386, i486, i586, alpha, IA64, M68K, etc.. Does i386 mean intel-80386? Why when I told the webmaster that my pc is intel piii 933, he told me to download the i386 version?... (3 Replies)
Discussion started by: HOUSCOUS
3 Replies

10. UNIX for Dummies Questions & Answers

Solaris 8 on a i386

Hi, I am trying to installing solaris on a intel PC, but I am unable to do it. So my question is where can I find some good documents (I tried sun.com did not find any thing). If I want to dual boot between Linux and Solaris, would I install solaris first if so why? Thanks alot ... (5 Replies)
Discussion started by: chamkila
5 Replies

Featured Tech Videos