Visit Our UNIX and Linux User Community


I changed PS1 and now ....


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers I changed PS1 and now ....
# 1  
Old 02-11-2002
Data I changed PS1 and now ....

Hello

I am using Debain Potato and I changed the PS1. When I log in locally everythink is fine, except that when I enter a long row without hitting enter, then it word wraps automatically. And it does it not at the end of the row, it does it in the middle of the row!
It also does not writes the following string in a new row. It overwrites the same row!

I have no clue what I did wrong.
Here is my PS1:

Quote:
PS1="[\!][\u@\h^[[1;34;47m \W]^[[0;30;47m\$ "
Hope you can help me.

Greetings
Marcus
# 2  
Old 02-12-2002
First, go back to a traditional prompt and see what response you get.

Or try one like this just for troubleshooting purposes.
ie. PS1="`hostname`-$LOGNAME:\${PWD#*}> "


Next, what are you trying to accomplish with this prompt? Please explain...

Smilie
# 3  
Old 02-12-2002
Okay, I put

Quote:
PS1="`hostname`-$LOGNAME:\${PWD#*}> "
this as my PS1.

This is working.

What I am trying to do is to get some color into it. So I can easily tell the what the promt is and what is not. I am using mostly the command line interface. And I can make it look better. Smilie

So, do you know a different way to put color into the promt?
# 4  
Old 02-12-2002
What type of window or Telnet session do you use?

If it is a telnet session you should be able to change the colors from the toolbar at the top of the telnet session.

I use a Chameleon Terminal. What type of terminal do you use?



Smilie
# 5  
Old 02-12-2002
I am using Tera Term Pro.

And what am I doing when I am working locally on it? So, it must work somehow. :-(
I even tried it on Red Hat 7 but there is the same effect.
# 6  
Old 02-12-2002
From the Korn Shell FAQ
Quote:
Q2. Why does the screen width not function correctly when non-printing characters are in my prompt?
A2. The shell computes the screen width by subtracting the width of the prompt from the screen width. To account for non-printing characters, for example escape sequences that display in the title bar, follow these characters with a carriage return. The shell starts recomputing the width after each carriage return.
In your case, you will need to figure out how many of your characters are non-printing and inbed a c/r at the right point to correct the calculation of characters remaining on the line.
# 7  
Old 02-13-2002
@ Perderabo

What do you mean by
Quote:
c/r
???
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #203
Difficulty: Medium
Perl is not an interpreted language.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

PS1 - change

Hello I am attempting to generate a bash scrip that prompts me at loggin to change my PS1 - However, I am running into an issue w/ the code. #!/bin/bash #the point of this script is to that it automates and changes my prompts every day msg1="What do you feel like adding today :" echo... (11 Replies)
Discussion started by: D'go
11 Replies

2. Shell Programming and Scripting

Script to echo "File permissions or ownership changed from required " when accidentally changed.

Hi All, I have to work in the late nights some times for server maintenance and in a hurry to complete I am accidentally changing ownership or permission of directories :( which have similar names ( /var in root and var of some other directory ).:confused: Can some one suggest me with the... (1 Reply)
Discussion started by: shiek.kaleem
1 Replies

3. Shell Programming and Scripting

Changing PS1

I have coded PS1 as shown, producing the following result when writing on the command line ┌─ cdl └──╼ make tracepdf2d If I make an error in the command an ✗ is printed ┌─ ✗ cdl └──╼ ls-a ls-a: command not found My problem is that if I just press enter, I do not want to have the... (3 Replies)
Discussion started by: kristinu
3 Replies

4. UNIX for Dummies Questions & Answers

Setting PS1

I have set PSI for my prompt using the following command: PS1="${debian_chroot:+($debian_chroot)}\\u@\h:\\\w\a]\ "which produces chrisd@pguk:~]I want to include [ in the beginning but cannot understand the way to do this. Also I want to show only the current directory, not the whole... (4 Replies)
Discussion started by: kristinu
4 Replies

5. Shell Programming and Scripting

PS1 challenge

Ok then i Have a challenge for you : Give me PS1 so that it always display the least 2 levels of directory (except if i am above of course) I want it this way : so if i go to / /home/ /home/user /home/user/whatever /home/user/whatever1/whatever2 my PS1 should respectively... (12 Replies)
Discussion started by: ctsgnb
12 Replies

6. Shell Programming and Scripting

Help with Export PS1 I think :-0

I am 100% new to Unix and trying to learn. This is my first time even touching a script in Unix. We have the following variable script that I am trying to run.... ################################## ###### variable test### ################################## Hostname=`hostname`... (3 Replies)
Discussion started by: LRoberts
3 Replies

7. UNIX for Dummies Questions & Answers

PS1 prompt

please advise what's wrong with this command ? PS1="`hostname`:`who am i | cut -d " " -f1`:>>" trying to make the PS1 prompt look like : machine_name:username:>> thank you (4 Replies)
Discussion started by: venhart
4 Replies

8. Shell Programming and Scripting

To change PS1 for every one second

I want to change the PS1 prompt with current time. I want the PS1 to update for every one second. I write a Script. PS1='\T' but it updates after i press enter key.I want to update without pressing enter key. can any one help me? (0 Replies)
Discussion started by: lakshmananindia
0 Replies

9. UNIX for Dummies Questions & Answers

PS1 problem

can anyone tell me how to change the $ prompt by calling a variable. Say for example i called a var 'enable' I and would like the $ prompt to change to a phrase like 'my prompt' any help would be great (1 Reply)
Discussion started by: pg080394
1 Replies

10. UNIX for Advanced & Expert Users

PS1 variable

I want to set my prompt to something more descriptive than a plain old $, so I set the PS1 variable as such: PS1="" Which changes the prompt correctly, but when I change directories, it does not update the prompt. So I tried this: PS1="`pwd`>" I get the same results when changing... (2 Replies)
Discussion started by: dangral
2 Replies

Featured Tech Videos