Visit Our UNIX and Linux User Community


/dev/fb* missing


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers /dev/fb* missing
# 1  
Old 02-11-2002
/dev/fb* missing

I am trying to run openwin on Solaris 5.8, but get an error:


/dev/fb: No such file or directory
Graphics Adapter device /dev/fb is of unknown type

Fatal server error:
InitOutput: Error loading module for /dev/fb

giving up.
/usr/openwin/bin/xinit: Connection refused (errno 146): unable to connect to X
server
/usr/openwin/bin/xinit: No such process (errno 3): Server error.

I also can not do xhost + and have set the display variable...

There is no device in /dev called fb, and I want to know how you create this?
# 2  
Old 02-11-2002
Re: /dev/fb* missing

Quote:
Originally posted by heinb
I am trying to run openwin on Solaris 5.8, but get an error:
/dev/fb: No such file or directory

There is no device in /dev called fb, and I want to know how you create this?
This is what the /dev/fb* devices are on my system:
Quote:
redhead@rimfaxe{51} ~> uname -a
SunOS rimfaxe 5.8 Generic_108528-05 sun4u sparc SUNW,Ultra-250
redhead@rimfaxe{52} ~> ll /dev/fb*
lrwxrwxrwx 1 root 9 Aug 30 17:34 /dev/fb0 -> fbs/gfxp0

/dev/fbs:
total 1
lrwxrwxrwx 1 root 42 Aug 30 17:34 gfxp0 -> ../../devices/pci@1f,4000/TSI,gfxp@4:gfxp0
redhead@rimfaxe{53} ~> ll /devices/pci@1f,4000/TSI,gfxp@4:gfxp0
crw------- 1 root 68, 0 Aug 30 17:34 /devices/pci@1f,4000/TSI,gfxp@4:gfxp0
This means, the actual /dev/fb0 is only a link to /dev/fbs/gfxp0, which also is a link to /devices/pci@1f,400/TSI,gfxp@4:gfxp0
The device is a charactor device, which you would make with the mknod(1M) command. And from my output, you can see, the device has a major of 68 and a minor of 0, so if you were to create this specific device the command would be:
mknod /devices/pci@1f,4000/TSI,gfxp@4:gfxp0 c 68 0
# 3  
Old 02-11-2002
Thanks for the suggestion. I think something is seriously wron on this system...

root@finoradev # mknod /devices/pci@1f,4000/TSI,gfxp@4:gfxp0 c 68 0
mknod: No such file or directory

There are also no /dev/gfx* devices in that dir? It looks like a complete setup for the graphics devices needs to be done.
# 4  
Old 02-11-2002
It's rather dangerous to just use the mknod command directly like that.

There is a devlinks utility that will recreate the symbolic links in the /dev directory. There is also a drvconfig utility that can create the stuff in the /devices utility.

Sun has a notion of a "reconfiguation" reboot and I think that this is the safest approach for a start. You just "touch /reconfigure" and then you reboot. The start-up scripts notice the file /reconfigure and run stuff like drvconfig and devlinks automatically.
# 5  
Old 02-11-2002
This looks like another post from you. I replied to it concerning if this is a new installation. There is documented for Solaris 7 and below getting this error if you built the system without the proper OEM support.

if the client was installed from an OS Service that did
not include OEM support, the system may not have the proper packages
to run OpenWindows or CDE. The symptom of this problem is an error message similar the following, when attempting to start a windowing system:

/dev/fb: No such file or directory
Graphics Adapter device /dev/fb is of unknown type

The fix is to reload the OS with the proper OEM support -

In order to avoid the above stated problems, the following
recommendations for client configuration must be applied:

1. The easiest solution is to remove the OS Service. Then readd the
OS Service selecting the "Entire Distribution + OEM" as the
cluster type. The Entire Distribution + OEM cluster
will install all the required packages. This is more convenient
than adding individual packages especially if more clients are
going to be added at a later date.
thehoghunter
# 6  
Old 02-12-2002
Thank you very much for the help! I will give it a go.
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #133
Difficulty: Easy
The first prototypes of Linux were publicly released in 1991.
True or False?

10 More Discussions You Might Find Interesting

1. HP-UX

Dev/urandom and dev/random missing in HP-UX

Hi, In our HP-UX B.11.11. I could not find dev/urandom and dev/random Are all pseudo-devices implemented as device drivers, or in need to run /configure some package to install the package to have dev/urandom. Please help (4 Replies)
Discussion started by: rashi
4 Replies

2. Red Hat

Changing grub from /dev/sda to /dev/sdb

Hi, Please suggest steps to change grub from /dev/sda to /dev/sdb, (1 Reply)
Discussion started by: manoj.solaris
1 Replies

3. Shell Programming and Scripting

Automating partitioning setup of /dev/sda on /dev/sdc

Objective: To recreate the partitioning setup of /dev/sda on /dev/sdc How would I parse the below information and initialize variables (an array?) that can be used to build sgdisk commands in a script, regardless of the number of partitions? Something along the lines of: sgdisk -n... (12 Replies)
Discussion started by: RogerBaran
12 Replies

4. Solaris

Lun remove, stuck in /dev/dsk and /dev/rdsk

So, we removed a LUN from the SAN and the system is refusing to remove the references to it in the /dev folder. I've done the following: devfsadm -Cv powermt -q luxadm -e offline <drive path> luxadm probe All those commands failed to remove the path. The drive stills shows up as <drive... (13 Replies)
Discussion started by: DustinT
13 Replies

5. SuSE

/dev/sg7 missing

Hello all. I have a device thats suposed to be /dev/sg7 but when I do "ls -laF /dev/sg*" all sgXX are there from 0 to 15 except 7. what is going wrong:mad:. Please its urgent:wall: (1 Reply)
Discussion started by: eXadra
1 Replies

6. Solaris

Size missing on /dev/dsk/c0t0d0s3

Our used size is 83 gb. Total of the folders and documents size is46,2 gb. 83-46=37 gb. Where is my space. Where was lost? Could you please I need your opinions? {root}/space>du -s -h * 308K alaerrm-jprof 1K argerela 20G baerckup_in 1.8G cererm 28M ecerlipselink ... (8 Replies)
Discussion started by: getrue
8 Replies

7. AIX

/dev/rmt devices are missing

Hello, I attached a tape drive to one of my partitions but i cannot find the device. I run the command lsdev|grep rmt but i dont get anything in return. When i run lsslot -c slot i can see the slot number and the device that belongs to the tape drive but i cannot find any rmt files in /dev.... (6 Replies)
Discussion started by: omonoiatis9
6 Replies

8. Ubuntu

/dev/ttyb missing from UBUNTU

HI All I am doing first steps in debugging with GDB. I have been suggested to redirect output to another terminal using the command using tty /dev/ttyb I had a look at my ubuntu doing ls /dev/tty* and I cannot find this ttyb. What is it and how to achieve the same thing? I am... (0 Replies)
Discussion started by: manustone
0 Replies

9. Solaris

What is /dev/tty /dev/null and /dev/console

Hi, Anyone can help My solaris 8 system has the following /dev/null , /dev/tty and /dev/console All permission are lrwxrwxrwx Can this be change to a non-world write ?? any impact ?? (12 Replies)
Discussion started by: civic2005
12 Replies

10. AIX

missing /dev/ipldevice

Hello I was doing a mksysb and was given an error message that my /dev/ipldevice was missing. when i do an lslv -m hd5 i get the following output: LP PP1 PV1 PP2 PV2 PP3 PV3 0001 0001 hdisk0 0002 0002 hdisk0 I check other... (3 Replies)
Discussion started by: mhenryj
3 Replies

Featured Tech Videos